summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-05-25 18:04:24 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-05-25 18:04:24 +0000
commit07799304be5bb342f14c5609c40ae9ff8f9a2603 (patch)
tree2ab23e657911c20856a81a7be1380a9b69f716ac /sys-libs
parentAutomated update. (diff)
downloadgentoo-2-07799304be5bb342f14c5609c40ae9ff8f9a2603.tar.gz
gentoo-2-07799304be5bb342f14c5609c40ae9ff8f9a2603.tar.bz2
gentoo-2-07799304be5bb342f14c5609c40ae9ff8f9a2603.zip
Fix build for musl. Bug #550298.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcap-ng/ChangeLog6
-rw-r--r--sys-libs/libcap-ng/files/libcap-ng-0.7.5-add-unistd_h.patch20
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.7.5.ebuild3
3 files changed, 27 insertions, 2 deletions
diff --git a/sys-libs/libcap-ng/ChangeLog b/sys-libs/libcap-ng/ChangeLog
index 660c801f28c3..6dd3084a38db 100644
--- a/sys-libs/libcap-ng/ChangeLog
+++ b/sys-libs/libcap-ng/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcap-ng
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.77 2015/05/11 10:00:25 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.78 2015/05/25 18:04:24 blueness Exp $
+
+ 25 May 2015; Anthony G. Basile <blueness@gentoo.org>
+ +files/libcap-ng-0.7.5-add-unistd_h.patch, libcap-ng-0.7.5.ebuild:
+ Fix build for musl. Bug #550298.
*libcap-ng-0.7.5 (11 May 2015)
diff --git a/sys-libs/libcap-ng/files/libcap-ng-0.7.5-add-unistd_h.patch b/sys-libs/libcap-ng/files/libcap-ng-0.7.5-add-unistd_h.patch
new file mode 100644
index 000000000000..bfeef6e2da39
--- /dev/null
+++ b/sys-libs/libcap-ng/files/libcap-ng-0.7.5-add-unistd_h.patch
@@ -0,0 +1,20 @@
+utils/proc-llist.c: include <unistd.h>
+
+proc-llist.c references pid_t and uid_t types but does not include <unistd.h>. This
+works on glibc and uClibc because of the way their headers stack, but on musl (and
+possible other libc) this fails. POSIX mandates that <unistd.h> provides these. See
+Issue 6 at http://pubs.opengroup.org/onlinepubs/9699919799/basedefs/unistd.h.html.
+
+Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
+
+diff -Nuar libcap-ng-0.7.5.orig/utils/proc-llist.c libcap-ng-0.7.5/utils/proc-llist.c
+--- libcap-ng-0.7.5.orig/utils/proc-llist.c 2015-02-18 17:13:33.000000000 -0500
++++ libcap-ng-0.7.5/utils/proc-llist.c 2015-05-25 13:39:32.196624248 -0400
+@@ -24,6 +24,7 @@
+ #include "config.h"
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #include "proc-llist.h"
+
+ void list_create(llist *l)
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.5.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.5.ebuild
index 6a5abf778854..9532eaa878cf 100644
--- a/sys-libs/libcap-ng/libcap-ng-0.7.5.ebuild
+++ b/sys-libs/libcap-ng/libcap-ng-0.7.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.7.5.ebuild,v 1.1 2015/05/11 10:00:25 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.7.5.ebuild,v 1.2 2015/05/25 18:04:24 blueness Exp $
EAPI=5
@@ -25,6 +25,7 @@ DEPEND="${RDEPEND}
python? ( >=dev-lang/swig-2 )"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-add-unistd_h.patch
sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
autotools-utils_src_prepare