summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-19 22:52:55 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-19 22:52:55 +0000
commit0318b72f5621b9ebd2944e9a139d284a115fc3ee (patch)
tree031e9c5c429d6434b941fd7c12c371b28ffb29ac /sys-libs
parentStable on x86, bug #151879. (diff)
downloadgentoo-2-0318b72f5621b9ebd2944e9a139d284a115fc3ee.tar.gz
gentoo-2-0318b72f5621b9ebd2944e9a139d284a115fc3ee.tar.bz2
gentoo-2-0318b72f5621b9ebd2944e9a139d284a115fc3ee.zip
make sure $jobs is set to a fallback value when running locale-gen
(Portage version: 2.1.2_pre3-r5)
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-2.3.6-r5.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.4-r4.ebuild4
-rw-r--r--sys-libs/glibc/glibc-2.5.ebuild4
3 files changed, 6 insertions, 6 deletions
diff --git a/sys-libs/glibc/glibc-2.3.6-r5.ebuild b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
index 2f1a19374c01..e5ccd91484c9 100644
--- a/sys-libs/glibc/glibc-2.3.6-r5.ebuild
+++ b/sys-libs/glibc/glibc-2.3.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.6 2006/10/19 20:29:13 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.3.6-r5.ebuild,v 1.7 2006/10/19 22:52:55 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -541,7 +541,7 @@ toolchain-glibc_pkg_postinst() {
fi
local x jobs
for x in ${MAKEOPTS} ; do [[ ${x} == -j* ]] && jobs=${x#-j} ; done
- locale-gen -j ${jobs} --config "${locale_list}"
+ locale-gen -j ${jobs:-1} --config "${locale_list}"
fi
echo
diff --git a/sys-libs/glibc/glibc-2.4-r4.ebuild b/sys-libs/glibc/glibc-2.4-r4.ebuild
index 3cdb7566ce4c..54e808c3000b 100644
--- a/sys-libs/glibc/glibc-2.4-r4.ebuild
+++ b/sys-libs/glibc/glibc-2.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.4 2006/10/07 04:42:37 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.4-r4.ebuild,v 1.5 2006/10/19 22:52:55 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -559,7 +559,7 @@ toolchain-glibc_pkg_postinst() {
fi
local x jobs
for x in ${MAKEOPTS} ; do [[ ${x} == -j* ]] && jobs=${x#-j} ; done
- locale-gen -j ${jobs} --config "${locale_list}"
+ locale-gen -j ${jobs:-1} --config "${locale_list}"
fi
echo
diff --git a/sys-libs/glibc/glibc-2.5.ebuild b/sys-libs/glibc/glibc-2.5.ebuild
index 5351d55298a8..56ac3046b854 100644
--- a/sys-libs/glibc/glibc-2.5.ebuild
+++ b/sys-libs/glibc/glibc-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.8 2006/10/19 00:24:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.5.ebuild,v 1.9 2006/10/19 22:52:55 vapier Exp $
# Here's how the cross-compile logic breaks down ...
# CTARGET - machine that will target the binaries
@@ -540,7 +540,7 @@ toolchain-glibc_pkg_postinst() {
fi
local x jobs
for x in ${MAKEOPTS} ; do [[ ${x} == -j* ]] && jobs=${x#-j} ; done
- locale-gen -j ${jobs} --config "${locale_list}"
+ locale-gen -j ${jobs:-1} --config "${locale_list}"
fi
echo