summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-02-07 16:10:52 +0000
committerAchim Gottinger <achim@gentoo.org>2001-02-07 16:10:52 +0000
commitee9370024399e437cc5bf9059862f90092726ddb (patch)
treecfedc7627885a81bc93880532501da76c862d323 /sys-libs/zlib
parentMaintainence and FHS 2.1 fixes for RC4 (diff)
downloadgentoo-2-ee9370024399e437cc5bf9059862f90092726ddb.tar.gz
gentoo-2-ee9370024399e437cc5bf9059862f90092726ddb.tar.bz2
gentoo-2-ee9370024399e437cc5bf9059862f90092726ddb.zip
Maintainence and FHS 2.1 fixes for RC4
Diffstat (limited to 'sys-libs/zlib')
-rw-r--r--sys-libs/zlib/zlib-1.1.3-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-libs/zlib/zlib-1.1.3-r2.ebuild b/sys-libs/zlib/zlib-1.1.3-r2.ebuild
new file mode 100644
index 000000000000..aa2d35c84db3
--- /dev/null
+++ b/sys-libs/zlib/zlib-1.1.3-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/zlib/zlib-1.1.3-r2.ebuild,v 1.1 2001/02/07 16:10:52 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Standard (de)compression library"
+SRC_URI="ftp://ftp.freesoftware.com/pub/infozip/zlib/${A}"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ try ./configure --shared --prefix=/usr
+ try make ${MAKEOPTS}
+ try make test
+ try ./configure --prefix=/usr
+ try make ${MAKEOPTS}
+}
+
+src_install() {
+
+ into /usr
+ dodir /usr/include
+ insinto /usr/include
+ doins zconf.h zlib.h
+
+ dolib libz.so.1.1.3
+ dolib libz.a
+ dosym libz.so.1.1.3 /usr/lib/libz.so
+ dosym libz.so.1.1.3 /usr/lib/libz.so.1
+
+ doman zlib.3
+ dodoc FAQ README ChangeLog
+ docinto txt
+ dodoc algorithm.txt
+}
+