summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-11-04 16:25:06 +0000
committerMike Frysinger <vapier@gentoo.org>2009-11-04 16:25:06 +0000
commite12ecdff328c5abde5c147cc1c21b55caed2d635 (patch)
tree4dbc03dc91b9a8427cea2af7fc7a075f4a51fcb9 /sys-libs/uclibc/uclibc-0.9.30.1-r1.ebuild
parentx86 stable, bug #214397 (diff)
downloadgentoo-2-e12ecdff328c5abde5c147cc1c21b55caed2d635.tar.gz
gentoo-2-e12ecdff328c5abde5c147cc1c21b55caed2d635.tar.bz2
gentoo-2-e12ecdff328c5abde5c147cc1c21b55caed2d635.zip
Dont try installing ldd/ldconfig utils when shared library support is disabled #291787 by Petric Frank.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/uclibc/uclibc-0.9.30.1-r1.ebuild')
-rw-r--r--sys-libs/uclibc/uclibc-0.9.30.1-r1.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/sys-libs/uclibc/uclibc-0.9.30.1-r1.ebuild b/sys-libs/uclibc/uclibc-0.9.30.1-r1.ebuild
index a4355b6db390..337e70488776 100644
--- a/sys-libs/uclibc/uclibc-0.9.30.1-r1.ebuild
+++ b/sys-libs/uclibc/uclibc-0.9.30.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.30.1-r1.ebuild,v 1.6 2009/09/23 22:07:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc/uclibc-0.9.30.1-r1.ebuild,v 1.7 2009/11/04 16:25:06 vapier Exp $
#ESVN_REPO_URI="svn://uclibc.org/trunk/uClibc"
#inherit subversion
@@ -133,6 +133,13 @@ set_opt() {
sed -i -e "/^\# $1 is not set/d" -e "/^$1=.*/d" .config
echo "$1=$2" >> .config
}
+get_opt() {
+ (
+ unset $1
+ . ${2:-"${S}"/.config}
+ echo ${!1}
+ )
+}
src_unpack() {
[[ -n ${ESVN_REPO_URI} ]] \
@@ -341,7 +348,7 @@ src_install() {
# system headers correctly. See gcc/doc/gccinstall.info
if [[ ${CTARGET} != ${CHOST} ]] ; then
dosym usr/include /usr/${CTARGET}/sys-include
- if ! just_headers ; then
+ if ! just_headers && [[ -n $(get_opt HAVE_SHARED) ]] ; then
newbin utils/ldconfig.host ${CTARGET}-ldconfig || die
newbin utils/ldd.host ${CTARGET}-ldd || die
fi