summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-12-11 16:46:21 +0000
committerMike Frysinger <vapier@gentoo.org>2005-12-11 16:46:21 +0000
commitc72d2f8845d58d7014a624d63f8172eceaa19f7d (patch)
tree2d4192f31e8ad975fece92eb4b373e51174d80d6 /sys-libs/uclibc++/uclibc++-0.1.12.ebuild
parentold (diff)
downloadgentoo-2-c72d2f8845d58d7014a624d63f8172eceaa19f7d.tar.gz
gentoo-2-c72d2f8845d58d7014a624d63f8172eceaa19f7d.tar.bz2
gentoo-2-c72d2f8845d58d7014a624d63f8172eceaa19f7d.zip
Version bump.
(Portage version: 2.0.53)
Diffstat (limited to 'sys-libs/uclibc++/uclibc++-0.1.12.ebuild')
-rw-r--r--sys-libs/uclibc++/uclibc++-0.1.12.ebuild74
1 files changed, 74 insertions, 0 deletions
diff --git a/sys-libs/uclibc++/uclibc++-0.1.12.ebuild b/sys-libs/uclibc++/uclibc++-0.1.12.ebuild
new file mode 100644
index 000000000000..d787e5893c74
--- /dev/null
+++ b/sys-libs/uclibc++/uclibc++-0.1.12.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/uclibc++/uclibc++-0.1.12.ebuild,v 1.1 2005/12/11 16:46:21 vapier Exp $
+
+inherit eutils toolchain-funcs
+
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="embedded C++ library"
+HOMEPAGE="http://cxx.uclibc.org/"
+SRC_URI="http://cxx.uclibc.org/src/uClibc++-${PV}.tbz2"
+
+LICENSE="GPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+ && SLOT="${CTARGET}" \
+ || SLOT="0"
+KEYWORDS="~arm ~ppc ~x86"
+IUSE="debug static"
+
+DEPEND=""
+
+S=${WORKDIR}/uClibc++
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ make defconfig || die "defconfig failed"
+
+ local target
+ case $(tc-arch ${CTARGET}) in
+ arm) target="arm";;
+ mips) target="mips";;
+ ppc) target="powerpc";;
+ x86) target="i386";;
+ *) die "$(tc-arch ${CTARGET}) lists no defaults :/";;
+ esac
+
+ sed -i \
+ -e '/^UCLIBCXX_RUNTIME_PREFIX=/d' \
+ -e '/^TARGET_'${target}'/d' \
+ .config
+
+ echo "UCLIBCXX_RUNTIME_PREFIX=\"/usr/${CTARGET}\"" >> .config
+ echo "TARGET_${target}=y" >> .config
+ use debug && echo "CONFIG_DODEBUG=y" >> .config
+
+ yes "" | make oldconfig || die "oldconfig failed"
+
+ # has to come after make oldconfig, else it will be disabled
+ echo "BUILD_STATIC_LIB=y" >> .config
+ if use static ; then
+ echo "BUILD_ONLY_STATIC_LIB=y" >> .config
+ fi
+}
+
+src_compile() {
+ emake -j1 ARCH_CFLAGS="${CFLAGS}" CROSS=${CTARGET}- || die "make failed"
+}
+
+src_test() {
+ make test || die "test failed"
+}
+
+src_install() {
+ make install PREFIX="${D}" || die
+ dodir /usr/bin
+ dosym /usr/${CTARGET}/bin/g++-uc /usr/bin/g++-uc
+ dodoc ChangeLog README TODO
+}