summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-09-05 20:49:21 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-09-05 20:49:21 +0000
commit122d059b1283462b77e6bc4ee675c6e71ce65422 (patch)
treeb2878d4e253557ec66f1661302aae599623cc54b /sys-libs/system-config-base/system-config-base-1.ebuild
parentStable on alpha wrt Bug #142587. (diff)
downloadgentoo-2-122d059b1283462b77e6bc4ee675c6e71ce65422.tar.gz
gentoo-2-122d059b1283462b77e6bc4ee675c6e71ce65422.tar.bz2
gentoo-2-122d059b1283462b77e6bc4ee675c6e71ce65422.zip
system-config-base-1.ebuild layout package
(Portage version: 2.1.1_rc1-r1)
Diffstat (limited to 'sys-libs/system-config-base/system-config-base-1.ebuild')
-rw-r--r--sys-libs/system-config-base/system-config-base-1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-libs/system-config-base/system-config-base-1.ebuild b/sys-libs/system-config-base/system-config-base-1.ebuild
new file mode 100644
index 000000000000..ad0f7ff318ae
--- /dev/null
+++ b/sys-libs/system-config-base/system-config-base-1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/system-config-base/system-config-base-1.ebuild,v 1.1 2006/09/05 20:49:21 dberkholz Exp $
+
+inherit eutils
+
+DESCRIPTION="system-config-* layout package"
+SRC_URI=""
+HOMEPAGE="http://www.gentoo.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/pam"
+
+S=${WORKDIR}
+
+src_install() {
+ dopamd ${FILESDIR}/config-util
+}
+
+pkg_postinst() {
+ if [ "$(stat -c%a ${ROOT}etc/default/useradd)" != "644" ] ; then
+ echo
+ ewarn
+ ewarn "Your ${ROOT}etc/default/useradd file must be world-readable"
+ ewarn " for the system-config-* utilities to work properly."
+ ewarn " If you did not change them on purpose, consider running:"
+ ewarn
+ echo -e "\tchmod 0644 ${ROOT}etc/default/useradd"
+ echo
+ fi
+}