summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2012-05-14 07:26:40 +0000
committerFabian Groffen <grobian@gentoo.org>2012-05-14 07:26:40 +0000
commitfdbc859b7d67cedefecf284d081d3270cf2d48e6 (patch)
tree614f9f7da507cf2ecfada6ca0cb4e376c545cb10 /sys-libs/slang
parentSync and update 0.8 branch with configure switches. (diff)
downloadgentoo-2-fdbc859b7d67cedefecf284d081d3270cf2d48e6.tar.gz
gentoo-2-fdbc859b7d67cedefecf284d081d3270cf2d48e6.tar.bz2
gentoo-2-fdbc859b7d67cedefecf284d081d3270cf2d48e6.zip
Fix linking on Solaris
(Portage version: 2.2.01.20430-prefix/cvs/SunOS i386)
Diffstat (limited to 'sys-libs/slang')
-rw-r--r--sys-libs/slang/ChangeLog5
-rw-r--r--sys-libs/slang/slang-2.2.4.ebuild5
2 files changed, 8 insertions, 2 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index 1525b391e7c3..a87791338be2 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/slang
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.131 2012/05/04 14:36:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.132 2012/05/14 07:26:40 grobian Exp $
+
+ 14 May 2012; Fabian Groffen <grobian@gentoo.org> slang-2.2.4.ebuild:
+ Fix linking on Solaris
04 May 2012; Alexis Ballier <aballier@gentoo.org> slang-2.2.4.ebuild:
keyword ~amd64-fbsd
diff --git a/sys-libs/slang/slang-2.2.4.ebuild b/sys-libs/slang/slang-2.2.4.ebuild
index 91c11eda0cf2..ba6a06e29667 100644
--- a/sys-libs/slang/slang-2.2.4.ebuild
+++ b/sys-libs/slang/slang-2.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.2.4.ebuild,v 1.11 2012/05/04 14:36:13 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.2.4.ebuild,v 1.12 2012/05/14 07:26:40 grobian Exp $
EAPI=4
inherit eutils
@@ -30,6 +30,9 @@ src_prepare() {
# avoid linking to -ltermcap race with some systems
sed -i -e '/^TERMCAP=/s:=.*:=:' configure || die
+ # we use the GNU linker also on Solaris
+ sed -i -e 's/-G -fPIC/-shared -fPIC/g' \
+ -e 's/-Wl,-h,/-Wl,-soname,/g' configure || die
}
src_configure() {