summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2009-08-24 23:57:00 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2009-08-24 23:57:00 +0000
commitfd9faa5ace56e509545b50764c300e514229c199 (patch)
tree4aea1b25e55b96aa83686393a0162189b57ca3fa /sys-libs/slang
parentFix bug #281442, wrong DESKTOP_SESSION set if ${HOME}/.dmrc is empty and auto... (diff)
downloadgentoo-2-fd9faa5ace56e509545b50764c300e514229c199.tar.gz
gentoo-2-fd9faa5ace56e509545b50764c300e514229c199.tar.bz2
gentoo-2-fd9faa5ace56e509545b50764c300e514229c199.zip
Version bumped. Added zlib USE flag.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/slang')
-rw-r--r--sys-libs/slang/ChangeLog7
-rw-r--r--sys-libs/slang/slang-2.2.0.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index ee2fecd87507..51f78b14f7ac 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/slang
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.100 2009/05/06 17:56:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.101 2009/08/24 23:57:00 matsuu Exp $
+
+*slang-2.2.0 (24 Aug 2009)
+
+ 24 Aug 2009; MATSUU Takuto <matsuu@gentoo.org> +slang-2.2.0.ebuild:
+ Version bumped. Added zlib USE flag.
06 May 2009; Raúl Porcel <armin76@gentoo.org> slang-2.1.4.ebuild:
arm/ia64/s390/sh/sparc stable wrt #267920
diff --git a/sys-libs/slang/slang-2.2.0.ebuild b/sys-libs/slang/slang-2.2.0.ebuild
new file mode 100644
index 000000000000..f81a517c3a00
--- /dev/null
+++ b/sys-libs/slang/slang-2.2.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.2.0.ebuild,v 1.1 2009/08/24 23:57:00 matsuu Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="a portable programmer's library designed to allow a developer to create robust portable software."
+HOMEPAGE="http://www.s-lang.org"
+SRC_URI="ftp://ftp.fu-berlin.de/pub/unix/misc/slang/v${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="cjk pcre png readline zlib"
+
+RDEPEND="sys-libs/ncurses
+ pcre? ( dev-libs/libpcre )
+ png? ( media-libs/libpng )
+ cjk? ( dev-libs/oniguruma )
+ readline? ( sys-libs/readline )
+ zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.1.2-slsh-libs.patch \
+ "${FILESDIR}"/${PN}-2.1.3-uclibc.patch
+}
+
+src_configure() {
+ local myconf
+
+ if use readline; then
+ myconf+=" --with-readline=gnu"
+ else
+ myconf+=" --with-readline=slang"
+ fi
+
+ econf \
+ $(use_with cjk onig) \
+ $(use_with pcre) \
+ $(use_with png) \
+ $(use_with zlib z) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -j1 elf static || die "emake elf static failed"
+
+ cd slsh
+ emake -j1 slsh || die "emake slsh failed"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install-all || die "emake install-all failed"
+
+ rm -rf "${D}"/usr/share/doc/{slang,slsh}
+
+ dodoc NEWS README *.txt doc/{,internal,text}/*.txt
+ dohtml doc/slangdoc.html slsh/doc/html/*.html
+}