summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-06-15 09:52:58 +0000
committerSamuli Suominen <drac@gentoo.org>2008-06-15 09:52:58 +0000
commitfb276ef3f58eb5d9de132acbb2ab207ddea89381 (patch)
treefe7fa9725f8faf17c45ab4355dd7debfc85f322b /sys-libs/slang
parentRemove tree-incompatible versions as slang-1 is no more. Marked 0.52.8 stable... (diff)
downloadgentoo-2-fb276ef3f58eb5d9de132acbb2ab207ddea89381.tar.gz
gentoo-2-fb276ef3f58eb5d9de132acbb2ab207ddea89381.tar.bz2
gentoo-2-fb276ef3f58eb5d9de132acbb2ab207ddea89381.zip
old
(Portage version: 2.1.5.5)
Diffstat (limited to 'sys-libs/slang')
-rw-r--r--sys-libs/slang/files/slang-1.4.9-fbsdlink.patch26
-rw-r--r--sys-libs/slang/slang-1.4.9-r2.ebuild69
2 files changed, 0 insertions, 95 deletions
diff --git a/sys-libs/slang/files/slang-1.4.9-fbsdlink.patch b/sys-libs/slang/files/slang-1.4.9-fbsdlink.patch
deleted file mode 100644
index 472348fbbc03..000000000000
--- a/sys-libs/slang/files/slang-1.4.9-fbsdlink.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-Index: slang-1.4.9/autoconf/aclocal.m4
-===================================================================
---- slang-1.4.9.orig/autoconf/aclocal.m4
-+++ slang-1.4.9/autoconf/aclocal.m4
-@@ -489,7 +489,7 @@ ELFLIB_MAJOR="\$(ELFLIB).\$(ELF_MAJOR_VE
- ELFLIB_MAJOR_MINOR="\$(ELFLIB).\$(ELF_MAJOR_VERSION).\$(ELF_MINOR_VERSION)"
-
- case "$host_os" in
-- *linux* )
-+ *linux* | *freebsd* )
- DYNAMIC_LINK_FLAGS="-Wl,-export-dynamic"
- ELF_CC="gcc"
- ELF_CFLAGS="$ELF_CFLAGS -fPIC"
-Index: slang-1.4.9/configure
-===================================================================
---- slang-1.4.9.orig/configure
-+++ slang-1.4.9/configure
-@@ -489,7 +489,7 @@ ELFLIB_MAJOR="\$(ELFLIB).\$(ELF_MAJOR_VE
- ELFLIB_MAJOR_MINOR="\$(ELFLIB).\$(ELF_MAJOR_VERSION).\$(ELF_MINOR_VERSION)"
-
- case "$host_os" in
-- *linux* )
-+ *linux* | *freebsd* )
- DYNAMIC_LINK_FLAGS="-Wl,-export-dynamic"
- ELF_CC="gcc"
- ELF_CFLAGS="$ELF_CFLAGS -fPIC"
diff --git a/sys-libs/slang/slang-1.4.9-r2.ebuild b/sys-libs/slang/slang-1.4.9-r2.ebuild
deleted file mode 100644
index bc12360305ee..000000000000
--- a/sys-libs/slang/slang-1.4.9-r2.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-1.4.9-r2.ebuild,v 1.20 2008/02/09 06:38:09 drac Exp $
-
-inherit eutils toolchain-funcs
-
-# Patches are taken from http://www.suse.de/~nadvornik/slang/
-# They were originally Red Hat and Debian's patches
-
-DESCRIPTION="Console display library used by most text viewer"
-HOMEPAGE="http://www.s-lang.org/"
-SRC_URI="ftp://space.mit.edu/pub/davis/slang/v1.4/${P}.tar.bz2
- mirror://gentoo/${P}-patches.tar.gz"
-
-LICENSE="|| ( GPL-2 Artistic )"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="cjk unicode"
-
-DEPEND=">=sys-libs/ncurses-5.2-r2"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${WORKDIR}"/${P}.patch
- use userland_BSD || epatch "${WORKDIR}"/${P}-fsuid.patch
- epatch "${WORKDIR}"/${P}-autoconf.patch
- if use unicode ; then
- epatch "${WORKDIR}"/slang-debian-utf8.patch
- epatch "${WORKDIR}"/slang-utf8-acs.patch
- epatch "${WORKDIR}"/slang-utf8-fix.patch
- epatch "${WORKDIR}"/slang-utf8-fix2.patch
- fi
-
- epatch "${FILESDIR}"/${P}-fbsdlink.patch
-
- if use cjk ; then
- sed -i \
- -e "/SLANG_HAS_KANJI_SUPPORT/s/0/1/" \
- src/sl-feat.h
- fi
-}
-
-src_compile() {
- export LANG=C
- export LC_ALL=C
- econf || die "econf failed"
- sed -i -e "/^ELF_LINK/s:gcc:$(tc-getCC):" src/Makefile || die
- emake CC="$(tc-getCC)" ELF_CC="$(tc-getCC)" -j1 all elf || die "make failed"
-}
-
-src_install() {
- make install install-elf DESTDIR="${D}" || die "make install failed"
- chmod a+rx "${D}"/usr/$(get_libdir)/libslang*$(get_libname)* || die "chmod failed"
-
- if use unicode ; then
- for i in "${D}"/usr/$(get_libdir)/libslang-utf8* ; do
- local libslang=${i/${D}/}
- dosym ${libslang} ${libslang/-utf8/}
- done
- dosym /usr/$(get_libdir)/libslang{-utf8,}.a
- fi
-
- rm -rf "${D}"/usr/doc
- dodoc NEWS README *.txt
- dodoc doc/*.txt doc/internal/*.txt doc/text/*.txt
- dohtml doc/*.html
-}