summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2007-09-18 16:47:17 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2007-09-18 16:47:17 +0000
commit4d6bbeaff640d3fe3c416ad3ca01f38800524c7e (patch)
tree60dccefe1db6182d833caff79c688d3a3301101b /sys-libs/slang
parentMask liferea 1.4.x; bug #191408 (diff)
downloadgentoo-2-4d6bbeaff640d3fe3c416ad3ca01f38800524c7e.tar.gz
gentoo-2-4d6bbeaff640d3fe3c416ad3ca01f38800524c7e.tar.bz2
gentoo-2-4d6bbeaff640d3fe3c416ad3ca01f38800524c7e.zip
Version bumped, bug #182339.
(Portage version: 2.1.3.9)
Diffstat (limited to 'sys-libs/slang')
-rw-r--r--sys-libs/slang/ChangeLog8
-rw-r--r--sys-libs/slang/files/digest-slang-2.1.23
-rw-r--r--sys-libs/slang/files/slang-2.1.2-slsh-libs.patch12
-rw-r--r--sys-libs/slang/slang-2.1.2.ebuild65
4 files changed, 87 insertions, 1 deletions
diff --git a/sys-libs/slang/ChangeLog b/sys-libs/slang/ChangeLog
index 2638c1c05fd8..7de82c3e7c5a 100644
--- a/sys-libs/slang/ChangeLog
+++ b/sys-libs/slang/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/slang
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.61 2007/08/30 12:45:53 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/ChangeLog,v 1.62 2007/09/18 16:47:16 matsuu Exp $
+
+*slang-2.1.2 (18 Sep 2007)
+
+ 18 Sep 2007; MATSUU Takuto <matsuu@gentoo.org>
+ +files/slang-2.1.2-slsh-libs.patch, +slang-2.1.2.ebuild:
+ Version bumped, bug #182339.
30 Aug 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing liquidx from metadata due to his retirement (see #171155 for
diff --git a/sys-libs/slang/files/digest-slang-2.1.2 b/sys-libs/slang/files/digest-slang-2.1.2
new file mode 100644
index 000000000000..276045be1d22
--- /dev/null
+++ b/sys-libs/slang/files/digest-slang-2.1.2
@@ -0,0 +1,3 @@
+MD5 2e038bae1d7e800980372b46da5212fe slang-2.1.2.tar.gz 1474249
+RMD160 f275ad760ef53b83d7de77db0c9066bb7ff15dcb slang-2.1.2.tar.gz 1474249
+SHA256 9b5d22c23af0cb79132e2bfdbc1e39ab4c8bdbc5da32c4b3201d9c473b0ec5f5 slang-2.1.2.tar.gz 1474249
diff --git a/sys-libs/slang/files/slang-2.1.2-slsh-libs.patch b/sys-libs/slang/files/slang-2.1.2-slsh-libs.patch
new file mode 100644
index 000000000000..da9c3ecfaa09
--- /dev/null
+++ b/sys-libs/slang/files/slang-2.1.2-slsh-libs.patch
@@ -0,0 +1,12 @@
+diff -Naur slang-2.1.2.orig/slsh/Makefile.in slang-2.1.2/slsh/Makefile.in
+--- slang-2.1.2.orig/slsh/Makefile.in 2007-09-09 10:39:18.000000000 +0900
++++ slang-2.1.2/slsh/Makefile.in 2007-09-19 01:31:41.000000000 +0900
+@@ -74,7 +74,7 @@
+ slsh_exe: slsh.o readline.o
+ $(CC) $(CFLAGS) slsh.o readline.o -o slsh_exe $(LDFLAGS) $(SRC_LIBS)
+ slsh: slsh.o readline.o
+- $(CC) $(CFLAGS) slsh.o readline.o -o slsh $(LDFLAGS) $(INST_LIBS)
++ $(CC) $(CFLAGS) slsh.o readline.o -o slsh $(LDFLAGS) $(SRC_LIBS)
+ slsh.o: slsh.c slsh.h config.h Makefile
+ $(CC) -c $(CFLAGS) $(SLANG_SRCINC) $(DEFS) slsh.c
+ readline.o: readline.c slsh.h config.h Makefile
diff --git a/sys-libs/slang/slang-2.1.2.ebuild b/sys-libs/slang/slang-2.1.2.ebuild
new file mode 100644
index 000000000000..1951b85f1c2d
--- /dev/null
+++ b/sys-libs/slang/slang-2.1.2.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/slang/slang-2.1.2.ebuild,v 1.1 2007/09/18 16:47:16 matsuu Exp $
+
+inherit eutils
+
+DESCRIPTION="Console display library used by most text viewer"
+HOMEPAGE="http://www.s-lang.org/"
+SRC_URI="ftp://space.mit.edu/pub/davis/slang/v${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~x86"
+# USE=cjk is broken; see http://www.jedsoft.org/pipermail/slang-users_jedsoft.org/2006/000399.html
+IUSE="pcre png"
+
+DEPEND=">=sys-libs/ncurses-5.2-r2
+ pcre? ( dev-libs/libpcre )
+ png? ( media-libs/libpng )"
+
+MAKEOPTS="${MAKEOPTS} -j1"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-slsh-libs.patch"
+
+ sed -i -e '/^THIS_LIB/s/slang/slang-2/' src/Makefile.in || die
+
+ grep -rlZ -- '-lslang\>' "${S}" | xargs -0 sed -i -e 's:-lslang:-lslang-2:g'
+}
+
+src_compile() {
+ econf \
+ $(use_with pcre) \
+ $(use_with png) || die "econf failed"
+ emake all || die "make all failed"
+ cd slsh
+ emake slsh || die "make slsh failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-static || die "make install failed"
+
+ # Move headers around
+ dodir /usr/include/slang-2
+ mv "${D}"/usr/include/*.h "${D}/usr/include/slang-2"
+
+ rm -rf "${D}/usr/share/doc/{slang,slsh}"
+
+ dodoc NEWS README *.txt
+ dodoc doc/*.txt doc/internal/*.txt doc/text/*.txt
+ dohtml doc/slangdoc.html
+ dohtml slsh/doc/html/*.html
+}
+
+pkg_postinst() {
+ elog "For compatibility reason slang 2.x is installed in Gentoo as libslang-2."
+ elog "This has the unfortunate consequence that if you want to build something"
+ elog "from sources that uses slang 2.x, you need to change the linking library"
+ elog "to -lslang-2 instead of simply -lslang."
+ elog "We're sorry for the inconvenience, but it's to overcome an otherwise"
+ elog "problematic situation."
+}