summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-08-29 21:10:20 +0000
committerMike Frysinger <vapier@gentoo.org>2009-08-29 21:10:20 +0000
commitff89627ace5ddf4ea453f82c62a8993d06889e6e (patch)
treed33d2a4c82cd5193e2989a9377af197ed91b7831 /sys-libs/readline
parentBump to newer snapshot, and include poll() CPU usage fix from Ubuntu. Massive... (diff)
downloadgentoo-2-ff89627ace5ddf4ea453f82c62a8993d06889e6e.tar.gz
gentoo-2-ff89627ace5ddf4ea453f82c62a8993d06889e6e.tar.bz2
gentoo-2-ff89627ace5ddf4ea453f82c62a8993d06889e6e.zip
Version bump #283138 by Arfrever Frehtes Taifersar Arahesis.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/readline')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/readline-6.0_p4.ebuild102
2 files changed, 108 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 3d20e19a976d..413cc5130823 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.129 2009/05/18 11:48:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.130 2009/08/29 21:10:20 vapier Exp $
+
+*readline-6.0_p4 (29 Aug 2009)
+
+ 29 Aug 2009; Mike Frysinger <vapier@gentoo.org> +readline-6.0_p4.ebuild:
+ Version bump #283138 by Arfrever Frehtes Taifersar Arahesis.
18 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
readline-6.0_p3.ebuild:
diff --git a/sys-libs/readline/readline-6.0_p4.ebuild b/sys-libs/readline/readline-6.0_p4.ebuild
new file mode 100644
index 000000000000..cf8c5b173bd3
--- /dev/null
+++ b/sys-libs/readline/readline-6.0_p4.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-6.0_p4.ebuild,v 1.1 2009/08/29 21:10:20 vapier Exp $
+
+inherit autotools eutils multilib toolchain-funcs flag-o-matic
+
+# Official patches
+# See ftp://ftp.cwru.edu/pub/bash/readline-6.0-patches/
+PLEVEL=${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+[[ ${PV} != *_p* ]] && PLEVEL=0
+patches() {
+ [[ ${PLEVEL} -eq 0 ]] && return 1
+ local opt=$1
+ eval set -- {1..${PLEVEL}}
+ set -- $(printf "${PN}${MY_PV/\.}-%03d " "$@")
+ if [[ ${opt} == -s ]] ; then
+ echo "${@/#/${DISTDIR}/}"
+ else
+ local u
+ for u in ftp://ftp.cwru.edu/pub/bash mirror://gnu/${PN} ; do
+ printf "${u}/${PN}-${MY_PV}-patches/%s " "$@"
+ done
+ fi
+}
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz $(patches)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.05b-r2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd "${S}"
+ [[ ${PLEVEL} -gt 0 ]] && epatch $(patches -s)
+ epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
+ epatch "${FILESDIR}"/${PN}-6.0-rlfe-build.patch #151174
+ epatch "${FILESDIR}"/${PN}-5.2-no-ignore-shlib-errors.patch #216952
+
+ # force ncurses linking #71420
+ sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
+
+ # fix building under Gentoo/FreeBSD; upstream FreeBSD deprecated
+ # objformat for years, so we don't want to rely on that.
+ sed -i -e '/objformat/s:if .*; then:if true; then:' support/shobj-conf || die
+
+ # the bundled rlfe had its configure.in updated, but no one actually
+ # ran autoconf to have the configure file updated
+ ln -s ../.. examples/rlfe/readline
+ cd examples/rlfe
+ eautoconf
+}
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+
+ econf --with-curses || die
+ emake || die
+
+ if ! tc-is-cross-compiler ; then
+ cd examples/rlfe
+ append-ldflags -Lreadline
+ econf || die
+ emake || die "make rlfe failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ gen_usr_ldscript -a readline history #4411
+
+ if ! tc-is-cross-compiler; then
+ dobin examples/rlfe/rlfe || die
+ fi
+
+ dodoc CHANGELOG CHANGES README USAGE NEWS
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}
+
+pkg_preinst() {
+ preserve_old_lib /$(get_libdir)/lib{history,readline}.so.{4,5} #29865
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/lib{history,readline}.so.{4,5}
+}