summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-12 23:30:22 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-12 23:30:22 +0000
commit69507a68565a9f602a4dc870dc38eb1b11ed6354 (patch)
treeb601968802ce5bb48cea91b03cba15dbc6354be2 /sys-libs/readline
parentVersion bump (diff)
downloadgentoo-2-69507a68565a9f602a4dc870dc38eb1b11ed6354.tar.gz
gentoo-2-69507a68565a9f602a4dc870dc38eb1b11ed6354.tar.bz2
gentoo-2-69507a68565a9f602a4dc870dc38eb1b11ed6354.zip
Version bump.
(Portage version: 2.1.2_pre2-r5)
Diffstat (limited to 'sys-libs/readline')
-rw-r--r--sys-libs/readline/ChangeLog7
-rw-r--r--sys-libs/readline/files/digest-readline-5.23
-rw-r--r--sys-libs/readline/readline-5.2.ebuild106
3 files changed, 115 insertions, 1 deletions
diff --git a/sys-libs/readline/ChangeLog b/sys-libs/readline/ChangeLog
index 2f3fa3506421..96608548eeb3 100644
--- a/sys-libs/readline/ChangeLog
+++ b/sys-libs/readline/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/readline
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.81 2006/08/19 15:43:36 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/ChangeLog,v 1.82 2006/10/12 23:30:22 vapier Exp $
+
+*readline-5.2 (12 Oct 2006)
+
+ 12 Oct 2006; Mike Frysinger <vapier@gentoo.org> +readline-5.2.ebuild:
+ Version bump.
19 Aug 2006; Fabian Groffen <grobian@gentoo.org> readline-5.1_p4.ebuild:
Marked ppc-macos stable for progressive users (bug #129885)
diff --git a/sys-libs/readline/files/digest-readline-5.2 b/sys-libs/readline/files/digest-readline-5.2
new file mode 100644
index 000000000000..e9ccac17fb66
--- /dev/null
+++ b/sys-libs/readline/files/digest-readline-5.2
@@ -0,0 +1,3 @@
+MD5 e39331f32ad14009b9ff49cc10c5e751 readline-5.2.tar.gz 2037705
+RMD160 983cbb25192e0a376b80cb2428fe8ee254a041c7 readline-5.2.tar.gz 2037705
+SHA256 12e88d96aee2cd1192500356f0535540db499282ca7f76339fb4228c31249f45 readline-5.2.tar.gz 2037705
diff --git a/sys-libs/readline/readline-5.2.ebuild b/sys-libs/readline/readline-5.2.ebuild
new file mode 100644
index 000000000000..4f0b166cbca9
--- /dev/null
+++ b/sys-libs/readline/readline-5.2.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/readline/readline-5.2.ebuild,v 1.1 2006/10/12 23:30:22 vapier Exp $
+
+inherit eutils multilib toolchain-funcs
+
+# Official patches
+# See ftp://ftp.cwru.edu/pub/bash/readline-5.1-patches/
+PLEVEL=0 #${PV##*_p}
+MY_PV=${PV/_p*}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Another cute console display library"
+HOMEPAGE="http://cnswww.cns.cwru.edu/php/chet/readline/rltop.html"
+SRC_URI="mirror://gnu/readline/${MY_P}.tar.gz
+ $(for ((i=1; i<=PLEVEL; i++)); do
+ printf 'ftp://ftp.cwru.edu/pub/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ printf 'mirror://gnu/bash/readline-%s-patches/readline%s-%03d\n' \
+ ${MY_PV} ${MY_PV/\.} ${i}
+ done)"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+# We must be certain that we have a bash that is linked
+# to its internal readline, else we may get problems.
+RDEPEND=">=sys-libs/ncurses-5.2-r2"
+DEPEND="${RDEPEND}
+ >=app-shells/bash-2.05b-r2"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${MY_P}.tar.gz
+
+ cd "${S}"
+ # Official patches
+ local i
+ for ((i=1; i<=PLEVEL; i++)); do
+ epatch "${DISTDIR}"/${PN}${MY_PV/\.}-$(printf '%03d' ${i})
+ done
+ epatch "${FILESDIR}"/${PN}-5.0-no_rpath.patch
+ #epatch "${FILESDIR}"/${PN}-5.1-rlfe-build.patch #116483
+ epatch "${FILESDIR}"/${PN}-5.1-rlfe-uclibc.patch
+
+ ln -s ../.. examples/rlfe/readline
+
+ # force ncurses linking #71420
+ sed -i -e 's:^SHLIB_LIBS=:SHLIB_LIBS=-lncurses:' support/shobj-conf || die "sed"
+}
+
+src_compile() {
+ # the --libdir= is needed because if lib64 is a directory, it will default
+ # to using that... even if CONF_LIBDIR isnt set or we're using a version
+ # of portage without CONF_LIBDIR support.
+ econf --with-curses --libdir=/usr/$(get_libdir) || die
+ emake || die
+
+ if ! tc-is-cross-compiler; then
+ cd examples/rlfe
+ econf || die
+ emake || die "make rlfe failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodir /$(get_libdir)
+
+ if ! use userland_Darwin ; then
+ mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
+ chmod a+rx "${D}"/$(get_libdir)/*.so*
+
+ # Bug #4411
+ gen_usr_ldscript libreadline.so
+ gen_usr_ldscript libhistory.so
+ fi
+
+ if ! tc-is-cross-compiler; then
+ dobin examples/rlfe/rlfe || die
+ fi
+
+ dodoc CHANGELOG CHANGES README USAGE NEWS
+ docinto ps
+ dodoc doc/*.ps
+ dohtml -r doc
+}
+
+pkg_preinst() {
+ # Backwards compatibility #29865
+ if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
+ cp -pPR "${ROOT}"/$(get_libdir)/libreadline.so.4* "${D}"/$(get_libdir)/
+ touch "${D}"/$(get_libdir)/libreadline.so.4*
+ fi
+}
+
+pkg_postinst() {
+ if [[ -e ${ROOT}/$(get_libdir)/libreadline.so.4 ]] ; then
+ ewarn "Your old readline libraries have been copied over."
+ ewarn "You should run 'revdep-rebuild --library libreadline.so.4' asap."
+ ewarn "Once you have, you can safely delete /$(get_libdir)/libreadline.so.4*"
+ fi
+}