summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-12-05 19:35:02 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-12-05 19:35:02 +0000
commit09433c9eab2e50940d0949d4da43a1a80d47a22d (patch)
tree682155125a4405b540cabdd3982b1b2ba3799758 /sys-libs/pam
parenthopefully fix #9385, #9567 (diff)
downloadgentoo-2-09433c9eab2e50940d0949d4da43a1a80d47a22d.tar.gz
gentoo-2-09433c9eab2e50940d0949d4da43a1a80d47a22d.tar.bz2
gentoo-2-09433c9eab2e50940d0949d4da43a1a80d47a22d.zip
bison fixes
Diffstat (limited to 'sys-libs/pam')
-rw-r--r--sys-libs/pam/ChangeLog7
-rw-r--r--sys-libs/pam/files/pam-0.75-pam_console-bison.fixes.patch18
-rw-r--r--sys-libs/pam/pam-0.75-r10.ebuild24
3 files changed, 40 insertions, 9 deletions
diff --git a/sys-libs/pam/ChangeLog b/sys-libs/pam/ChangeLog
index cae4903e6b01..552e636feaf5 100644
--- a/sys-libs/pam/ChangeLog
+++ b/sys-libs/pam/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/pam
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.15 2002/11/03 10:50:00 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/ChangeLog,v 1.16 2002/12/05 19:35:02 azarah Exp $
+
+ 05 Dec 2002; Martin Schlemmer <azarah@gentoo.org> pam-0.75-r10.ebuild :
+
+ Fix bison syntax for bison-1.50 or later, thanks to Redhat. Added
+ pam-0.75-pam_console-bison.fixes.patch for this.
26 Oct 2002; Martin Schlemmer <azarah@gentoo.org> pam-0.75-r10.ebuild :
diff --git a/sys-libs/pam/files/pam-0.75-pam_console-bison.fixes.patch b/sys-libs/pam/files/pam-0.75-pam_console-bison.fixes.patch
new file mode 100644
index 000000000000..8194bedffd29
--- /dev/null
+++ b/sys-libs/pam/files/pam-0.75-pam_console-bison.fixes.patch
@@ -0,0 +1,18 @@
+diff -urN Linux-PAM-0.75/modules/pam_console/config.y Linux-PAM-0.75.bison/modules/pam_console/config.y
+--- Linux-PAM-0.75/modules/pam_console/config.y 2001-10-02 22:29:10.000000000 +0200
++++ Linux-PAM-0.75.bison/modules/pam_console/config.y 2002-11-21 23:40:36.000000000 +0200
+@@ -117,11 +117,11 @@
+ | stringlist string {$$ = g_slist_append($1, $2);}
+ ;
+
+-optstring: string {$$=$1}
+- | /* empty */ {$$=NULL}
++optstring: string {$$=$1;}
++ | /* empty */ {$$=NULL;}
+ ;
+
+-string: STRING {$$=$1}
++string: STRING {$$=$1;} ;
+
+ %%
+
diff --git a/sys-libs/pam/pam-0.75-r10.ebuild b/sys-libs/pam/pam-0.75-r10.ebuild
index 81710d82048d..c1022bbb21c8 100644
--- a/sys-libs/pam/pam-0.75-r10.ebuild
+++ b/sys-libs/pam/pam-0.75-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r10.ebuild,v 1.2 2002/11/03 10:50:00 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/pam/pam-0.75-r10.ebuild,v 1.3 2002/12/05 19:35:02 azarah Exp $
IUSE="berkdb"
@@ -46,25 +46,33 @@ src_unpack() {
einfo " ${x##*/}..."
bzip2 -dc ${S2}/patchdir/${x} | patch -p1 > /dev/null || \
die "Failed Patch: ${x##*/}!"
+# pam-0.75-userdb.patch.bz2 patch userdb.c twice, which causes --dry-run
+# in epatch to fail ...
+# epatch ${S2}/patchdir/${x}
fi
done
# Get pam_userdb to link to db3 or db4 if they exist
# <azarah@gentoo.org> (3 Nov 2002)
- cd ${S}; patch -p1 < ${FILESDIR}/${P}-pam_userdb-use-db3.patch || die
+ cd ${S}; epatch ${FILESDIR}/${P}-pam_userdb-use-db3.patch
+ # Fix bison syntax for bison-1.50 or later, thanks to Redhat
+ cd ${S}; epatch ${FILESDIR}/${P}-pam_console-bison.fixes.patch
+
+ cd ${S}/doc
+ einfo "Unpacking docs..."
+ tar -xvzf Linux-PAM-0.75-docs.tar.gz > /dev/null || \
+ die "Failed to unpack docs!"
+
+ cd ${S}; einfo "Installing module docs..."
for readme in modules/pam_*/README
do
cp -f ${readme} doc/txts/README.$(dirname ${readme} | sed -e 's|^modules/||')
done
+ einfo "Generating configure..."
export WANT_AUTOCONF_2_5=1
- autoconf
-
- cd ${S}/doc
- einfo "Unpacking docs..."
- tar -xvzf Linux-PAM-0.75-docs.tar.gz > /dev/null || \
- die "Failed to unpack docs"
+ cd ${S}; autoconf || :
}
src_compile() {