summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-07-25 19:14:04 +0000
committerPacho Ramos <pacho@gentoo.org>2012-07-25 19:14:04 +0000
commit24901cec55f6aa2e2842706c18832e3a303fc81a (patch)
tree1e966f367c58c8f7497c97d71f26bbc0d283dbca /sys-libs/openhpi
parentAdd missing files, bug #428027 (diff)
downloadgentoo-2-24901cec55f6aa2e2842706c18832e3a303fc81a.tar.gz
gentoo-2-24901cec55f6aa2e2842706c18832e3a303fc81a.tar.bz2
gentoo-2-24901cec55f6aa2e2842706c18832e3a303fc81a.zip
Version bump, with a shorter description (to make repoman happier), it builds (#322215), glib-2.32 compatible (#423683 by flameeyes), fixed LICENSE (#426164 by Ian Stakenvicius).
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/openhpi')
-rw-r--r--sys-libs/openhpi/ChangeLog12
-rw-r--r--sys-libs/openhpi/openhpi-3.0.0.ebuild55
2 files changed, 64 insertions, 3 deletions
diff --git a/sys-libs/openhpi/ChangeLog b/sys-libs/openhpi/ChangeLog
index e1b0cd1c1310..dec332f2d3cc 100644
--- a/sys-libs/openhpi/ChangeLog
+++ b/sys-libs/openhpi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-libs/openhpi
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/openhpi/ChangeLog,v 1.7 2009/09/23 21:17:57 patrick Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openhpi/ChangeLog,v 1.8 2012/07/25 19:14:04 pacho Exp $
+
+*openhpi-3.0.0 (25 Jul 2012)
+
+ 25 Jul 2012; Pacho Ramos <pacho@gentoo.org> +openhpi-3.0.0.ebuild:
+ Version bump, with a shorter description (to make repoman happier), it builds
+ (#322215), glib-2.32 compatible (#423683 by flameeyes), fixed LICENSE (#426164
+ by Ian Stakenvicius).
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> openhpi-2.0.3.ebuild:
Remove virtual/libc
@@ -31,4 +38,3 @@
25 Mar 2005; Robin H. Johnson <robbat2@gentoo.org> +metadata.xml,
+openhpi-2.0.3.ebuild:
Initial commit. Ebuild by Robin H. Johnson <robbat2@gentoo.org>.
-
diff --git a/sys-libs/openhpi/openhpi-3.0.0.ebuild b/sys-libs/openhpi/openhpi-3.0.0.ebuild
new file mode 100644
index 000000000000..e737b920e0bf
--- /dev/null
+++ b/sys-libs/openhpi/openhpi-3.0.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/openhpi/openhpi-3.0.0.ebuild,v 1.1 2012/07/25 19:14:04 pacho Exp $
+
+EAPI=4
+inherit eutils
+
+DESCRIPTION="Open source implementation of the Service Availability Forum (SAF) Hardware Platform Interface (HPI)"
+HOMEPAGE="http://www.openhpi.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="snmp"
+
+COMMONDEPEND=">=dev-libs/glib-2.12:2
+ sys-fs/e2fsprogs
+ sys-fs/sysfsutils
+ >=sys-libs/openipmi-1.4.20
+ snmp? ( >=net-analyzer/net-snmp-5.07 )"
+RDEPEND="${COMMONDEPEND}"
+DEPEND="${COMMONDEPEND}
+ >=sys-devel/autoconf-2.57
+ >=sys-devel/automake-1.8
+ >=sys-devel/gcc-3.2.0
+ virtual/os-headers"
+
+src_configure() {
+ econf --with-varpath=/var/lib/openhpi \
+ --enable-clients \
+ --enable-cpp_wrappers \
+ --enable-daemon \
+ --enable-ipmidirect \
+ --enable-sysfs \
+ --enable-watchdog \
+ --enable-simulator \
+ --disable-testcover \
+ $(use_enable snmp snmp_bc)
+}
+
+src_install() {
+ # Stage main files.
+ emake DESTDIR="${D}" install
+
+ # Stage conf.d-file and init.d-script.
+ newinitd "${FILESDIR}"/openhpi-initd openhpid
+ newconfd "${FILESDIR}"/openhpi-confd openhpid
+
+ # Stage documentation.
+ dodoc README
+
+ # Make sure the data dir exists or openhpid will fail silently.
+ keepdir /var/lib/openhpi/
+}