summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-12-24 07:47:20 +0000
committerMike Frysinger <vapier@gentoo.org>2013-12-24 07:47:20 +0000
commite5ded94361687f31b16684a6a4499d11cf8c31f8 (patch)
treef3de686c10fcd5ad61bd09fbcbd9b2c3781c49a5 /sys-libs/newlib
parentForce latest automake-wrapper to keep people up-to-date. (diff)
downloadgentoo-2-e5ded94361687f31b16684a6a4499d11cf8c31f8.tar.gz
gentoo-2-e5ded94361687f31b16684a6a4499d11cf8c31f8.tar.bz2
gentoo-2-e5ded94361687f31b16684a6a4499d11cf8c31f8.zip
Add live git ebuild by Andrey Hippo #489380.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs/newlib')
-rw-r--r--sys-libs/newlib/ChangeLog7
-rw-r--r--sys-libs/newlib/newlib-9999.ebuild76
2 files changed, 82 insertions, 1 deletions
diff --git a/sys-libs/newlib/ChangeLog b/sys-libs/newlib/ChangeLog
index 7ca3a0bfb1e6..87f3da862bc5 100644
--- a/sys-libs/newlib/ChangeLog
+++ b/sys-libs/newlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/newlib
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.23 2013/12/24 06:44:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.24 2013/12/24 07:47:20 vapier Exp $
+
+*newlib-9999 (24 Dec 2013)
+
+ 24 Dec 2013; Mike Frysinger <vapier@gentoo.org> +newlib-9999.ebuild:
+ Add live git ebuild by Andrey Hippo #489380.
*newlib-2.1.0 (24 Dec 2013)
diff --git a/sys-libs/newlib/newlib-9999.ebuild b/sys-libs/newlib/newlib-9999.ebuild
new file mode 100644
index 000000000000..84e806e7dda8
--- /dev/null
+++ b/sys-libs/newlib/newlib-9999.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-9999.ebuild,v 1.1 2013/12/24 07:47:20 vapier Exp $
+
+EAPI="4"
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://sourceware.org/git/newlib.git"
+ inherit git-r3
+else
+ SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
+ KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="Newlib is a C library intended for use on embedded systems"
+HOMEPAGE="http://sourceware.org/newlib/"
+
+LICENSE="NEWLIB LIBGLOSS GPL-2"
+SLOT="0"
+IUSE="nls threads unicode crosscompile_opts_headers-only"
+RESTRICT="strip"
+
+NEWLIBBUILD="${WORKDIR}/build"
+
+pkg_setup() {
+ # Reject newlib-on-glibc type installs
+ if [[ ${CTARGET} == ${CHOST} ]] ; then
+ case ${CHOST} in
+ *-newlib|*-elf) ;;
+ *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
+ esac
+ fi
+}
+
+src_configure() {
+ # we should fix this ...
+ unset LDFLAGS
+ CHOST=${CTARGET} strip-unsupported-flags
+
+ local myconf=""
+ [[ ${CTARGET} == "spu" ]] \
+ && myconf="${myconf} --disable-newlib-multithread" \
+ || myconf="${myconf} $(use_enable threads newlib-multithread)"
+
+ mkdir -p "${NEWLIBBUILD}"
+ cd "${NEWLIBBUILD}"
+
+ ECONF_SOURCE=${S} \
+ econf \
+ $(use_enable unicode newlib-mb) \
+ $(use_enable nls) \
+ ${myconf}
+}
+
+src_compile() {
+ emake -C "${NEWLIBBUILD}"
+}
+
+src_install() {
+ cd "${NEWLIBBUILD}"
+ emake -j1 DESTDIR="${D}" install
+# env -uRESTRICT CHOST=${CTARGET} prepallstrip
+ # minor hack to keep things clean
+ rm -fR "${D}"/usr/share/info
+ rm -fR "${D}"/usr/info
+}