summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-10-22 12:30:59 +0000
committerMike Frysinger <vapier@gentoo.org>2009-10-22 12:30:59 +0000
commitffd578177575dd52a3315c97a268132dc42717f6 (patch)
treede442ecfe4ca16f7e1f53cf2599a8bb47d25eccf /sys-libs/ncurses
parentRe-fix bug 268378. (diff)
downloadgentoo-2-ffd578177575dd52a3315c97a268132dc42717f6.tar.gz
gentoo-2-ffd578177575dd52a3315c97a268132dc42717f6.tar.bz2
gentoo-2-ffd578177575dd52a3315c97a268132dc42717f6.zip
Fix up ncurses tic script to better detect cross-compiling #288881 by Sergiy Borodych.
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/ncurses')
-rw-r--r--sys-libs/ncurses/ChangeLog7
-rw-r--r--sys-libs/ncurses/files/ncurses-5.7-tic-cross-detection.patch58
-rw-r--r--sys-libs/ncurses/ncurses-5.7-r2.ebuild3
3 files changed, 66 insertions, 2 deletions
diff --git a/sys-libs/ncurses/ChangeLog b/sys-libs/ncurses/ChangeLog
index 8fbcdd462235..76829d3c67e8 100644
--- a/sys-libs/ncurses/ChangeLog
+++ b/sys-libs/ncurses/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/ncurses
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.165 2009/10/11 07:30:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ChangeLog,v 1.166 2009/10/22 12:30:58 vapier Exp $
+
+ 22 Oct 2009; Mike Frysinger <vapier@gentoo.org> ncurses-5.7-r2.ebuild,
+ +files/ncurses-5.7-tic-cross-detection.patch:
+ Fix up ncurses tic script to better detect cross-compiling #288881 by
+ Sergiy Borodych.
*ncurses-5.7-r2 (11 Oct 2009)
diff --git a/sys-libs/ncurses/files/ncurses-5.7-tic-cross-detection.patch b/sys-libs/ncurses/files/ncurses-5.7-tic-cross-detection.patch
new file mode 100644
index 000000000000..a57cd78c77f6
--- /dev/null
+++ b/sys-libs/ncurses/files/ncurses-5.7-tic-cross-detection.patch
@@ -0,0 +1,58 @@
+use $cross_compiling that autotools already set up rather than trying to
+do a custom & fragile job with compiler names
+
+configure.in also needs AC_SUBST(cross_compiling) ...
+
+http://bugs.gentoo.org/288881
+
+--- a/configure
++++ b/configure
+@@ -17300,6 +17300,7 @@
+ s,@build_alias@,$build_alias,;t t
+ s,@host_alias@,$host_alias,;t t
+ s,@target_alias@,$target_alias,;t t
++s,@cross_compiling@,$cross_compiling,;t t
+ s,@ECHO_C@,$ECHO_C,;t t
+ s,@ECHO_N@,$ECHO_N,;t t
+ s,@ECHO_T@,$ECHO_T,;t t
+--- a/misc/run_tic.in
++++ b/misc/run_tic.in
+@@ -52,8 +52,7 @@
+ : ${ticdir=@TERMINFO@}
+ : ${source=@TERMINFO_SRC@}
+ : ${LN_S="@LN_S@"}
+-: ${THAT_CC=cc}
+-: ${THIS_CC=cc}
++: ${cross_compiling=@cross_compiling@}
+ : ${ext_funcs=@NCURSES_EXT_FUNCS@}
+
+ test -z "${DESTDIR}" && DESTDIR=
+@@ -61,7 +60,7 @@
+ # Allow tic to run either from the install-path, or from the build-directory.
+ # Do not do this if we appear to be cross-compiling. In that case, we rely
+ # on the host's copy of tic to compile the terminfo database.
+-if test "$THAT_CC" = "$THIS_CC" ; then
++if test "$cross_compiling" != "yes" ; then
+ case "$PATH" in
+ :*) PATH=../progs:../lib:${DESTDIR}$bindir$PATH ;;
+ *) PATH=../progs:../lib:${DESTDIR}$bindir:$PATH ;;
+--- a/misc/Makefile.in
++++ b/misc/Makefile.in
+@@ -59,6 +59,7 @@
+
+ CC = @CC@
+ HOSTCC = @BUILD_CC@
++cross_compiling = @cross_compiling@
+
+ tabsetdir = $(datadir)/tabset
+ ticdir = @TERMINFO@
+@@ -91,8 +92,7 @@
+ datadir=${datadir} \
+ ticdir=${ticdir} \
+ source=terminfo.tmp \
+- THIS_CC="$(CC)" \
+- THAT_CC="$(HOSTCC)" \
++ cross_compiling="${cross_compiling}" \
+ $(SHELL) ./run_tic.sh
+ @cd $(srcdir)/tabset && \
+ $(SHELL) -c 'for i in * ; do \
diff --git a/sys-libs/ncurses/ncurses-5.7-r2.ebuild b/sys-libs/ncurses/ncurses-5.7-r2.ebuild
index 519ced50af3a..d162c6abe8c0 100644
--- a/sys-libs/ncurses/ncurses-5.7-r2.ebuild
+++ b/sys-libs/ncurses/ncurses-5.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.7-r2.ebuild,v 1.1 2009/10/11 07:30:28 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/ncurses/ncurses-5.7-r2.ebuild,v 1.2 2009/10/22 12:30:58 vapier Exp $
EAPI="1"
inherit eutils flag-o-matic toolchain-funcs
@@ -29,6 +29,7 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-5.6-gfbsd.patch
epatch "${FILESDIR}"/${PN}-5.7-emacs.patch #270527
epatch "${FILESDIR}"/${PN}-5.7-nongnu.patch
+ epatch "${FILESDIR}"/${PN}-5.7-tic-cross-detection.patch #288881
epatch "${FILESDIR}"/${P}-hashdb-open.patch #245370
}