summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-08-31 10:11:55 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-08-31 10:11:55 +0000
commitc6005cde8e3f7b8275d2eebe17f447df0e43a263 (patch)
tree742e8a64c7b943d91784e94ba40dcce7c5df4d7a /sys-libs/musl
parentRemove unneeded useflag from metadata.xml (diff)
downloadgentoo-2-c6005cde8e3f7b8275d2eebe17f447df0e43a263.tar.gz
gentoo-2-c6005cde8e3f7b8275d2eebe17f447df0e43a263.tar.bz2
gentoo-2-c6005cde8e3f7b8275d2eebe17f447df0e43a263.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-libs/musl')
-rw-r--r--sys-libs/musl/ChangeLog7
-rw-r--r--sys-libs/musl/musl-0.9.13.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/sys-libs/musl/ChangeLog b/sys-libs/musl/ChangeLog
index 3a2d1cfc2a51..907dce7a5597 100644
--- a/sys-libs/musl/ChangeLog
+++ b/sys-libs/musl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/musl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.11 2013/08/09 00:50:50 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/ChangeLog,v 1.12 2013/08/31 10:11:55 blueness Exp $
+
+*musl-0.9.13 (31 Aug 2013)
+
+ 31 Aug 2013; Anthony G. Basile <blueness@gentoo.org> +musl-0.9.13.ebuild:
+ Version bump
09 Aug 2013; Anthony G. Basile <blueness@gentoo.org> musl-0.9.12.ebuild,
musl-9999.ebuild:
diff --git a/sys-libs/musl/musl-0.9.13.ebuild b/sys-libs/musl/musl-0.9.13.ebuild
new file mode 100644
index 000000000000..ac08a55c767d
--- /dev/null
+++ b/sys-libs/musl/musl-0.9.13.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/musl/musl-0.9.13.ebuild,v 1.1 2013/08/31 10:11:55 blueness Exp $
+
+EAPI="5"
+
+inherit eutils flag-o-matic multilib toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.musl-libc.org/musl"
+ inherit git-2
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+ if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+ export CTARGET=${CATEGORY/cross-}
+ fi
+fi
+
+DESCRIPTION="Lightweight, fast and simple C library focused on standards-conformance and safety"
+HOMEPAGE="http://www.musl-libc.org/"
+if [[ ${PV} != "9999" ]] ; then
+ PATCH_VER=""
+ SRC_URI="http://www.musl-libc.org/releases/${P}.tar.gz"
+ KEYWORDS="-* ~amd64 ~arm ~mips ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="crosscompile_opts_headers-only"
+
+is_crosscompile() {
+ [[ ${CHOST} != ${CTARGET} ]]
+}
+
+just_headers() {
+ use crosscompile_opts_headers-only && is_crosscompile
+}
+
+pkg_setup() {
+ if [ ${CTARGET} == ${CHOST} ] ; then
+ case ${CHOST} in
+ *-musl*) ;;
+ *) die "Use sys-devel/crossdev to build a musl toolchain" ;;
+ esac
+ fi
+}
+
+src_configure() {
+ tc-export CC
+
+ ./configure \
+ --target="${CTARGET}" \
+ --prefix="/usr" \
+ --disable-gcc-wrapper
+}
+
+src_compile() {
+ emake include/bits/alltypes.h || die
+ just_headers && return 0
+
+ emake || die
+}
+
+src_install() {
+ local sysroot=${D}
+ is_crosscompile && sysroot+="/usr/${CTARGET}"
+
+ local target="install"
+ just_headers && target="install-headers"
+ emake DESTDIR="${sysroot}" ${target} || die
+
+ # Make sure we install the sys-include symlink so that when
+ # we build a 2nd stage cross-compiler, gcc finds the target
+ # system headers correctly. See gcc/doc/gccinstall.info
+ if is_crosscompile ; then
+ dosym usr/include /usr/${CTARGET}/sys-include
+ fi
+}
+
+pkg_postinst() {
+ is_crosscompile && return 0
+
+ [ "${ROOT}" != "/" ] && return 0
+
+ # TODO: musl doesn't use ldconfig, instead here we can
+ # create sym links to libraries outside of /lib and /usr/lib
+ ldconfig
+ # reload init ...
+ /sbin/telinit U 2>/dev/null
+}