summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2008-11-14 12:06:05 +0000
committerLuca Barbato <lu_zero@gentoo.org>2008-11-14 12:06:05 +0000
commitfa6d631f343cafe571e8525c26df01afc2c629a0 (patch)
tree1c6aee6fedebc53b7af009e6a37aae3d15d47d7c /sys-libs/mars
parentMIT_Plus license required by mars (diff)
downloadgentoo-2-fa6d631f343cafe571e8525c26df01afc2c629a0.tar.gz
gentoo-2-fa6d631f343cafe571e8525c26df01afc2c629a0.tar.bz2
gentoo-2-fa6d631f343cafe571e8525c26df01afc2c629a0.zip
New version
(Portage version: 2.2_rc13/cvs/Linux 2.6.24-rc5-g31034440 ppc64)
Diffstat (limited to 'sys-libs/mars')
-rw-r--r--sys-libs/mars/ChangeLog8
-rw-r--r--sys-libs/mars/mars-1.0.1.ebuild (renamed from sys-libs/mars/mars-08.06.26.ebuild)20
2 files changed, 18 insertions, 10 deletions
diff --git a/sys-libs/mars/ChangeLog b/sys-libs/mars/ChangeLog
index f13b126f2bb2..91cc2ac05bd4 100644
--- a/sys-libs/mars/ChangeLog
+++ b/sys-libs/mars/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/mars
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/mars/ChangeLog,v 1.1 2008/08/23 13:27:42 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/mars/ChangeLog,v 1.2 2008/11/14 12:06:05 lu_zero Exp $
+
+*mars-1.0.1 (14 Nov 2008)
+
+ 14 Nov 2008; Luca Barbato <lu_zero@gentoo.org> +mars-1.0.1.ebuild,
+ -mars-08.06.26.ebuild:
+ New version
*mars-08.06.26 (23 Aug 2008)
diff --git a/sys-libs/mars/mars-08.06.26.ebuild b/sys-libs/mars/mars-1.0.1.ebuild
index 40ffca1a781c..97b88d181606 100644
--- a/sys-libs/mars/mars-08.06.26.ebuild
+++ b/sys-libs/mars/mars-1.0.1.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/mars/mars-08.06.26.ebuild,v 1.1 2008/08/23 13:27:42 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/mars/mars-1.0.1.ebuild,v 1.1 2008/11/14 12:06:05 lu_zero Exp $
inherit autotools
+MY_P=${P/mars/mars-src}
+
DESCRIPTION="Multicore Application Runtime System"
HOMEPAGE="ftp://ftp.infradead.org/pub/Sony-PS3/mars/"
-SRC_URI="ftp://ftp.infradead.org/pub/Sony-PS3/mars/${P}.tar.gz"
+SRC_URI="ftp://ftp.infradead.org/pub/Sony-PS3/mars/1.0.1/${MY_P}.tar.gz"
-LICENSE="MARS"
+LICENSE="MIT_Plus MIT"
SLOT="0"
KEYWORDS="~ppc64"
IUSE=""
@@ -16,14 +18,14 @@ IUSE=""
DEPEND="sys-libs/libspe2"
RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}/core"
+
src_unpack () {
unpack ${A}
cd "${S}"
- # repeat after me: "dummy triplet are bogus"
- sed -i -e "s:ppu-::" -e "s:spu:spu-elf:g" \
- -e "s:embedspu-elf:embedspu:" src/mpu/configure.ac || die
- sed -i -e "s:ppu:${CHOST}:" src/host/configure.ac || die
- sed -i -e "s:spu/include:spu-elf/include:" include/Makefile.am || die
+ # repeat after me: "dummy tuples are bogus"
+ sed -i -e "s:/spu:/spu-elf:" \
+ -e "s:--host=spu:--host=spu-elf:" configure.ac
eautoreconf
}
@@ -31,7 +33,7 @@ src_compile () {
unset CFLAGS
unset CXXFLAGS
unset CFLAGS_ppc64
- econf || die
+ econf --with-mars-platform=cell || die
emake || die
}