summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-06-07 13:13:23 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-06-07 13:13:23 +0000
commita008c3918e8234675a49e17393cfc5f2a7a2a9c0 (patch)
treedef1f9f1cc9c7f9909d0c67e36088f859b65e866 /sys-libs/libutempter
parentmirrors to mirror, fixes #135898 (diff)
downloadgentoo-2-a008c3918e8234675a49e17393cfc5f2a7a2a9c0.tar.gz
gentoo-2-a008c3918e8234675a49e17393cfc5f2a7a2a9c0.tar.bz2
gentoo-2-a008c3918e8234675a49e17393cfc5f2a7a2a9c0.zip
support ROOT at SpankY's request
(Portage version: 2.1_rc4-r3)
Diffstat (limited to 'sys-libs/libutempter')
-rw-r--r--sys-libs/libutempter/ChangeLog6
-rw-r--r--sys-libs/libutempter/libutempter-1.1.2.1.ebuild21
-rw-r--r--sys-libs/libutempter/libutempter-1.1.4.1.ebuild21
3 files changed, 23 insertions, 25 deletions
diff --git a/sys-libs/libutempter/ChangeLog b/sys-libs/libutempter/ChangeLog
index 63a7601e81f1..ec64c64a2a11 100644
--- a/sys-libs/libutempter/ChangeLog
+++ b/sys-libs/libutempter/ChangeLog
@@ -1,11 +1,15 @@
# ChangeLog for sys-libs/libutempter
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/ChangeLog,v 1.10 2006/06/07 12:03:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/ChangeLog,v 1.11 2006/06/07 13:13:23 seemant Exp $
07 Jun 2006; Diego Pettenò <flameeyes@gentoo.org>
libutempter-1.1.4.1.ebuild:
Re-add ~x86-fbsd keyword after adding linking with -lutil on FreeBSD.
+ 07 Jun 2006; Seemant Kulleen <seemant@gentoo.org>
+ libutempter-1.1.2.1.ebuild, libutempter-1.1.4.1.ebuild:
+ support ROOT at SpankY's request
+
24 May 2006; Diego Pettenò <flameeyes@gentoo.org>
libutempter-1.1.2.1.ebuild:
Use the right compiler so that cross-distcc does not fail.
diff --git a/sys-libs/libutempter/libutempter-1.1.2.1.ebuild b/sys-libs/libutempter/libutempter-1.1.2.1.ebuild
index 1c341c914cbb..424ce1a0e00a 100644
--- a/sys-libs/libutempter/libutempter-1.1.2.1.ebuild
+++ b/sys-libs/libutempter/libutempter-1.1.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/libutempter-1.1.2.1.ebuild,v 1.11 2006/05/24 21:00:04 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/libutempter-1.1.2.1.ebuild,v 1.12 2006/06/07 13:13:23 seemant Exp $
inherit rpm eutils flag-o-matic versionator toolchain-funcs
@@ -64,18 +64,15 @@ src_install() {
pkg_postinst() {
- if [ "${ROOT}" = "/" ]
+ if [ -f ${ROOT}/var/log/wtmp ]
then
- if [ -f /var/log/wtmp ]
- then
- chown root:utmp /var/log/wtmp
- chmod 664 /var/log/wtmp
- fi
+ chown root:utmp ${ROOT}/var/log/wtmp
+ chmod 664 ${ROOT}/var/log/wtmp
+ fi
- if [ -f /var/run/utmp ]
- then
- chown root:utmp /var/run/utmp
- chmod 664 /var/run/utmp
- fi
+ if [ -f ${ROOT}/var/run/utmp ]
+ then
+ chown root:utmp ${ROOT}/var/run/utmp
+ chmod 664 ${ROOT}/var/run/utmp
fi
}
diff --git a/sys-libs/libutempter/libutempter-1.1.4.1.ebuild b/sys-libs/libutempter/libutempter-1.1.4.1.ebuild
index 5307e7d806d4..1eb8406a4b3d 100644
--- a/sys-libs/libutempter/libutempter-1.1.4.1.ebuild
+++ b/sys-libs/libutempter/libutempter-1.1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/libutempter-1.1.4.1.ebuild,v 1.2 2006/06/07 12:03:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/libutempter-1.1.4.1.ebuild,v 1.3 2006/06/07 13:13:23 seemant Exp $
inherit rpm eutils flag-o-matic versionator toolchain-funcs
@@ -51,18 +51,15 @@ src_install() {
pkg_postinst() {
- if [ "${ROOT}" = "/" ]
+ if [ -f ${ROOT}/var/log/wtmp ]
then
- if [ -f /var/log/wtmp ]
- then
- chown root:utmp /var/log/wtmp
- chmod 664 /var/log/wtmp
- fi
+ chown root:utmp ${ROOT}/var/log/wtmp
+ chmod 664 ${ROOT}/var/log/wtmp
+ fi
- if [ -f /var/run/utmp ]
- then
- chown root:utmp /var/run/utmp
- chmod 664 /var/run/utmp
- fi
+ if [ -f ${ROOT}/var/run/utmp ]
+ then
+ chown root:utmp ${ROOT}/var/run/utmp
+ chmod 664 ${ROOT}/var/run/utmp
fi
}