summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2005-05-13 21:05:13 +0000
committerSeemant Kulleen <seemant@gentoo.org>2005-05-13 21:05:13 +0000
commit5bb16d7d0a56b095f0d7cd6241fc1bb891fc1515 (patch)
treef7cfdf8efd6034c6ac2036b0491734321e4eedf2 /sys-libs/libutempter
parentstable on hppa (diff)
downloadgentoo-2-5bb16d7d0a56b095f0d7cd6241fc1bb891fc1515.tar.gz
gentoo-2-5bb16d7d0a56b095f0d7cd6241fc1bb891fc1515.tar.bz2
gentoo-2-5bb16d7d0a56b095f0d7cd6241fc1bb891fc1515.zip
New package as a replacement for sys-apps/utempter. This seems to be the package we will move to as the preferred utempter, as it works better for freebsd, and also mike harris of redhat/freedesktop is rumoured to be rejumping the development of this
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-libs/libutempter')
-rw-r--r--sys-libs/libutempter/ChangeLog14
-rw-r--r--sys-libs/libutempter/Manifest2
-rw-r--r--sys-libs/libutempter/files/digest-libutempter-1.1.2.12
-rw-r--r--sys-libs/libutempter/libutempter-1.1.2.1.ebuild81
-rw-r--r--sys-libs/libutempter/metadata.xml9
5 files changed, 108 insertions, 0 deletions
diff --git a/sys-libs/libutempter/ChangeLog b/sys-libs/libutempter/ChangeLog
new file mode 100644
index 000000000000..fe882dd0ce2d
--- /dev/null
+++ b/sys-libs/libutempter/ChangeLog
@@ -0,0 +1,14 @@
+# ChangeLog for sys-libs/libutempter
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/ChangeLog,v 1.1 2005/05/13 21:05:13 seemant Exp $
+
+*libutempter-1.1.2.1 (13 May 2005)
+
+ 13 May 2005; Seemant Kulleen <seemant@gentoo.org>
+ +libutempter-1.1.2.1.ebuild:
+ New package as a replacement for sys-apps/utempter. This seems to be the
+ package we will move to as the preferred utempter, as it works better for
+ freebsd, and also mike harris of redhat/freedesktop is rumoured to be
+ rejumping the development of this. At any rate, at least Flameeyes will
+ be happy.
+
diff --git a/sys-libs/libutempter/Manifest b/sys-libs/libutempter/Manifest
new file mode 100644
index 000000000000..bc2a273ca70f
--- /dev/null
+++ b/sys-libs/libutempter/Manifest
@@ -0,0 +1,2 @@
+MD5 01dfd03a707b91a0342688899ff8ca16 libutempter-1.1.2.1.ebuild 1894
+MD5 ffebc89596505e2ec9dc3c4f0851780f files/digest-libutempter-1.1.2.1 146
diff --git a/sys-libs/libutempter/files/digest-libutempter-1.1.2.1 b/sys-libs/libutempter/files/digest-libutempter-1.1.2.1
new file mode 100644
index 000000000000..513a6f432d8e
--- /dev/null
+++ b/sys-libs/libutempter/files/digest-libutempter-1.1.2.1
@@ -0,0 +1,2 @@
+MD5 718df9b195ca947b0e212b96015822f1 libutempter-1.1.2-alt1.src.rpm 20125
+MD5 428f57d482fda1ca1a4199737f0a4c72 libutempter-patches-1.tar.bz2 1968
diff --git a/sys-libs/libutempter/libutempter-1.1.2.1.ebuild b/sys-libs/libutempter/libutempter-1.1.2.1.ebuild
new file mode 100644
index 000000000000..4e71617f8a5b
--- /dev/null
+++ b/sys-libs/libutempter/libutempter-1.1.2.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libutempter/libutempter-1.1.2.1.ebuild,v 1.1 2005/05/13 21:05:13 seemant Exp $
+
+inherit rpm eutils flag-o-matic versionator
+
+MY_P=${PN}-$(replace_version_separator 3 '-alt')
+S=${WORKDIR}/${PN}-$(get_version_component_range 1-3)
+PATCHVER="1"
+DESCRIPTION="Library that allows non-privileged apps to write utmp (login) info, which need root access"
+HOMEPAGE="http://altlinux.org/index.php?module=sisyphus&package=libutempter"
+SRC_URI="ftp://ftp.altlinux.ru/pub/distributions/ALTLinux/Sisyphus/SRPMS.classic/${MY_P}.src.rpm
+ mirror://gentoo/${PN}-patches-${PATCHVER}.tar.bz2"
+
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND="!virtual/utempter"
+PROVIDE="virtual/utempter"
+
+PATCHDIR="${WORKDIR}/gentoo/patches"
+
+pkg_setup() {
+ enewgroup utmp 406
+}
+
+src_unpack() {
+ unpack ${A}
+ rpm_src_unpack
+ cd ${S}
+
+ export EPATCH_SUFFIX="patch"
+ epatch ${PATCHDIR}
+
+ if ! use elibc_glibc && ! use elibc_uclibc
+ then
+ epatch ${PATCHDIR}/freebsd
+ fi
+}
+
+src_compile() {
+ make \
+ RPM_OPT_FLAGS="${CFLAGS}" \
+ libdir=/usr/$(get_libdir) \
+ libexecdir=/usr/$(get_libdir) || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ libdir=/usr/$(get_libdir) \
+ libexecdir=/usr/$(get_libdir) \
+ install || die
+
+ fowners root:utmp /usr/$(get_libdir)/utempter/utempter
+ fperms 2755 /usr/$(get_libdir)/utempter/utempter
+ dodir /usr/sbin
+ dosym ../$(get_libdir)/utempter/utempter /usr/sbin/utempter
+}
+
+
+pkg_postinst() {
+ if [ "${ROOT}" = "/" ]
+ then
+ if [ -f /var/log/wtmp ]
+ then
+ chown root:utmp /var/log/wtmp
+ chmod 664 /var/log/wtmp
+ fi
+
+ if [ -f /var/run/utmp ]
+ then
+ chown root:utmp /var/run/utmp
+ chmod 664 /var/run/utmp
+ fi
+ fi
+}
diff --git a/sys-libs/libutempter/metadata.xml b/sys-libs/libutempter/metadata.xml
new file mode 100644
index 000000000000..e0681d72487b
--- /dev/null
+++ b/sys-libs/libutempter/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<herd>X11</herd>
+<maintainer>
+ <email>seemant@gentoo.org</email>
+</maintainer>
+</pkgmetadata>