summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2005-05-16 16:25:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2005-05-16 16:25:46 +0000
commite1112ea84856b1b8823054167db6ca85848c52de (patch)
tree092d17599110444845d59c81b7cf2a518711835d /sys-libs/libtrash
parentstable on hppa (diff)
downloadgentoo-2-e1112ea84856b1b8823054167db6ca85848c52de.tar.gz
gentoo-2-e1112ea84856b1b8823054167db6ca85848c52de.tar.bz2
gentoo-2-e1112ea84856b1b8823054167db6ca85848c52de.zip
Fixed inheriting gcc, Bug 92745.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-libs/libtrash')
-rw-r--r--sys-libs/libtrash/ChangeLog7
-rw-r--r--sys-libs/libtrash/Manifest6
-rw-r--r--sys-libs/libtrash/libtrash-2.2.ebuild13
3 files changed, 15 insertions, 11 deletions
diff --git a/sys-libs/libtrash/ChangeLog b/sys-libs/libtrash/ChangeLog
index 5722e99e12fc..98a4917a53f7 100644
--- a/sys-libs/libtrash/ChangeLog
+++ b/sys-libs/libtrash/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/libtrash
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/ChangeLog,v 1.5 2004/09/03 18:24:08 pvdabeel Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/ChangeLog,v 1.6 2005/05/16 16:21:18 matsuu Exp $
+
+ 16 May 2005; MATSUU Takuto <matsuu@gentoo.org> libtrash-2.2.ebuild:
+ Fixed inheriting gcc, Bug 92745.
03 Sep 2004; Pieter Van den Abeele <pvdabeel@gentoo.org>
libtrash-2.2.ebuild:
diff --git a/sys-libs/libtrash/Manifest b/sys-libs/libtrash/Manifest
index 83ed92e05315..2c7a3b510f48 100644
--- a/sys-libs/libtrash/Manifest
+++ b/sys-libs/libtrash/Manifest
@@ -1,6 +1,6 @@
MD5 c68f455715a3d4c58b7adf569114087b ChangeLog 648
-MD5 b8e4660c0338956836ec8a3052379213 libtrash-2.2.ebuild 1276
MD5 e10a0da4fac2882942ffa8360ccdd921 metadata.xml 201
-MD5 a165552d7dee01c2d7bbf914ae701cba files/cleanTrash.cron 200
-MD5 8600c86ec08b5db06b59aa2a2e0ec2a3 files/digest-libtrash-2.2 60
+MD5 695a936998846b06c6058e76eba7aa75 libtrash-2.2.ebuild 1379
MD5 02701c7978b919cf96660c80a3ff1a82 files/libtrash-2.2-gentoo.patch 2708
+MD5 8600c86ec08b5db06b59aa2a2e0ec2a3 files/digest-libtrash-2.2 60
+MD5 a165552d7dee01c2d7bbf914ae701cba files/cleanTrash.cron 200
diff --git a/sys-libs/libtrash/libtrash-2.2.ebuild b/sys-libs/libtrash/libtrash-2.2.ebuild
index 5e7a1ac4a132..ef6074ba3702 100644
--- a/sys-libs/libtrash/libtrash-2.2.ebuild
+++ b/sys-libs/libtrash/libtrash-2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/libtrash-2.2.ebuild,v 1.6 2004/09/03 18:24:08 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/libtrash-2.2.ebuild,v 1.7 2005/05/16 16:21:18 matsuu Exp $
-inherit eutils gcc
+inherit eutils toolchain-funcs
DESCRIPTION="provides a trash can by intercepting certain calls to glibc"
HOMEPAGE="http://www.m-arriaga.net/software/libtrash/"
@@ -19,14 +19,15 @@ DEPEND=">=virtual/libc-2.3.2
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}-gentoo.patch
+ sed -i -e "/^INSTLIBDIR/s/lib/$(get_libdir)/" ${S}/src/Makefile || die
}
src_compile() {
- make CC="$(gcc-getCC)" CFLAGS="${CFLAGS}" || die
+ make CC="$(tc-getCC)" CFLAGS="${CFLAGS}" || die
}
src_install() {
- dodir /etc /usr/lib
+ dodir /etc /usr/$(get_libdir)
make DESTDIR=${D} install || die
dosbin cleanTrash/ct2.pl
@@ -44,7 +45,7 @@ pkg_postinst() {
einfo "To use this you have to put the trash library as one"
einfo "of the variables in LD_PRELOAD."
einfo "Example in bash:"
- einfo "export LD_PRELOAD=/usr/lib/libtrash.so"
+ einfo "export LD_PRELOAD=/usr/$(get_libdir)/libtrash.so"
einfo
einfo "Also, see /etc/cron.daily/cleanTrash.cron if you'd like to turn on"
einfo "daily trash cleanup."