summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-03-27 00:27:27 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-03-27 00:27:27 +0000
commitbe1a252e9fa66931477b951708f49bcd34c2ce98 (patch)
tree03c2344bc2015c6a4e95c7fccdf12a3d06f645a5 /sys-libs/libtrash/libtrash-2.2.ebuild
parentVersion bump. Closes bug #45731 and updates the SPARC configuration scripts. (diff)
downloadgentoo-2-be1a252e9fa66931477b951708f49bcd34c2ce98.tar.gz
gentoo-2-be1a252e9fa66931477b951708f49bcd34c2ce98.tar.bz2
gentoo-2-be1a252e9fa66931477b951708f49bcd34c2ce98.zip
Initial import. Bug #17615.
Diffstat (limited to 'sys-libs/libtrash/libtrash-2.2.ebuild')
-rw-r--r--sys-libs/libtrash/libtrash-2.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/sys-libs/libtrash/libtrash-2.2.ebuild b/sys-libs/libtrash/libtrash-2.2.ebuild
new file mode 100644
index 000000000000..609616279ca0
--- /dev/null
+++ b/sys-libs/libtrash/libtrash-2.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libtrash/libtrash-2.2.ebuild,v 1.1 2004/03/27 00:27:27 matsuu Exp $
+
+DESCRIPTION="provides a trash can by intercepting certain calls to glibc"
+HOMEPAGE="http://www.m-arriaga.net/software/libtrash/"
+SRC_URI="http://www.m-arriaga.net/software/libtrash/${P}.tgz"
+
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND=">=virtual/glibc-2.3.2
+ dev-lang/perl"
+
+src_unpack() {
+ unpack ${A}
+
+ epatch ${FILESDIR}/${P}-gentoo.patch
+}
+
+src_compile() {
+ make CC="${CC}" CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dodir /etc /usr/lib
+ make DESTDIR=${D} install || die
+
+ dosbin cleanTrash/ct2.pl
+ exeinto /etc/cron.daily
+ doexe ${FILESDIR}/cleanTrash.cron
+
+ dodoc CHANGE.LOG README libtrash.conf TODO
+
+ docinto cleanTrash
+ dodoc cleanTrash/README cleanTrash/cleanTrash
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use this you have to put the trash library as one"
+ einfo "of the variables in LD_PRELOAD."
+ einfo "Example in bash:"
+ einfo "export LD_PRELOAD=/usr/lib/libtrash.so"
+ einfo
+ einfo "Also, see /etc/cron.daily/cleanTrash.cron if you'd like to turn on"
+ einfo "daily trash cleanup."
+ einfo
+}