summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2006-07-11 12:19:14 +0000
committerDaniel Black <dragonheart@gentoo.org>2006-07-11 12:19:14 +0000
commitf969b5c8e3aec4739b31f4f8351e2ee4c6865f90 (patch)
treebd0f6a43ebab2a2075ea4398fff7129b68696f7f /sys-libs/libstatgrab/libstatgrab-0.13.ebuild
parentMark 1.0 stable on ia64 (diff)
downloadgentoo-2-f969b5c8e3aec4739b31f4f8351e2ee4c6865f90.tar.gz
gentoo-2-f969b5c8e3aec4739b31f4f8351e2ee4c6865f90.tar.bz2
gentoo-2-f969b5c8e3aec4739b31f4f8351e2ee4c6865f90.zip
version bump + cleanout
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'sys-libs/libstatgrab/libstatgrab-0.13.ebuild')
-rw-r--r--sys-libs/libstatgrab/libstatgrab-0.13.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/sys-libs/libstatgrab/libstatgrab-0.13.ebuild b/sys-libs/libstatgrab/libstatgrab-0.13.ebuild
new file mode 100644
index 000000000000..26cd3a1dd6cb
--- /dev/null
+++ b/sys-libs/libstatgrab/libstatgrab-0.13.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libstatgrab/libstatgrab-0.13.ebuild,v 1.1 2006/07/11 12:19:14 dragonheart Exp $
+
+DESCRIPTION="Provides cross platform access to statistics about the system on which it's run."
+HOMEPAGE="http://www.i-scream.org/libstatgrab/"
+SRC_URI="http://www.mirrorservice.org/sites/ftp.i-scream.org/pub/i-scream/libstatgrab/${P}.tar.gz"
+
+LICENSE="|| ( GPL-2 LGPL-2.1 )"
+SLOT=0
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
+IUSE=""
+RDEPEND=">=sys-libs/ncurses-5.4-r1
+ virtual/libc"
+
+DEPEND="${RDEPEND}
+ sys-apps/gawk
+ sys-apps/grep
+ sys-devel/gcc
+ dev-util/pkgconfig"
+
+src_compile() {
+ econf --disable-setgid-binaries --disable-setuid-binaries \
+ --disable-deprecated --with-ncurses || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "einstall failed"
+ dodoc ChangeLog PLATFORMS NEWS AUTHORS README
+}