summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-06-18 03:58:27 +0000
committerMike Frysinger <vapier@gentoo.org>2013-06-18 03:58:27 +0000
commit061904d03ace3087cd465e43503bc66a572e8f16 (patch)
tree0e4830142f0ca093c37ca9b5a58955904e864f52 /sys-libs/libseccomp
parentclean old; add slot dep for gtk+ (diff)
downloadgentoo-2-061904d03ace3087cd465e43503bc66a572e8f16.tar.gz
gentoo-2-061904d03ace3087cd465e43503bc66a572e8f16.tar.bz2
gentoo-2-061904d03ace3087cd465e43503bc66a572e8f16.zip
Version bump #473626 by Paul Moore. Set V=1 when building #451820 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha179/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs/libseccomp')
-rw-r--r--sys-libs/libseccomp/ChangeLog8
-rw-r--r--sys-libs/libseccomp/libseccomp-2.1.0.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/libseccomp/ChangeLog b/sys-libs/libseccomp/ChangeLog
index 8925bbfeb5ac..62c065b419b6 100644
--- a/sys-libs/libseccomp/ChangeLog
+++ b/sys-libs/libseccomp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libseccomp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libseccomp/ChangeLog,v 1.7 2013/01/22 17:26:00 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libseccomp/ChangeLog,v 1.8 2013/06/18 03:58:27 vapier Exp $
+
+*libseccomp-2.1.0 (18 Jun 2013)
+
+ 18 Jun 2013; Mike Frysinger <vapier@gentoo.org> +libseccomp-2.1.0.ebuild:
+ Version bump #473626 by Paul Moore. Set V=1 when building #451820 by Agostino
+ Sarubbo.
22 Jan 2013; Agostino Sarubbo <ago@gentoo.org> libseccomp-1.0.1.ebuild:
Stable for x86, wrt bug #451496
diff --git a/sys-libs/libseccomp/libseccomp-2.1.0.ebuild b/sys-libs/libseccomp/libseccomp-2.1.0.ebuild
new file mode 100644
index 000000000000..649a007976ce
--- /dev/null
+++ b/sys-libs/libseccomp/libseccomp-2.1.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libseccomp/libseccomp-2.1.0.ebuild,v 1.1 2013/06/18 03:58:27 vapier Exp $
+
+# Note: USE=static-libs isn't great -- only PIC objects are provided.
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="high level interface to Linux seccomp filter"
+HOMEPAGE="http://sourceforge.net/projects/libseccomp/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ sed -i \
+ -e '/^SUBDIRS_BUILD/s:tests::' \
+ Makefile || die
+ sed -i \
+ -e '/^LDFLAGS/s|:=|+=|' \
+ {tests,tools}/Makefile || die
+ export MAKEOPTS+=" V=1"
+ tc-export AR CC
+ export GCC=${CC}
+}
+
+src_test() {
+ emake SUBDIRS_BUILD='tests'
+ cd tests
+ ./regression || die
+}
+
+src_install() {
+ default
+ use static-libs && dolib.a src/libseccomp.a
+}