summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-03-02 17:03:10 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-03-02 17:03:10 +0000
commitec503422b0a6f4540ea8b21c1cc7a6fa7624cf6d (patch)
tree6ba2ee546e9d9aa9cc7c19277593c66e8fd62d2b /sys-libs/libsafe
parentadding initial support for s390 (diff)
downloadgentoo-2-ec503422b0a6f4540ea8b21c1cc7a6fa7624cf6d.tar.gz
gentoo-2-ec503422b0a6f4540ea8b21c1cc7a6fa7624cf6d.tar.bz2
gentoo-2-ec503422b0a6f4540ea8b21c1cc7a6fa7624cf6d.zip
Initial import.
Diffstat (limited to 'sys-libs/libsafe')
-rw-r--r--sys-libs/libsafe/ChangeLog10
-rw-r--r--sys-libs/libsafe/Manifest2
-rw-r--r--sys-libs/libsafe/files/digest-libsafe-2.0_p161
-rw-r--r--sys-libs/libsafe/libsafe-2.0_p16.ebuild60
-rw-r--r--sys-libs/libsafe/metadata.xml8
5 files changed, 81 insertions, 0 deletions
diff --git a/sys-libs/libsafe/ChangeLog b/sys-libs/libsafe/ChangeLog
new file mode 100644
index 000000000000..955435ab6aba
--- /dev/null
+++ b/sys-libs/libsafe/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sys-libs/libsafe
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/ChangeLog,v 1.1 2004/03/02 17:03:10 matsuu Exp $
+
+*libsafe-2.0_p16 (03 Mar 2004)
+
+ 03 Mar 2004; <matsuu@gentoo.org> libsafe-2.0_p16.ebuild:
+ Initial import. Ebuild submitted by Daniel Black <groover@playful.com>.
+ Bug #14720.
+
diff --git a/sys-libs/libsafe/Manifest b/sys-libs/libsafe/Manifest
new file mode 100644
index 000000000000..65e7af8d5256
--- /dev/null
+++ b/sys-libs/libsafe/Manifest
@@ -0,0 +1,2 @@
+MD5 0df3ec64b12b9446345f77e15a1e2fdc libsafe-2.0_p16.ebuild 1594
+MD5 4802aa342dde49b03cd59d85b07e801c files/digest-libsafe-2.0_p16 63
diff --git a/sys-libs/libsafe/files/digest-libsafe-2.0_p16 b/sys-libs/libsafe/files/digest-libsafe-2.0_p16
new file mode 100644
index 000000000000..fdd539b81368
--- /dev/null
+++ b/sys-libs/libsafe/files/digest-libsafe-2.0_p16
@@ -0,0 +1 @@
+MD5 6b7b6e6df84d4afb469ccc66d04fc24d libsafe-2.0-16.tgz 360508
diff --git a/sys-libs/libsafe/libsafe-2.0_p16.ebuild b/sys-libs/libsafe/libsafe-2.0_p16.ebuild
new file mode 100644
index 000000000000..933e6f10f5c9
--- /dev/null
+++ b/sys-libs/libsafe/libsafe-2.0_p16.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/libsafe-2.0_p16.ebuild,v 1.1 2004/03/02 17:03:10 matsuu Exp $
+
+MY_P="${P/_p/-}"
+DESCRIPTION="Protection against buffer overflow vulnerabilities"
+HOMEPAGE="http://www.research.avayalabs.com/project/libsafe/index.html"
+SRC_URI="http://www.research.avayalabs.com/project/libsafe/src/${MY_P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="prelude"
+
+DEPEND="virtual/glibc
+ prelude? ( dev-libs/libprelude )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local mycflags=""
+
+ mycflags="${mycflags} ${CFLAGS}"
+ mycflags="${mycflags} -DLIBSAFE_VERSION=\"\$(VERSION)\""
+ use prelude && mycflags="${mycflags} \$(LIBPRELUDE_CFLAGS)"
+
+ # Note email notification currently not implimented in this ebuild
+ # due to I cannot work out if a mta is on localhost:25 for it.
+ # It safer not too assume it is. Uncomment the following if desired
+ # use mta && mycflags="${mycflags} -DNOTIFY_WITH_EMAIL"
+
+ emake CC="${CC}" CFLAGS="${mycflags}" || die
+}
+
+src_install() {
+
+ # libsafe stuff
+ into /
+ dolib.so src/libsafe.so.${PV/_p/.} || die
+ # dodir /lib
+ dosym libsafe.so.${PV/_p/.} /lib/libsafe.so || die
+ dosym libsafe.so.${PV/_p/.} /lib/libsafe.so.${PV%%.*} || die
+
+ # Documentation
+ doman doc/libsafe.8
+ dohtml doc/libsafe.8.html
+
+ dodoc COPYING README INSTALL
+ use prelude && dodoc LIBPRELUDE
+ # use mta && dodoc EMAIL_NOTIFICATION
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use this you have to put the library as one of the variables"
+ einfo "in LD_PRELOAD."
+ einfo "Example in bash:"
+ einfo "export LD_PRELOAD=/lib/libsafe.so.${PV%%.*}"
+ einfo
+}
diff --git a/sys-libs/libsafe/metadata.xml b/sys-libs/libsafe/metadata.xml
new file mode 100644
index 000000000000..e8268537c302
--- /dev/null
+++ b/sys-libs/libsafe/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>matsuu@gentoo.org</email>
+</maintainer>
+<longdescription>The libsafe library protects a process against the exploitation of buffer overflow vulnerabilities in process stacks. Libsafe works with any existing pre-compiled executable (but is incompatible with libc5-linked processes) and can be used transparently, even on a system-wide basis.</longdescription>
+</pkgmetadata>