summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2004-11-06 04:57:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2004-11-06 04:57:28 +0000
commit9309cc79662eca957557ece89c9664b582d78210 (patch)
tree91e7186e716f3881de1ead54f8b6309a503588b1 /sys-libs/libsafe
parent~ppc keyworded as per bug #70096 (Manifest recommit) (diff)
downloadgentoo-2-9309cc79662eca957557ece89c9664b582d78210.tar.gz
gentoo-2-9309cc79662eca957557ece89c9664b582d78210.tar.bz2
gentoo-2-9309cc79662eca957557ece89c9664b582d78210.zip
Fixed ${CC} to $(tc-getCC). bugs 70115.
Diffstat (limited to 'sys-libs/libsafe')
-rw-r--r--sys-libs/libsafe/ChangeLog8
-rw-r--r--sys-libs/libsafe/Manifest4
-rw-r--r--sys-libs/libsafe/files/digest-libsafe-2.0_p16-r11
-rw-r--r--sys-libs/libsafe/libsafe-2.0_p16-r1.ebuild62
4 files changed, 73 insertions, 2 deletions
diff --git a/sys-libs/libsafe/ChangeLog b/sys-libs/libsafe/ChangeLog
index d1a6c2e94fe9..5536b4dad172 100644
--- a/sys-libs/libsafe/ChangeLog
+++ b/sys-libs/libsafe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/libsafe
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/ChangeLog,v 1.3 2004/07/02 08:47:38 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/ChangeLog,v 1.4 2004/11/06 04:57:28 matsuu Exp $
+
+*libsafe-2.0_p16-r1 (06 Nov 2004)
+
+ 06 Nov 2004; MATSUU Takuto <matsuu@gentoo.org> +libsafe-2.0_p16-r1.ebuild:
+ Fixed ${CC} to $(tc-getCC). bugs 70115.
+ Added ~amd64 to KEYWORDS.
02 Jul 2004; Jeremy Huddleston <eradicator@gentoo.org>
libsafe-2.0_p16.ebuild:
diff --git a/sys-libs/libsafe/Manifest b/sys-libs/libsafe/Manifest
index a008e1e9374b..03e0cd4c0a9c 100644
--- a/sys-libs/libsafe/Manifest
+++ b/sys-libs/libsafe/Manifest
@@ -1,4 +1,6 @@
-MD5 91063604d95e341746e9a7aac643eb00 ChangeLog 505
+MD5 982e1da9c8f6831f848b7f4231c7eacf libsafe-2.0_p16-r1.ebuild 1726
MD5 4b3afebbb670945ab28ecaee9f78a020 libsafe-2.0_p16.ebuild 1688
+MD5 91063604d95e341746e9a7aac643eb00 ChangeLog 505
MD5 bb8d0a4581b8faf1798232a83d6b2553 metadata.xml 520
+MD5 4802aa342dde49b03cd59d85b07e801c files/digest-libsafe-2.0_p16-r1 63
MD5 4802aa342dde49b03cd59d85b07e801c files/digest-libsafe-2.0_p16 63
diff --git a/sys-libs/libsafe/files/digest-libsafe-2.0_p16-r1 b/sys-libs/libsafe/files/digest-libsafe-2.0_p16-r1
new file mode 100644
index 000000000000..fdd539b81368
--- /dev/null
+++ b/sys-libs/libsafe/files/digest-libsafe-2.0_p16-r1
@@ -0,0 +1 @@
+MD5 6b7b6e6df84d4afb469ccc66d04fc24d libsafe-2.0-16.tgz 360508
diff --git a/sys-libs/libsafe/libsafe-2.0_p16-r1.ebuild b/sys-libs/libsafe/libsafe-2.0_p16-r1.ebuild
new file mode 100644
index 000000000000..b5f3fb587f4c
--- /dev/null
+++ b/sys-libs/libsafe/libsafe-2.0_p16-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libsafe/libsafe-2.0_p16-r1.ebuild,v 1.1 2004/11/06 04:57:28 matsuu Exp $
+
+inherit toolchain-funcs
+
+MY_P="${P/_p/-}"
+DESCRIPTION="Protection against buffer overflow vulnerabilities"
+HOMEPAGE="http://www.research.avayalabs.com/project/libsafe/index.html"
+SRC_URI="http://www.research.avayalabs.com/project/libsafe/src/${MY_P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="prelude"
+
+DEPEND="virtual/libc
+ prelude? ( dev-libs/libprelude )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local mycflags=""
+
+ mycflags="${mycflags} ${CFLAGS}"
+ mycflags="${mycflags} -DLIBSAFE_VERSION=\"\$(VERSION)\""
+ use prelude && mycflags="${mycflags} \$(LIBPRELUDE_CFLAGS)"
+
+ # Note email notification currently not implimented in this ebuild
+ # due to I cannot work out if a mta is on localhost:25 for it.
+ # It safer not too assume it is. Uncomment the following if desired
+ # use mta && mycflags="${mycflags} -DNOTIFY_WITH_EMAIL"
+
+ emake CC="$(tc-getCC)" CFLAGS="${mycflags}" || die
+}
+
+src_install() {
+
+ # libsafe stuff
+ into /
+ dolib.so src/libsafe.so.${PV/_p/.} || die
+ # dodir /lib
+ dosym libsafe.so.${PV/_p/.} /lib/libsafe.so || die
+ dosym libsafe.so.${PV/_p/.} /lib/libsafe.so.${PV%%.*} || die
+
+ # Documentation
+ doman doc/libsafe.8
+ dohtml doc/libsafe.8.html
+
+ dodoc COPYING README INSTALL
+ use prelude && dodoc LIBPRELUDE
+ # use mta && dodoc EMAIL_NOTIFICATION
+}
+
+pkg_postinst() {
+ einfo
+ einfo "To use this you have to put the library as one of the variables"
+ einfo "in LD_PRELOAD."
+ einfo "Example in bash:"
+ einfo "export LD_PRELOAD=/lib/libsafe.so.${PV%%.*}"
+ einfo
+}