summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-11-01 17:38:32 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-11-01 17:38:32 +0000
commit2f363352128ee20610582494377d9b79eb941030 (patch)
treeb4c229b03056cdb2fad58beffec57c6fefa5d6ba /sys-libs/libcxx
parentupdate description: C++0x -> C++11 (diff)
downloadgentoo-2-2f363352128ee20610582494377d9b79eb941030.tar.gz
gentoo-2-2f363352128ee20610582494377d9b79eb941030.tar.bz2
gentoo-2-2f363352128ee20610582494377d9b79eb941030.zip
remove old
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-libs/libcxx')
-rw-r--r--sys-libs/libcxx/ChangeLog6
-rw-r--r--sys-libs/libcxx/libcxx-0.0_p20120528.ebuild68
2 files changed, 5 insertions, 69 deletions
diff --git a/sys-libs/libcxx/ChangeLog b/sys-libs/libcxx/ChangeLog
index 22f5380aa9bb..db25edf35101 100644
--- a/sys-libs/libcxx/ChangeLog
+++ b/sys-libs/libcxx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-libs/libcxx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.6 2012/11/01 17:37:04 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/ChangeLog,v 1.7 2012/11/01 17:38:32 aballier Exp $
+
+ 01 Nov 2012; Alexis Ballier <aballier@gentoo.org>
+ -libcxx-0.0_p20120528.ebuild:
+ remove old
01 Nov 2012; Alexis Ballier <aballier@gentoo.org>
libcxx-0.0_p20120911.ebuild, libcxx-9999.ebuild:
diff --git a/sys-libs/libcxx/libcxx-0.0_p20120528.ebuild b/sys-libs/libcxx/libcxx-0.0_p20120528.ebuild
deleted file mode 100644
index 7d61fc1bdfb3..000000000000
--- a/sys-libs/libcxx/libcxx-0.0_p20120528.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcxx/libcxx-0.0_p20120528.ebuild,v 1.1 2012/05/28 14:03:08 aballier Exp $
-
-EAPI=4
-
-ESVN_REPO_URI="http://llvm.org/svn/llvm-project/libcxx/trunk"
-
-[ "${PV%9999}" != "${PV}" ] && SCM="subversion" || SCM=""
-
-inherit cmake-utils ${SCM} base flag-o-matic
-
-DESCRIPTION="New implementation of the C++ standard library, targeting C++0X"
-HOMEPAGE="http://libcxx.llvm.org/"
-if [ "${PV%9999}" = "${PV}" ] ; then
- SRC_URI="mirror://gentoo/${P}.tar.xz"
-else
- SRC_URI=""
-fi
-
-LICENSE="|| ( UoI-NCSA MIT )"
-SLOT="0"
-if [ "${PV%9999}" = "${PV}" ] ; then
- KEYWORDS="~amd64"
-else
- KEYWORDS=""
-fi
-IUSE=""
-
-RDEPEND="sys-libs/libcxxrt"
-DEPEND="${RDEPEND}
- sys-devel/clang
- app-arch/xz-utils"
-
-PATCHES=( "${FILESDIR}/multilib.patch"
- "${FILESDIR}/cxxrt.patch" )
-DOCS=( "CREDITS.TXT" )
-
-src_prepare() {
- base_src_prepare
-}
-
-src_configure() {
- append-cppflags "-I/usr/include/libcxxrt -DLIBCXXRT"
- # Needs to be built with clang. gcc-4.6.3 fails at least.
- # TODO: cross-compile ?
- export CC=clang
- export CXX=clang++
- cmake-utils_src_configure
-}
-
-# Tests fail for now, if anybody is able to fix them, help is very welcome.
-src_test() {
- cd "${S}/test"
- LD_LIBRARY_PATH="${CMAKE_BUILD_DIR}/lib:${LD_LIBRARY_PATH}" \
- CC="clang++" \
- HEADER_INCLUDE="-I${S}/include" \
- SOURCE_LIB="-L${CMAKE_BUILD_DIR}/lib" \
- ./testit || die
-}
-
-pkg_postinst() {
- elog "This package (${PN}) is mainly intended as a replacement for the C++"
- elog "standard library when using clang."
- elog "To use it, instead of libstdc++, use:"
- elog " clang++ -stdlib=libc++"
- elog "to compile your C++ programs."
-}