summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-03-02 17:52:37 +0000
committerHanno Böck <hanno@gentoo.org>2009-03-02 17:52:37 +0000
commit738935c593c704dd1f321a42eaf4de79c5f14d38 (patch)
treed2079e22a29f4ddf028b51a2fa64ee6bd4f8b95d /sys-libs/libchipcard
parentgwenhywfar version bump (diff)
downloadgentoo-2-738935c593c704dd1f321a42eaf4de79c5f14d38.tar.gz
gentoo-2-738935c593c704dd1f321a42eaf4de79c5f14d38.tar.bz2
gentoo-2-738935c593c704dd1f321a42eaf4de79c5f14d38.zip
libchipcard bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/libchipcard')
-rw-r--r--sys-libs/libchipcard/ChangeLog9
-rw-r--r--sys-libs/libchipcard/libchipcard-4.2.4.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/sys-libs/libchipcard/ChangeLog b/sys-libs/libchipcard/ChangeLog
index ff7165204196..04d7f5e94a8f 100644
--- a/sys-libs/libchipcard/ChangeLog
+++ b/sys-libs/libchipcard/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libchipcard
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libchipcard/ChangeLog,v 1.74 2008/11/13 23:44:09 hanno Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libchipcard/ChangeLog,v 1.75 2009/03/02 17:52:37 hanno Exp $
+
+*libchipcard-4.2.4 (02 Mar 2009)
+
+ 02 Mar 2009; Hanno Boeck <hanno@gentoo.org> +libchipcard-4.2.4.ebuild:
+ Version bump and switch to hal.
*libchipcard-4.2.3 (13 Nov 2008)
diff --git a/sys-libs/libchipcard/libchipcard-4.2.4.ebuild b/sys-libs/libchipcard/libchipcard-4.2.4.ebuild
new file mode 100644
index 000000000000..0086360a4397
--- /dev/null
+++ b/sys-libs/libchipcard/libchipcard-4.2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libchipcard/libchipcard-4.2.4.ebuild,v 1.1 2009/03/02 17:52:37 hanno Exp $
+
+DESCRIPTION="Libchipcard is a library for easy access to chip cards via chip card readers (terminals)."
+HOMEPAGE="http://www.libchipcard.de"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug doc ssl usb"
+
+DEPEND=">=sys-libs/gwenhywfar-3.4.1
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ usb? ( dev-libs/libusb )
+ sys-apps/hal"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P}"
+
+src_compile() {
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable usb libusb` \
+ --localstatedir=/var \
+ --enable-pcsc || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ keepdir /var/log/chipcard \
+ /var/lib/chipcardd/newcerts \
+ /usr/lib/chipcardd/server/lowlevel
+
+ doinitd "${FILESDIR}/chipcardd4" || die
+
+ dodoc AUTHORS ChangeLog README doc/CERTIFICATES doc/CONFIG doc/IPCCOMMANDS || die
+ if use doc ; then
+ docinto tutorials
+ dodoc tutorials/*.{c,h,xml} tutorials/README || die
+ fi
+
+ find "${D}" -name '*.la' -delete
+}