summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2006-03-26 20:52:11 +0000
committerHanno Böck <hanno@gentoo.org>2006-03-26 20:52:11 +0000
commitd55be7cda1c4c82f1b8899d95eeb3494c2eba88f (patch)
tree9cddcb5b095e0f138a26f11c956707443958265b /sys-libs/gwenhywfar
parentMark 3.4.3 stable on ia64 (diff)
downloadgentoo-2-d55be7cda1c4c82f1b8899d95eeb3494c2eba88f.tar.gz
gentoo-2-d55be7cda1c4c82f1b8899d95eeb3494c2eba88f.tar.bz2
gentoo-2-d55be7cda1c4c82f1b8899d95eeb3494c2eba88f.zip
gwenhywfar version bump
(Portage version: 2.1_pre7-r1)
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-2.1.13
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 3f133ec9b536..1e3c0907897f 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.26 2006/03/22 16:15:27 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.27 2006/03/26 20:52:11 hanno Exp $
+
+*gwenhywfar-2.1.1 (26 Mar 2006)
+
+ 26 Mar 2006; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-2.1.1.ebuild:
+ Version bump.
*gwenhywfar-2.1.0 (22 Mar 2006)
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-2.1.1 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-2.1.1
new file mode 100644
index 000000000000..b1cf82c93279
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-2.1.1
@@ -0,0 +1,3 @@
+MD5 8578b610c366d2c667242c5562647649 gwenhywfar-2.1.1.tar.gz 1136812
+RMD160 7159dbe8d400f36aea4b84d5c0c0c7cba625aff3 gwenhywfar-2.1.1.tar.gz 1136812
+SHA256 585961c9b1f85fac768aabbd3b6a944c21a4cd0eb9ef42783a0b2bfb2f1003ae gwenhywfar-2.1.1.tar.gz 1136812
diff --git a/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild b/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild
new file mode 100644
index 000000000000..40535757dc5f
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-2.1.1.ebuild,v 1.1 2006/03/26 20:52:11 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )
+ ncurses? ( sys-libs/ncurses )"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ `use_enable ncurses gwenui` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}