summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2010-12-15 19:26:01 +0000
committerHanno Böck <hanno@gentoo.org>2010-12-15 19:26:01 +0000
commitc6cf557d82d502db8a51b1f5c321adc94b20b42c (patch)
tree44012ea79b47bd84f60e095f3ff0c33e108f0775 /sys-libs/gwenhywfar
parentStable on alpha, bug #312385 (diff)
downloadgentoo-2-c6cf557d82d502db8a51b1f5c321adc94b20b42c.tar.gz
gentoo-2-c6cf557d82d502db8a51b1f5c321adc94b20b42c.tar.bz2
gentoo-2-c6cf557d82d502db8a51b1f5c321adc94b20b42c.zip
gwenhywfar bump
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-4.0.2.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 48f6051313bf..ec09944e9747 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.82 2010/11/03 12:17:49 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.83 2010/12/15 19:26:01 hanno Exp $
+
+*gwenhywfar-4.0.2 (15 Dec 2010)
+
+ 15 Dec 2010; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-4.0.2.ebuild:
+ Version bump.
*gwenhywfar-4.0.1 (03 Nov 2010)
diff --git a/sys-libs/gwenhywfar/gwenhywfar-4.0.2.ebuild b/sys-libs/gwenhywfar/gwenhywfar-4.0.2.ebuild
new file mode 100644
index 000000000000..413c91ee0a27
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-4.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-4.0.2.ebuild,v 1.1 2010/12/15 19:26:01 hanno Exp $
+
+EAPI=2
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://www.aquamaniac.de/aqbanking/"
+SRC_URI="http://www.aquamaniac.de/sites/download/download.php?package=01&release=55&file=01&dummy=${P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc fox gtk qt4"
+
+RDEPEND="dev-libs/libgpg-error
+ >=dev-libs/libgcrypt-1.2.0
+ >=dev-libs/openssl-1.0.0
+ >=net-libs/gnutls-2.0.1
+ virtual/libiconv
+ virtual/libintl
+ fox? ( x11-libs/fox:1.6 )
+ gtk? ( >=x11-libs/gtk+-2.17.5:2 )
+ qt4? ( x11-libs/qt-gui:4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ local guis
+ use fox && guis="${guis} fox"
+ use gtk && guis="${guis} gtk2"
+ use qt4 && guis="${guis} qt4"
+
+ econf \
+ --disable-dependency-tracking \
+ --enable-ssl \
+ --enable-visibility \
+ $(use_enable debug) \
+ $(use_enable doc full-doc) \
+ --with-guis="${guis}" \
+ --with-docpath=/usr/share/doc/${PF}/apidoc
+}
+
+src_compile() {
+ emake || die
+
+ if use doc; then
+ emake srcdoc || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog README TODO
+
+ if use doc; then
+ emake DESTDIR="${D}" install-srcdoc || die
+ fi
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}