summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2009-06-04 20:19:29 +0000
committerHanno Böck <hanno@gentoo.org>2009-06-04 20:19:29 +0000
commit87777c3ea36db99bb73f9469970d4ff0bc8cd276 (patch)
treee1b2ddc19b7779e4a38244f30cd850b7138b6cd2 /sys-libs/gwenhywfar
parentStable on alpha, bug #271122 (diff)
downloadgentoo-2-87777c3ea36db99bb73f9469970d4ff0bc8cd276.tar.gz
gentoo-2-87777c3ea36db99bb73f9469970d4ff0bc8cd276.tar.bz2
gentoo-2-87777c3ea36db99bb73f9469970d4ff0bc8cd276.zip
gwenhywfar bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-3.8.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index 339d1d831ca4..a7ec9be548c8 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.66 2009/05/23 13:47:32 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.67 2009/06/04 20:19:29 hanno Exp $
+
+*gwenhywfar-3.8.2 (04 Jun 2009)
+
+ 04 Jun 2009; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-3.8.2.ebuild:
+ Version bump.
23 May 2009; Hanno Boeck <hanno@gentoo.org> gwenhywfar-3.8.1.ebuild:
Add dependency to libtool 2.
diff --git a/sys-libs/gwenhywfar/gwenhywfar-3.8.2.ebuild b/sys-libs/gwenhywfar/gwenhywfar-3.8.2.ebuild
new file mode 100644
index 000000000000..9e0b9b979103
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-3.8.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-3.8.2.ebuild,v 1.1 2009/06/04 20:19:29 hanno Exp $
+
+EAPI="2"
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="http://www2.aquamaniac.de/sites/download/download.php?package=01&release=23&file=01&dummy=${P}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="debug ssl doc"
+
+RDEPEND="ssl? ( net-libs/gnutls )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf --enable-visibility \
+ $(use_enable ssl) \
+ $(use_enable debug) \
+ $(use_enable doc full-doc) \
+ --with-docpath="/usr/share/doc/${PF}/apidoc" || die "configure failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc ; then
+ emake srcdoc || die "emake failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc README* AUTHORS ChangeLog TODO || die "dodoc failed"
+ if use doc ; then
+ make DESTDIR="${D}" install-srcdoc || die "install doc failed"
+ fi
+ find "${D}" -name '*.la' -delete
+}