summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-07-12 21:41:32 +0000
committerHanno Böck <hanno@gentoo.org>2005-07-12 21:41:32 +0000
commit6aa1031481111e30ed10130a1fca8426086677fb (patch)
tree8ff68b9c71254bd077380cca685924cc1bf051a6 /sys-libs/gwenhywfar
parentVersion bumped to fix alsasound init script issue, remove postconf, and updat... (diff)
downloadgentoo-2-6aa1031481111e30ed10130a1fca8426086677fb.tar.gz
gentoo-2-6aa1031481111e30ed10130a1fca8426086677fb.tar.bz2
gentoo-2-6aa1031481111e30ed10130a1fca8426086677fb.zip
gwenhywfar Version bump
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.14.01
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.14.0.ebuild39
3 files changed, 46 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index d2cd362f2452..389b582aa2bf 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.11 2005/04/13 07:01:45 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.12 2005/07/12 21:41:32 hanno Exp $
+
+*gwenhywfar-1.14.0 (12 Jul 2005)
+
+ 12 Jul 2005; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-1.14.0.ebuild:
+ Version bump.
*gwenhywfar-1.11.0 (13 Apr 2005)
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.14.0 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.14.0
new file mode 100644
index 000000000000..39c143263fed
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.14.0
@@ -0,0 +1 @@
+MD5 7a155942c19771c498570fd168ac006e gwenhywfar-1.14.0.tar.gz 1087854
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.14.0.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.14.0.ebuild
new file mode 100644
index 000000000000..8ba307168088
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.14.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.14.0.ebuild,v 1.1 2005/07/12 21:41:32 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~sparc ~alpha ~ppc"
+
+IUSE="debug ssl doc"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}