summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2005-09-26 15:58:07 +0000
committerHanno Böck <hanno@gentoo.org>2005-09-26 15:58:07 +0000
commit21defd05296611e2eedbe61f0cd4c5d4a9b374b7 (patch)
treedf4aa3bff86f52788d2671bd1dafad669d704423 /sys-libs/gwenhywfar
parentFix empty xlibs. Bug #91707 (diff)
downloadgentoo-2-21defd05296611e2eedbe61f0cd4c5d4a9b374b7.tar.gz
gentoo-2-21defd05296611e2eedbe61f0cd4c5d4a9b374b7.tar.bz2
gentoo-2-21defd05296611e2eedbe61f0cd4c5d4a9b374b7.zip
gwenhywfar version bump
(Portage version: 2.0.52-r1)
Diffstat (limited to 'sys-libs/gwenhywfar')
-rw-r--r--sys-libs/gwenhywfar/ChangeLog7
-rw-r--r--sys-libs/gwenhywfar/files/digest-gwenhywfar-1.18.01
-rw-r--r--sys-libs/gwenhywfar/gwenhywfar-1.18.0.ebuild41
3 files changed, 48 insertions, 1 deletions
diff --git a/sys-libs/gwenhywfar/ChangeLog b/sys-libs/gwenhywfar/ChangeLog
index b3d942d9d960..9ffdf9f4d180 100644
--- a/sys-libs/gwenhywfar/ChangeLog
+++ b/sys-libs/gwenhywfar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/gwenhywfar
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.15 2005/09/17 00:44:06 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/ChangeLog,v 1.16 2005/09/26 15:58:07 hanno Exp $
+
+*gwenhywfar-1.18.0 (26 Sep 2005)
+
+ 26 Sep 2005; Hanno Boeck <hanno@gentoo.org> +gwenhywfar-1.18.0.ebuild:
+ Version bump.
17 Sep 2005; Ciaran McCreesh <ciaranm@gentoo.org> ChangeLog:
Converted to UTF-8, fixed encoding screwups
diff --git a/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.18.0 b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.18.0
new file mode 100644
index 000000000000..a2fa9a82fef2
--- /dev/null
+++ b/sys-libs/gwenhywfar/files/digest-gwenhywfar-1.18.0
@@ -0,0 +1 @@
+MD5 3a2aac154dae8f331d5aa8fc052ae52f gwenhywfar-1.18.0.tar.gz 1153882
diff --git a/sys-libs/gwenhywfar/gwenhywfar-1.18.0.ebuild b/sys-libs/gwenhywfar/gwenhywfar-1.18.0.ebuild
new file mode 100644
index 000000000000..1886cda93bd5
--- /dev/null
+++ b/sys-libs/gwenhywfar/gwenhywfar-1.18.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gwenhywfar/gwenhywfar-1.18.0.ebuild,v 1.1 2005/09/26 15:58:07 hanno Exp $
+
+DESCRIPTION="A multi-platform helper library for other libraries"
+HOMEPAGE="http://gwenhywfar.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+
+IUSE="debug ssl doc ncurses"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6b )
+ sys-libs/ncurses
+ doc? ( app-doc/doxygen )
+ ncurses? ( sys-libs/ncurses )"
+
+src_compile() {
+ if use doc; then
+ APIDOC="--with-docpath=/usr/share/doc/${P}/apidoc"
+ fi
+ econf \
+ `use_enable ssl` \
+ `use_enable debug` \
+ `use_enable doc full-doc` \
+ `use_enable ncurses gwenui` \
+ ${APIDOC} || die "configure failed"
+ emake || die "emake failed"
+ if use doc; then
+ emake srcdoc || die "Building the api-doc failed"
+ fi
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc README* AUTHORS ABOUT-NLS COPYING ChangeLog INSTALL TODO
+ if use doc; then
+ make DESTDIR=${D} install-srcdoc || die "Installing the API-Doc failed"
+ fi
+}