summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-12-24 20:39:33 +0000
committerMike Frysinger <vapier@gentoo.org>2010-12-24 20:39:33 +0000
commit20ae5eac96d7ff064844de970dbd83a7f619c6aa (patch)
tree36927363c6de9af2e9d2a6c9718f1a262f0200e2 /sys-libs/gpm
parentold (diff)
downloadgentoo-2-20ae5eac96d7ff064844de970dbd83a7f619c6aa.tar.gz
gentoo-2-20ae5eac96d7ff064844de970dbd83a7f619c6aa.tar.bz2
gentoo-2-20ae5eac96d7ff064844de970dbd83a7f619c6aa.zip
Convert to EAPI=2, use the auto option with gen_usr_ldscript, update HOMEPAGE/SRC_URI #349358 by Mr. Anderson, and add upstream fix for parallel make warnings #206291 by Michael A. Smith.
(Portage version: 2.2.0_alpha10/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/gpm')
-rw-r--r--sys-libs/gpm/ChangeLog8
-rw-r--r--sys-libs/gpm/files/0001-fixup-make-warnings.patch35
-rw-r--r--sys-libs/gpm/gpm-1.20.6.ebuild42
3 files changed, 62 insertions, 23 deletions
diff --git a/sys-libs/gpm/ChangeLog b/sys-libs/gpm/ChangeLog
index 8191422451f3..2b211aa25960 100644
--- a/sys-libs/gpm/ChangeLog
+++ b/sys-libs/gpm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-libs/gpm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.86 2010/10/10 18:49:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/ChangeLog,v 1.87 2010/12/24 20:39:33 vapier Exp $
+
+ 24 Dec 2010; Mike Frysinger <vapier@gentoo.org>
+ +files/0001-fixup-make-warnings.patch, gpm-1.20.6.ebuild:
+ Convert to EAPI=2, use the auto option with gen_usr_ldscript, update
+ HOMEPAGE/SRC_URI #349358 by Mr. Anderson, and add upstream fix for
+ parallel make warnings #206291 by Michael A. Smith.
10 Oct 2010; Raúl Porcel <armin76@gentoo.org> gpm-1.20.6.ebuild:
sparc stable wrt #334967
diff --git a/sys-libs/gpm/files/0001-fixup-make-warnings.patch b/sys-libs/gpm/files/0001-fixup-make-warnings.patch
new file mode 100644
index 000000000000..c55d2f826d01
--- /dev/null
+++ b/sys-libs/gpm/files/0001-fixup-make-warnings.patch
@@ -0,0 +1,35 @@
+From 1bee81778e7355e6b902986b6e0fc5750546444a Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Mon, 16 Feb 2009 15:43:40 -0500
+Subject: [PATCH] fixup make warnings
+
+Split the toplevel dep target to use normal make dependencies and use the
+$(MAKE) var rather than hardcoding `make`.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile.in | 8 +++++---
+ 1 files changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.in b/Makefile.in
+index 90b92d0..89cbb5e 100644
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -26,9 +26,11 @@ SUBDIRS = src doc contrib
+
+ all: do-all
+
+-dep:
+- touch src/$(DEPFILE) # to prevent unecessary warnings
+- make -C src dep
++src/$(DEPFILE):
++ touch $@ # to prevent unecessary warnings
++
++dep: src/$(DEPFILE)
++ $(MAKE) -C src dep
+
+ check: all
+
+--
+1.7.3.1
+
diff --git a/sys-libs/gpm/gpm-1.20.6.ebuild b/sys-libs/gpm/gpm-1.20.6.ebuild
index b81a580a873d..cf5055b6f4cb 100644
--- a/sys-libs/gpm/gpm-1.20.6.ebuild
+++ b/sys-libs/gpm/gpm-1.20.6.ebuild
@@ -1,14 +1,16 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.6.ebuild,v 1.12 2010/10/10 18:49:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/gpm/gpm-1.20.6.ebuild,v 1.13 2010/12/24 20:39:33 vapier Exp $
# emacs support disabled due to #99533 #335900
-inherit eutils toolchain-funcs flag-o-matic
+EAPI="2"
+
+inherit eutils toolchain-funcs
DESCRIPTION="Console-based mouse driver"
-HOMEPAGE="http://linux.schottelius.org/gpm/"
-SRC_URI="http://linux.schottelius.org/gpm/archives/${P}.tar.lzma"
+HOMEPAGE="http://www.nico.schottelius.org/software/gpm/"
+SRC_URI="http://www.nico.schottelius.org/software/${PN}/archives/${P}.tar.lzma"
LICENSE="GPL-2"
SLOT="0"
@@ -19,36 +21,32 @@ DEPEND="sys-libs/ncurses
app-arch/xz-utils"
RDEPEND="selinux? ( sec-policy/selinux-gpm )"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PN}-1.20.5-abi.patch
epatch "${FILESDIR}"/0001-daemon-use-sys-ioctl.h-for-ioctl.patch #222099
+ epatch "${FILESDIR}"/0001-fixup-make-warnings.patch #206291
+
+ # workaround broken release
+ find -name '*.o' -delete
}
-src_compile() {
+src_configure() {
econf \
- --libdir=/$(get_libdir) \
--sysconfdir=/etc/gpm \
- emacs=/bin/false \
- || die "econf failed"
+ emacs=/bin/false
+}
- # workaround broken release
- find -name '*.o' | xargs rm
+src_compile() {
+ # make sure nothing compiled is left
emake clean || die
- emake -j1 -C doc || die
-
- emake EMACS=: || die "emake failed"
+ emake EMACS=: || die
}
src_install() {
- emake install DESTDIR="${D}" EMACS=: ELISP="" || die "make install failed"
+ emake install DESTDIR="${D}" EMACS=: ELISP="" || die
- dosym libgpm.so.1.20.0 /$(get_libdir)/libgpm.so.1
- dosym libgpm.so.1 /$(get_libdir)/libgpm.so
- dodir /usr/$(get_libdir)
- mv "${D}"/$(get_libdir)/libgpm.a "${D}"/usr/$(get_libdir)/ || die
- gen_usr_ldscript libgpm.so
+ dosym libgpm.so.1 /usr/$(get_libdir)/libgpm.so
+ gen_usr_ldscript -a gpm
insinto /etc/gpm
doins conf/gpm-*.conf