summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-09-17 22:53:43 +0000
committerMike Frysinger <vapier@gentoo.org>2014-09-17 22:53:43 +0000
commitf4d55bbcbdc7b344592d83fdc77b65c20c90c66d (patch)
treed94d8df5035bfe90651ac79315006890d7fe7171 /sys-libs/glibc
parentAutomated update. (diff)
downloadgentoo-2-f4d55bbcbdc7b344592d83fdc77b65c20c90c66d.tar.gz
gentoo-2-f4d55bbcbdc7b344592d83fdc77b65c20c90c66d.tar.bz2
gentoo-2-f4d55bbcbdc7b344592d83fdc77b65c20c90c66d.zip
Use `nonfatal` with emake when we check the return value ourselves #522962 by Manuel Lauss.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog7
-rw-r--r--sys-libs/glibc/files/eblits/common.eblit5
-rw-r--r--sys-libs/glibc/files/eblits/pkg_setup.eblit4
-rw-r--r--sys-libs/glibc/files/eblits/src_test.eblit6
4 files changed, 15 insertions, 7 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index e6dda5d30444..a724c6a09026 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.1023 2014/09/16 04:30:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.1024 2014/09/17 22:53:43 vapier Exp $
+
+ 17 Sep 2014; Mike Frysinger <vapier@gentoo.org> files/eblits/common.eblit,
+ files/eblits/pkg_setup.eblit, files/eblits/src_test.eblit:
+ Use `nonfatal` with emake when we check the return value ourselves #522962 by
+ Manuel Lauss.
16 Sep 2014; Mike Frysinger <vapier@gentoo.org> glibc-2.20.ebuild:
Move timezone-data dep to PDEPEND as it only loosely needs it at runtime
diff --git a/sys-libs/glibc/files/eblits/common.eblit b/sys-libs/glibc/files/eblits/common.eblit
index 89c145da562d..eb65d98dc87b 100644
--- a/sys-libs/glibc/files/eblits/common.eblit
+++ b/sys-libs/glibc/files/eblits/common.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.41 2014/09/10 19:15:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.42 2014/09/17 22:53:43 vapier Exp $
alt_prefix() {
is_crosscompile && echo /usr/${CTARGET}
@@ -10,6 +10,9 @@ if [[ ${EAPI:-0} == [012] ]] ; then
: ${ED:=${D}}
: ${EROOT:=${ROOT}}
fi
+if [[ ${EAPI:-0} == [0123] ]] ; then
+ nonfatal() { "$@" ; }
+fi
# We need to be able to set alternative headers for
# compiling for non-native platform
diff --git a/sys-libs/glibc/files/eblits/pkg_setup.eblit b/sys-libs/glibc/files/eblits/pkg_setup.eblit
index 8b8e547d9d73..9d678ff673c6 100644
--- a/sys-libs/glibc/files/eblits/pkg_setup.eblit
+++ b/sys-libs/glibc/files/eblits/pkg_setup.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/pkg_setup.eblit,v 1.12 2014/06/14 22:19:10 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/pkg_setup.eblit,v 1.13 2014/09/17 22:53:43 vapier Exp $
glibc_compile_test() {
local ret save_cflags=${CFLAGS}
@@ -12,7 +12,7 @@ glibc_compile_test() {
rm -f glibc-test*
printf '%b' "$*" > glibc-test.c
- emake -s glibc-test
+ nonfatal emake -s glibc-test
ret=$?
popd >/dev/null
diff --git a/sys-libs/glibc/files/eblits/src_test.eblit b/sys-libs/glibc/files/eblits/src_test.eblit
index 7d08b9395752..210cca3a46d4 100644
--- a/sys-libs/glibc/files/eblits/src_test.eblit
+++ b/sys-libs/glibc/files/eblits/src_test.eblit
@@ -1,12 +1,12 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_test.eblit,v 1.8 2014/09/10 18:15:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_test.eblit,v 1.9 2014/09/17 22:53:43 vapier Exp $
glibc_src_test() {
cd "$(builddir $1)"
- emake -j1 check && return 0
+ nonfatal emake -j1 check && return 0
einfo "make check failed - re-running with --keep-going to get the rest of the results"
- emake -j1 -k check
+ nonfatal emake -j1 -k check
ewarn "make check failed for ${ABI}-${CTARGET}-$1"
return 1
}