summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-09-10 19:15:42 +0000
committerMike Frysinger <vapier@gentoo.org>2014-09-10 19:15:42 +0000
commitb49585d8ea451a5678430fdf181c9b84d5c8e8f1 (patch)
tree8bc1bdbd9c3de74e88319b87b7f3186d7ad0fb2a /sys-libs/glibc
parentUpgrade EAPI to 4 #473728 by Benda Xu. (diff)
downloadgentoo-2-b49585d8ea451a5678430fdf181c9b84d5c8e8f1.tar.gz
gentoo-2-b49585d8ea451a5678430fdf181c9b84d5c8e8f1.tar.bz2
gentoo-2-b49585d8ea451a5678430fdf181c9b84d5c8e8f1.zip
Use SYSROOT when looking for source rather than ROOT #473728 by Benda Xu.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/ChangeLog5
-rw-r--r--sys-libs/glibc/files/eblits/common.eblit4
2 files changed, 6 insertions, 3 deletions
diff --git a/sys-libs/glibc/ChangeLog b/sys-libs/glibc/ChangeLog
index 03e7a9344c6b..ec5a8e2635d7 100644
--- a/sys-libs/glibc/ChangeLog
+++ b/sys-libs/glibc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/glibc
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.1021 2014/09/10 18:57:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/ChangeLog,v 1.1022 2014/09/10 19:15:42 vapier Exp $
+
+ 10 Sep 2014; Mike Frysinger <vapier@gentoo.org> files/eblits/common.eblit:
+ Use SYSROOT when looking for source rather than ROOT #473728 by Benda Xu.
10 Sep 2014; Mike Frysinger <vapier@gentoo.org> glibc-2.20.ebuild:
Upgrade EAPI to 4 #473728 by Benda Xu.
diff --git a/sys-libs/glibc/files/eblits/common.eblit b/sys-libs/glibc/files/eblits/common.eblit
index 2b0c1c96f952..89c145da562d 100644
--- a/sys-libs/glibc/files/eblits/common.eblit
+++ b/sys-libs/glibc/files/eblits/common.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.40 2014/09/10 18:15:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/common.eblit,v 1.41 2014/09/10 19:15:42 vapier Exp $
alt_prefix() {
is_crosscompile && echo /usr/${CTARGET}
@@ -23,7 +23,7 @@ alt_build_headers() {
if [[ -z ${ALT_BUILD_HEADERS} ]] ; then
ALT_BUILD_HEADERS=$(alt_headers)
if tc-is-cross-compiler ; then
- ALT_BUILD_HEADERS=${ROOT}$(alt_headers)
+ ALT_BUILD_HEADERS=${SYSROOT}$(alt_headers)
if [[ ! -e ${ALT_BUILD_HEADERS}/linux/version.h ]] ; then
local header_path=$(echo '#include <linux/version.h>' | $(tc-getCPP ${CTARGET}) ${CFLAGS} 2>&1 | grep -o '[^"]*linux/version.h')
ALT_BUILD_HEADERS=${header_path%/linux/version.h}