summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-08-13 22:48:53 +0000
committerMike Frysinger <vapier@gentoo.org>2012-08-13 22:48:53 +0000
commit9192434249e6b166f8113f2b817a85bf46f859c9 (patch)
tree798adb0753676eade84b46966d79ded4a95cde64 /sys-libs/glibc/glibc-2.9_p20081201-r3.ebuild
parentAdd support for cucumber as a test recipe. This allows abstracting some of th... (diff)
downloadgentoo-2-9192434249e6b166f8113f2b817a85bf46f859c9.tar.gz
gentoo-2-9192434249e6b166f8113f2b817a85bf46f859c9.tar.bz2
gentoo-2-9192434249e6b166f8113f2b817a85bf46f859c9.zip
Tweak CATEGORY processing to make it easier to understand.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sys-libs/glibc/glibc-2.9_p20081201-r3.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.9_p20081201-r3.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-libs/glibc/glibc-2.9_p20081201-r3.ebuild b/sys-libs/glibc/glibc-2.9_p20081201-r3.ebuild
index b05381287488..138ff3242523 100644
--- a/sys-libs/glibc/glibc-2.9_p20081201-r3.ebuild
+++ b/sys-libs/glibc/glibc-2.9_p20081201-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.9_p20081201-r3.ebuild,v 1.16 2012/06/08 22:06:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.9_p20081201-r3.ebuild,v 1.17 2012/08/13 22:48:53 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib multiprocessing
@@ -51,8 +51,8 @@ S=${WORKDIR}/glibc-${RELEASE_VER}${SNAP_VER+-${SNAP_VER}}
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
if [[ ${CTARGET} == ${CHOST} ]] ; then
- if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
- export CTARGET=${CATEGORY/cross-}
+ if [[ ${CATEGORY} == cross-* ]] ; then
+ export CTARGET=${CATEGORY#cross-}
fi
fi
@@ -82,7 +82,7 @@ DEPEND=">=sys-devel/gcc-3.4.4
RDEPEND="!sys-kernel/ps3-sources
selinux? ( sys-libs/libselinux )"
-if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+if [[ ${CATEGORY} == cross-* ]] ; then
DEPEND="${DEPEND} !crosscompile_opts_headers-only? ( ${CATEGORY}/gcc )"
[[ ${CATEGORY} == *-linux* ]] && DEPEND="${DEPEND} ${CATEGORY}/linux-headers"
else