summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-06-23 01:39:13 +0000
committerMike Frysinger <vapier@gentoo.org>2008-06-23 01:39:13 +0000
commit9349f859c6c589041c94855ba9d2b3140d1ba0ba (patch)
tree05097d2acda2237638ab87a65bcdf05314915b10 /sys-libs/glibc/glibc-2.6.1.ebuild
parentRevision bump to add support for the ia32 USE flag to install a 32-bit Opera ... (diff)
downloadgentoo-2-9349f859c6c589041c94855ba9d2b3140d1ba0ba.tar.gz
gentoo-2-9349f859c6c589041c94855ba9d2b3140d1ba0ba.tar.bz2
gentoo-2-9349f859c6c589041c94855ba9d2b3140d1ba0ba.zip
Short circuit header building in pkg testing and ABI recursion.
(Portage version: 2.2_rc1/cvs/Linux 2.6.25 x86_64)
Diffstat (limited to 'sys-libs/glibc/glibc-2.6.1.ebuild')
-rw-r--r--sys-libs/glibc/glibc-2.6.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/sys-libs/glibc/glibc-2.6.1.ebuild b/sys-libs/glibc/glibc-2.6.1.ebuild
index 19449b932395..0c3d455f5629 100644
--- a/sys-libs/glibc/glibc-2.6.1.ebuild
+++ b/sys-libs/glibc/glibc-2.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.6.1.ebuild,v 1.25 2008/06/23 00:48:43 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/glibc-2.6.1.ebuild,v 1.26 2008/06/23 01:39:12 vapier Exp $
inherit eutils versionator libtool toolchain-funcs flag-o-matic gnuconfig multilib
@@ -264,6 +264,9 @@ fix_lib64_symlinks() {
}
pkg_preinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
# PPC64+others may want to eventually be added to this logic if they
# decide to be multilib compatible and FHS compliant. note that this
# chunk of FHS compliance only applies to 64bit archs where 32bit
@@ -306,6 +309,9 @@ pkg_preinst() {
}
pkg_postinst() {
+ # nothing to do if just installing headers
+ just_headers && return
+
if ! tc-is-cross-compiler && [[ -x ${ROOT}/usr/sbin/iconvconfig ]] ; then
# Generate fastloading iconv module configuration file.
"${ROOT}"/usr/sbin/iconvconfig --prefix="${ROOT}"