summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-05-30 05:29:28 +0000
committerMike Frysinger <vapier@gentoo.org>2015-05-30 05:29:28 +0000
commit50cd68b14481c0c74a6556a42081ccf9942ab806 (patch)
treef2250d02d93ed6512a52e314308ff1a71fbf141c /sys-libs/glibc/files
parentFilter out -Wl,--hash-style=gnu for mips targets. (diff)
downloadgentoo-2-50cd68b14481c0c74a6556a42081ccf9942ab806.tar.gz
gentoo-2-50cd68b14481c0c74a6556a42081ccf9942ab806.tar.bz2
gentoo-2-50cd68b14481c0c74a6556a42081ccf9942ab806.zip
Hack around mips compiler settings when generating glibc headers #550192 by Andrew Aladjev.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-libs/glibc/files')
-rw-r--r--sys-libs/glibc/files/eblits/src_configure.eblit10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-libs/glibc/files/eblits/src_configure.eblit b/sys-libs/glibc/files/eblits/src_configure.eblit
index 1aa001c57f6c..6a769ebd0520 100644
--- a/sys-libs/glibc/files/eblits/src_configure.eblit
+++ b/sys-libs/glibc/files/eblits/src_configure.eblit
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_configure.eblit,v 1.6 2015/03/17 00:06:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/glibc/files/eblits/src_configure.eblit,v 1.7 2015/05/30 05:29:28 vapier Exp $
dump_toolchain_settings() {
echo
@@ -206,6 +206,14 @@ toolchain-glibc_headers_configure() {
export ${v}
done
+ # Blow away some random CC settings that screw things up. #550192
+ if [[ -d ${S}/sysdeps/mips ]]; then
+ pushd "${S}"/sysdeps/mips >/dev/null
+ sed -i -e '/^CC +=/s:=.*:= -D_MIPS_SZPTR=32:' mips32/Makefile mips64/n32/Makefile || die
+ sed -i -e '/^CC +=/s:=.*:= -D_MIPS_SZPTR=64:' mips64/n64/Makefile || die
+ popd >/dev/null
+ fi
+
local myconf=()
myconf+=(
--disable-sanity-checks