summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarl Trygve Kalleberg <karltk@gentoo.org>2001-11-02 14:03:13 +0000
committerKarl Trygve Kalleberg <karltk@gentoo.org>2001-11-02 14:03:13 +0000
commitc8e9db1d3101a20f4473440a89e4426831bcb8ae (patch)
treedc439f4c44be9d15ab3d71cbce6d24b96cd83c16 /sys-libs/db
parentJust an update (diff)
downloadgentoo-2-c8e9db1d3101a20f4473440a89e4426831bcb8ae.tar.gz
gentoo-2-c8e9db1d3101a20f4473440a89e4426831bcb8ae.tar.bz2
gentoo-2-c8e9db1d3101a20f4473440a89e4426831bcb8ae.zip
First attempt at packagin db-3.3.11; it appears to work, but it _really_ needs testing
Diffstat (limited to 'sys-libs/db')
-rw-r--r--sys-libs/db/db-3.3.11.ebuild35
-rw-r--r--sys-libs/db/files/digest-db-3.3.111
2 files changed, 36 insertions, 0 deletions
diff --git a/sys-libs/db/db-3.3.11.ebuild b/sys-libs/db/db-3.3.11.ebuild
new file mode 100644
index 000000000000..6e11346e3331
--- /dev/null
+++ b/sys-libs/db/db-3.3.11.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-3.3.11.ebuild,v 1.1 2001/11/02 14:03:13 karltk Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Berkeley DB"
+
+SRC_URI="http://www.sleepycat.com/update/3.3.11/db-3.3.11.tar.gz"
+
+HOMEPAGE="http://www.sleepycat.com"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ cd dist
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install () {
+ cd dist
+
+ make prefix=${D}/usr install || die
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/docs/* ${D}/usr/share/doc/${PF}/html/
+}
diff --git a/sys-libs/db/files/digest-db-3.3.11 b/sys-libs/db/files/digest-db-3.3.11
new file mode 100644
index 000000000000..926b35f3c279
--- /dev/null
+++ b/sys-libs/db/files/digest-db-3.3.11
@@ -0,0 +1 @@
+MD5 b6ae24fa55713f17a9ac3219d987722c db-3.3.11.tar.gz