summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-09-01 18:43:05 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-09-01 18:43:05 +0000
commit9cc2bd4dd2ba05f463dc0d1ce81e2ec0dfd51911 (patch)
tree3d45f5e6182f4f7b7a85e7f7710e3122a058e5a6 /sys-libs/db/db-1.85-r2.ebuild
parentEbuild cleanup to use epatch and not abuse sed. (diff)
downloadgentoo-2-9cc2bd4dd2ba05f463dc0d1ce81e2ec0dfd51911.tar.gz
gentoo-2-9cc2bd4dd2ba05f463dc0d1ce81e2ec0dfd51911.tar.bz2
gentoo-2-9cc2bd4dd2ba05f463dc0d1ce81e2ec0dfd51911.zip
Clean up old db-1.8.5 build to not for omit-frame-pointer, and grab it's patch from DISTDIR.
Diffstat (limited to 'sys-libs/db/db-1.85-r2.ebuild')
-rw-r--r--sys-libs/db/db-1.85-r2.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/sys-libs/db/db-1.85-r2.ebuild b/sys-libs/db/db-1.85-r2.ebuild
new file mode 100644
index 000000000000..38e0f5b39e41
--- /dev/null
+++ b/sys-libs/db/db-1.85-r2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/db/db-1.85-r2.ebuild,v 1.3 2004/09/01 18:43:05 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="db 1.85 -- required for RPM 4.0 to compile; that's about it."
+HOMEPAGE="http://www.sleepycat.com/"
+SRC_URI="http://www.sleepycat.com/update/snapshot/db.${PV}.tar.gz
+ mirror://gentoo/db.${PV}.patch.gz"
+
+LICENSE="DB"
+SLOT="1"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~ia64 ~amd64 ~ppc64 ~s390"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/db.${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${DISTDIR}/db.${PV}.patch.gz
+}
+
+src_compile() {
+ cd ${S}/PORT/linux
+ make ${MAKEOPTS} OORG="${CFLAGS}" prefix=/usr || die
+}
+
+src_install () {
+ cd ${S}/PORT/linux
+
+ newlib.a libdb.a libdb1.a || die "newlib.a failed"
+ newlib.so libdb.so.2 libdb1.so.2 || die "newlib.so failed"
+ dosym libdb1.so.2 /usr/lib/libdb1.so
+ dosym libdb1.so.2 /usr/lib/libdb.so.2
+ dosym libdb1.so.2 /usr/lib/libndbm.so
+ dosym libdb1.a /usr/lib/libndbm.a
+
+ dodir /usr/include/db1
+ insinto /usr/include/db1
+ doins include/db.h include/mpool.h
+
+ insinto /usr/include/db1
+ doins include/ndbm.h
+ dosed "s:<db.h>:<db1/db.h>:" /usr/include/db1/ndbm.h
+ dosym db1/ndbm.h /usr/include/ndbm.h
+ newbin db_dump185 db1_dump185
+
+ cd ${S}
+ dodoc changelog README
+ docinto ps
+ dodoc docs/*.ps
+ docinto hash
+ dodoc hash/README
+}