summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-07-21 20:33:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-07-21 20:33:06 +0000
commitaf274e7062229347cdc797bd9bab034cbab1e8cb (patch)
tree5957d6cf21cf11b7cf30b277f9b00d19a1609ff3 /sys-libs/cracklib
parentadded info about possible configure failure. closes #57504 (Manifest recommit) (diff)
downloadgentoo-2-af274e7062229347cdc797bd9bab034cbab1e8cb.tar.gz
gentoo-2-af274e7062229347cdc797bd9bab034cbab1e8cb.tar.bz2
gentoo-2-af274e7062229347cdc797bd9bab034cbab1e8cb.zip
use emake - works fine; error check sed; tidy
Diffstat (limited to 'sys-libs/cracklib')
-rw-r--r--sys-libs/cracklib/ChangeLog5
-rw-r--r--sys-libs/cracklib/cracklib-2.7-r9.ebuild25
2 files changed, 19 insertions, 11 deletions
diff --git a/sys-libs/cracklib/ChangeLog b/sys-libs/cracklib/ChangeLog
index 4992c204d925..c96f38735ca3 100644
--- a/sys-libs/cracklib/ChangeLog
+++ b/sys-libs/cracklib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-libs/cracklib
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.48 2004/06/30 13:24:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.49 2004/07/21 20:33:06 mr_bones_ Exp $
+
+ 21 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> cracklib-2.7-r9.ebuild:
+ use emake - works fine; error check sed; tidy
30 Jun 2004; Aron Griffis <agriffis@gentoo.org> cracklib-2.7-r9.ebuild:
stable on alpha and ia64
diff --git a/sys-libs/cracklib/cracklib-2.7-r9.ebuild b/sys-libs/cracklib/cracklib-2.7-r9.ebuild
index 9880d3435c88..0038c165a5ca 100644
--- a/sys-libs/cracklib/cracklib-2.7-r9.ebuild
+++ b/sys-libs/cracklib/cracklib-2.7-r9.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r9.ebuild,v 1.8 2004/06/30 13:24:41 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r9.ebuild,v 1.9 2004/07/21 20:33:06 mr_bones_ Exp $
inherit flag-o-matic eutils
MY_P=${P/-/,}
-S=${WORKDIR}/${MY_P}
DESCRIPTION="Password Checking Library"
HOMEPAGE="http://www.crypticide.org/users/alecm/"
SRC_URI="http://www.crypticide.org/users/alecm/security/${MY_P}.tar.gz"
@@ -21,6 +20,8 @@ DEPEND="${RDEPEND}
uclibc? ( app-arch/gzip )
sys-devel/gcc-config"
+S="${WORKDIR}/${MY_P}"
+
src_unpack() {
unpack ${A}
@@ -32,26 +33,30 @@ src_unpack() {
# add compressed dict support, taken from shadow-4.0.4.1
use uclibc && epatch ${FILESDIR}/${PN}-${PV}-gzip.patch
- sed -e 's|/usr/dict/words|/usr/share/dict/words|' -i util/create-cracklib-dict
+ sed -i \
+ -e 's|/usr/dict/words|/usr/share/dict/words|' \
+ util/create-cracklib-dict \
+ || die "sed util/create-cracklib-dict failed"
- [ "${ARCH}" = "alpha" -a "${CC}" = "ccc" ] && \
- sed -i -e 's:CFLAGS += -g :CFLAGS += -g3 :' ${S}/cracklib/Makefile
+ if [ "${ARCH}" = "alpha" -a "${CC}" = "ccc" ] ; then
+ sed -i \
+ -e 's:CFLAGS += -g :CFLAGS += -g3 :' ${S}/cracklib/Makefile \
+ || die "sed ${S}/cracklib/Makefile failed"
+ fi
}
src_compile() {
- # filter-flags -fstack-protector
- # Parallel make does not work for 2.7
- make all || die
+ emake all || die "emake failed"
}
src_install() {
dodir /usr/{lib,sbin,include} /lib
keepdir /usr/share/cracklib
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die "make install failed"
# Needed by pam
- if ( [ ! -f "${D}/usr/lib/libcrack.a" ] && use pam )
+ if [ ! -f "${D}/usr/lib/libcrack.a" ] && use pam
then
eerror "Could not find libcrack.a which is needed by core components!"
die "Could not find libcrack.a which is needed by core components!"