summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2004-08-12 08:10:18 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2004-08-12 08:10:18 +0000
commit9f1d346b9159d0dc5dcf2f3c29e1bc30c86b89c1 (patch)
treef0a177fbd73fa286d03bd8e20690b15c2698972c /sys-libs/cracklib
parentFix mms/sse for non-amd64; error check sed; tidy (Manifest recommit) (diff)
downloadgentoo-2-9f1d346b9159d0dc5dcf2f3c29e1bc30c86b89c1.tar.gz
gentoo-2-9f1d346b9159d0dc5dcf2f3c29e1bc30c86b89c1.tar.bz2
gentoo-2-9f1d346b9159d0dc5dcf2f3c29e1bc30c86b89c1.zip
Fix bug #57984.
Diffstat (limited to 'sys-libs/cracklib')
-rw-r--r--sys-libs/cracklib/ChangeLog7
-rw-r--r--sys-libs/cracklib/Manifest14
-rw-r--r--sys-libs/cracklib/cracklib-2.7-r10.ebuild90
-rw-r--r--sys-libs/cracklib/files/digest-cracklib-2.7-r101
4 files changed, 105 insertions, 7 deletions
diff --git a/sys-libs/cracklib/ChangeLog b/sys-libs/cracklib/ChangeLog
index c96f38735ca3..2557d30d1963 100644
--- a/sys-libs/cracklib/ChangeLog
+++ b/sys-libs/cracklib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/cracklib
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.49 2004/07/21 20:33:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.50 2004/08/12 08:10:18 robbat2 Exp $
+
+*cracklib-2.7-r10 (12 Aug 2004)
+
+ 12 Aug 2004; Robin H. Johnson <robbat2@gentoo.org> +cracklib-2.7-r10.ebuild:
+ Fix bug #57984.
21 Jul 2004; Michael Sterrett <mr_bones_@gentoo.org> cracklib-2.7-r9.ebuild:
use emake - works fine; error check sed; tidy
diff --git a/sys-libs/cracklib/Manifest b/sys-libs/cracklib/Manifest
index e89d62b89f6a..645809c44c3e 100644
--- a/sys-libs/cracklib/Manifest
+++ b/sys-libs/cracklib/Manifest
@@ -1,13 +1,15 @@
-MD5 4987779df22bfecfe820b286d362618b ChangeLog 6721
MD5 41ca96772abc2be30cbf0d044587bc55 cracklib-2.7-r7.ebuild 1420
+MD5 fd781ff98a6d6d5e503fb670501dce62 cracklib-2.7-r9.ebuild 2504
MD5 31f59463369435ebcbb7f2ae10c154df cracklib-2.7-r8.ebuild 1694
+MD5 4987779df22bfecfe820b286d362618b ChangeLog 6721
+MD5 f16ee174bfb92edd87043054daf35474 cracklib-2.7-r10.ebuild 2509
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
-MD5 5262da5fa8bd20e14fbaff61a038312f cracklib-2.7-r9.ebuild 2336
+MD5 f27fad03a3939b6e405193b419b645a4 files/digest-cracklib-2.7-r10 63
MD5 85783b83e5bfa51190033895cfaf803e files/cracklib-2.7-dec-alpha-compiler.diff 333
-MD5 9c566d6a249f8d02ad419aac76fffd66 files/cracklib-2.7-gentoo-new.diff 4244
+MD5 336ab4f8ce8e3a3955ec8722d32076b4 files/cracklib-2.7-gzip.patch 521
MD5 954e8e0d53c6f878366e472a90917356 files/cracklib-2.7-redhat.patch 1224
-MD5 f27fad03a3939b6e405193b419b645a4 files/digest-cracklib-2.7-r9 63
-MD5 f27fad03a3939b6e405193b419b645a4 files/digest-cracklib-2.7-r7 63
MD5 cd32ee2bf36a5facd5b5eb5d99aa66ee files/cracklib-2.7-static-lib.patch 1346
+MD5 9c566d6a249f8d02ad419aac76fffd66 files/cracklib-2.7-gentoo-new.diff 4244
+MD5 f27fad03a3939b6e405193b419b645a4 files/digest-cracklib-2.7-r7 63
MD5 f27fad03a3939b6e405193b419b645a4 files/digest-cracklib-2.7-r8 63
-MD5 336ab4f8ce8e3a3955ec8722d32076b4 files/cracklib-2.7-gzip.patch 521
+MD5 f27fad03a3939b6e405193b419b645a4 files/digest-cracklib-2.7-r9 63
diff --git a/sys-libs/cracklib/cracklib-2.7-r10.ebuild b/sys-libs/cracklib/cracklib-2.7-r10.ebuild
new file mode 100644
index 000000000000..6cfc0892143a
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.7-r10.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.7-r10.ebuild,v 1.1 2004/08/12 08:10:18 robbat2 Exp $
+
+inherit flag-o-matic eutils
+
+MY_P=${P/-/,}
+DESCRIPTION="Password Checking Library"
+HOMEPAGE="http://www.crypticide.org/users/alecm/"
+SRC_URI="http://www.crypticide.org/users/alecm/security/${MY_P}.tar.gz"
+
+LICENSE="CRACKLIB"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+IUSE="pam uclibc"
+
+RDEPEND="sys-apps/miscfiles
+ >=sys-apps/portage-2.0.47-r10"
+DEPEND="${RDEPEND}
+ uclibc? ( app-arch/gzip )
+ sys-devel/gcc-config"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-redhat.patch
+ epatch ${FILESDIR}/${P}-gentoo-new.diff
+ epatch ${FILESDIR}/${P}-static-lib.patch
+
+ # add compressed dict support, taken from shadow-4.0.4.1
+ use uclibc && epatch ${FILESDIR}/${PN}-${PV}-gzip.patch
+
+ sed -i \
+ -e 's|/usr/dict/words|/usr/share/dict/words|' \
+ util/create-cracklib-dict \
+ || die "sed util/create-cracklib-dict failed"
+
+ if [ "${ARCH}" = "alpha" -a "${CC}" = "ccc" ] ; then
+ sed -i \
+ -e 's:CFLAGS += -g :CFLAGS += -g3 :' ${S}/cracklib/Makefile \
+ || die "sed ${S}/cracklib/Makefile failed"
+ fi
+}
+
+src_compile() {
+ emake all || die "emake failed"
+}
+
+src_install() {
+ dodir /usr/{lib,sbin,include} /lib
+ keepdir /usr/share/cracklib
+
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # Needed by pam
+ if [ ! -f "${D}/usr/lib/libcrack.a" ] && use pam
+ then
+ eerror "Could not find libcrack.a which is needed by core components!"
+ die "Could not find libcrack.a which is needed by core components!"
+ fi
+
+ # correct permissions on static lib
+ [ -x ${D}/usr/lib/libcrack.a ] && fperms 644 usr/lib/libcrack.a
+
+ # put libcrack.so.2.7 in /lib for cases where /usr isn't available yet
+ mv ${D}/usr/lib/libcrack.so* ${D}/lib
+
+ # This link is needed and not created. :| bug #9611
+ cd ${D}/lib
+ dosym libcrack.so.2.7 /lib/libcrack.so.2
+
+ ## remove it, if not needed
+ ##use pam || rm -f ${D}/usr/lib/libcrack.a
+ # actually keep it, so other things can link against it if required and
+ # it's possible that pam is NOT in the USE flag at the time, and will be
+ # later on only.
+
+ cd ${S}
+
+ cp ${S}/cracklib/packer.h ${D}/usr/include
+ #fix the permissions on it as they may be wrong in some cases
+ fperms 644 usr/include/packer.h
+
+ preplib /usr/lib /lib
+
+ dodoc HISTORY LICENCE MANIFEST POSTER README
+}
diff --git a/sys-libs/cracklib/files/digest-cracklib-2.7-r10 b/sys-libs/cracklib/files/digest-cracklib-2.7-r10
new file mode 100644
index 000000000000..12a9da188d95
--- /dev/null
+++ b/sys-libs/cracklib/files/digest-cracklib-2.7-r10
@@ -0,0 +1 @@
+MD5 0c84ad7413d9dd3e5c2eaa5f97d53c4a cracklib,2.7.tar.gz 21059