summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-06-02 15:23:47 +0000
committerMike Frysinger <vapier@gentoo.org>2013-06-02 15:23:47 +0000
commit33e8ebfb6d8703aaa39668f12c44b6dda3cefbee (patch)
tree111a9fd707c5f9caabd4849a98a5d4dff83442d6 /sys-libs/cracklib
parentUpdate HOMEPAGE, bug #472080. (diff)
downloadgentoo-2-33e8ebfb6d8703aaa39668f12c44b6dda3cefbee.tar.gz
gentoo-2-33e8ebfb6d8703aaa39668f12c44b6dda3cefbee.tar.bz2
gentoo-2-33e8ebfb6d8703aaa39668f12c44b6dda3cefbee.zip
Version bump.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-libs/cracklib')
-rw-r--r--sys-libs/cracklib/ChangeLog9
-rw-r--r--sys-libs/cracklib/cracklib-2.9.0.ebuild105
2 files changed, 112 insertions, 2 deletions
diff --git a/sys-libs/cracklib/ChangeLog b/sys-libs/cracklib/ChangeLog
index 06e2a5fc1ecf..4f29c2fac87e 100644
--- a/sys-libs/cracklib/ChangeLog
+++ b/sys-libs/cracklib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/cracklib
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.175 2012/12/21 03:42:12 vapier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/ChangeLog,v 1.176 2013/06/02 15:23:47 vapier Exp $
+
+*cracklib-2.9.0 (02 Jun 2013)
+
+ 02 Jun 2013; Mike Frysinger <vapier@gentoo.org> +cracklib-2.9.0.ebuild:
+ Version bump.
*cracklib-2.8.22 (21 Dec 2012)
diff --git a/sys-libs/cracklib/cracklib-2.9.0.ebuild b/sys-libs/cracklib/cracklib-2.9.0.ebuild
new file mode 100644
index 000000000000..75d06e6457ea
--- /dev/null
+++ b/sys-libs/cracklib/cracklib-2.9.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/cracklib/cracklib-2.9.0.ebuild,v 1.1 2013/06/02 15:23:47 vapier Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* 2.7-pypy-* *-jython"
+
+inherit eutils distutils libtool toolchain-funcs
+
+MY_P=${P/_}
+DESCRIPTION="Password Checking Library"
+HOMEPAGE="http://sourceforge.net/projects/cracklib"
+SRC_URI="mirror://sourceforge/cracklib/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="build nls python static-libs zlib"
+
+RDEPEND="zlib? ( sys-libs/zlib )"
+DEPEND="${RDEPEND}
+ python? ( dev-python/setuptools )"
+
+S=${WORKDIR}/${MY_P}
+
+PYTHON_MODNAME="cracklib.py"
+do_python() {
+ use build && return 0
+ use python || return 0
+ case ${EBUILD_PHASE} in
+ prepare|configure|compile|install)
+ pushd python > /dev/null || die
+ distutils_src_${EBUILD_PHASE}
+ popd > /dev/null
+ ;;
+ *)
+ distutils_pkg_${EBUILD_PHASE}
+ ;;
+ esac
+}
+
+pkg_setup() {
+ # workaround #195017
+ if has unmerge-orphans ${FEATURES} && has_version "<${CATEGORY}/${PN}-2.8.10" ; then
+ eerror "Upgrade path is broken with FEATURES=unmerge-orphans"
+ eerror "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ die "Please run: FEATURES=-unmerge-orphans emerge cracklib"
+ fi
+
+ if use !build; then
+ use python && python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ elibtoolize #269003
+ do_python
+}
+
+src_configure() {
+ export ac_cv_header_zlib_h=$(usex zlib)
+ export ac_cv_search_gzopen=$(usex zlib -lz no)
+ econf \
+ --with-default-dict='$(libdir)/cracklib_dict' \
+ --without-python \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ default
+ do_python
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ use static-libs || find "${ED}"/usr -name libcrack.la -delete
+ rm -r "${ED}"/usr/share/cracklib
+
+ do_python
+
+ # move shared libs to /
+ gen_usr_ldscript -a crack
+
+ insinto /usr/share/dict
+ doins dicts/cracklib-small || die
+
+ dodoc AUTHORS ChangeLog NEWS README*
+}
+
+pkg_postinst() {
+ if [[ ${ROOT} == "/" ]] ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
+ eend $?
+ fi
+
+ do_python
+}
+
+pkg_postrm() {
+ do_python
+}