summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-10-02 18:11:00 +0000
committerMike Frysinger <vapier@gentoo.org>2008-10-02 18:11:00 +0000
commit5ead4d11b0c5e1ed6a60dd97dce9b4906192db71 (patch)
treec24f9e086b3672562973bd492fd450483fe5ef1a /sys-libs/com_err
parentStable for HPPA (bug #239301). (diff)
downloadgentoo-2-5ead4d11b0c5e1ed6a60dd97dce9b4906192db71.tar.gz
gentoo-2-5ead4d11b0c5e1ed6a60dd97dce9b4906192db71.tar.bz2
gentoo-2-5ead4d11b0c5e1ed6a60dd97dce9b4906192db71.zip
old
(Portage version: 2.2_rc8/cvs/Linux 2.6.26.2 x86_64)
Diffstat (limited to 'sys-libs/com_err')
-rw-r--r--sys-libs/com_err/com_err-1.40.10.ebuild79
-rw-r--r--sys-libs/com_err/com_err-1.40.4.ebuild79
-rw-r--r--sys-libs/com_err/com_err-1.40.6.ebuild79
-rw-r--r--sys-libs/com_err/com_err-1.40.8.ebuild79
-rw-r--r--sys-libs/com_err/files/com_err-1.40-headers.patch10
5 files changed, 0 insertions, 326 deletions
diff --git a/sys-libs/com_err/com_err-1.40.10.ebuild b/sys-libs/com_err/com_err-1.40.10.ebuild
deleted file mode 100644
index 0c3c37210a52..000000000000
--- a/sys-libs/com_err/com_err-1.40.10.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.40.10.ebuild,v 1.2 2008/08/26 18:44:03 gentoofan23 Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="common error display library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="!sys-libs/e2fsprogs-libs"
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/bc"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- $(use_enable nls) \
- || die
- emake -C lib/et || die
-}
-
-src_test() {
- make -C lib/et check || die "make check failed"
-}
-
-src_install() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- emake -C lib/et DESTDIR="${D}" install || die
- dosed '/^ET_DIR=/s:=.*:=/usr/share/et:' /usr/bin/compile_et
- dosym et/com_err.h /usr/include/com_err.h
-
- dolib.a lib/libcom_err.a || die "dolib.a"
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*$(get_libname)* "${D}"/$(get_libdir)/ || die "move $(get_libname)"
- gen_usr_ldscript libcom_err$(get_libname)
-}
-
-pkg_postinst() {
- echo
- ewarn "PLEASE PLEASE take note of this"
- ewarn "Please make *sure* to run revdep-rebuild now."
- ewarn "Certain things on your system may have linked against a different"
- ewarn "version of com_err -- those things need to be recompiled."
- ewarn "Sorry for the inconvenience"
- echo
- epause 10
- ebeep
-}
diff --git a/sys-libs/com_err/com_err-1.40.4.ebuild b/sys-libs/com_err/com_err-1.40.4.ebuild
deleted file mode 100644
index 7a69a44ce42f..000000000000
--- a/sys-libs/com_err/com_err-1.40.4.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.40.4.ebuild,v 1.9 2008/08/26 18:44:03 gentoofan23 Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="common error display library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="!sys-libs/e2fsprogs-libs"
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/bc"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- $(use_enable nls) \
- || die
- emake -C lib/et || die
-}
-
-src_test() {
- make -C lib/et check || die "make check failed"
-}
-
-src_install() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- make -C lib/et DESTDIR="${D}" install || die
- dosed '/^ET_DIR=/s:=.*:=/usr/share/et:' /usr/bin/compile_et
- dosym et/com_err.h /usr/include/com_err.h
-
- dolib.a lib/libcom_err.a || die "dolib.a"
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*$(get_libname)* "${D}"/$(get_libdir)/ || die "move $(get_libname)"
- gen_usr_ldscript libcom_err$(get_libname)
-}
-
-pkg_postinst() {
- echo
- ewarn "PLEASE PLEASE take note of this"
- ewarn "Please make *sure* to run revdep-rebuild now"
- ewarn "Certain things on your system may have linked against a"
- ewarn "different version of com_err -- those things need to be"
- ewarn "recompiled. Sorry for the inconvenience"
- echo
- epause 10
- ebeep
-}
diff --git a/sys-libs/com_err/com_err-1.40.6.ebuild b/sys-libs/com_err/com_err-1.40.6.ebuild
deleted file mode 100644
index 09d502cbe00a..000000000000
--- a/sys-libs/com_err/com_err-1.40.6.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.40.6.ebuild,v 1.7 2008/08/26 18:44:03 gentoofan23 Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="common error display library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="!sys-libs/e2fsprogs-libs"
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/bc"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- $(use_enable nls) \
- || die
- emake -C lib/et || die
-}
-
-src_test() {
- make -C lib/et check || die "make check failed"
-}
-
-src_install() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- make -C lib/et DESTDIR="${D}" install || die
- dosed '/^ET_DIR=/s:=.*:=/usr/share/et:' /usr/bin/compile_et
- dosym et/com_err.h /usr/include/com_err.h
-
- dolib.a lib/libcom_err.a || die "dolib.a"
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*$(get_libname)* "${D}"/$(get_libdir)/ || die "move $(get_libname)"
- gen_usr_ldscript libcom_err$(get_libname)
-}
-
-pkg_postinst() {
- echo
- ewarn "PLEASE PLEASE take note of this"
- ewarn "Please make *sure* to run revdep-rebuild now"
- ewarn "Certain things on your system may have linked against a"
- ewarn "different version of com_err -- those things need to be"
- ewarn "recompiled. Sorry for the inconvenience"
- echo
- epause 10
- ebeep
-}
diff --git a/sys-libs/com_err/com_err-1.40.8.ebuild b/sys-libs/com_err/com_err-1.40.8.ebuild
deleted file mode 100644
index 1a08f3c7d49f..000000000000
--- a/sys-libs/com_err/com_err-1.40.8.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/com_err/com_err-1.40.8.ebuild,v 1.9 2008/08/26 18:44:03 gentoofan23 Exp $
-
-inherit eutils flag-o-matic toolchain-funcs
-
-DESCRIPTION="common error display library"
-HOMEPAGE="http://e2fsprogs.sourceforge.net/"
-SRC_URI="mirror://sourceforge/e2fsprogs/e2fsprogs-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ~ppc ~ppc64 s390 sh ~sparc x86 ~x86-fbsd"
-IUSE="nls"
-
-RDEPEND="!sys-libs/e2fsprogs-libs"
-DEPEND="nls? ( sys-devel/gettext )
- sys-devel/bc"
-
-S=${WORKDIR}/e2fsprogs-${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/${PN}-1.39-makefile.patch
-}
-
-src_compile() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- # We want to use the "bsd" libraries while building on Darwin, but while
- # building on other Gentoo/*BSD we prefer elf-naming scheme.
- local libtype
- case ${CHOST} in
- *-darwin*) libtype=bsd;;
- *) libtype=elf;;
- esac
-
- econf \
- --enable-${libtype}-shlibs \
- --with-ldopts="${LDFLAGS}" \
- $(use_enable !elibc_uclibc tls) \
- $(use_enable nls) \
- || die
- emake -C lib/et || die
-}
-
-src_test() {
- make -C lib/et check || die "make check failed"
-}
-
-src_install() {
- export LDCONFIG=/bin/true
- export CC=$(tc-getCC)
- export STRIP=/bin/true
-
- emake -C lib/et DESTDIR="${D}" install || die
- dosed '/^ET_DIR=/s:=.*:=/usr/share/et:' /usr/bin/compile_et
- dosym et/com_err.h /usr/include/com_err.h
-
- dolib.a lib/libcom_err.a || die "dolib.a"
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*$(get_libname)* "${D}"/$(get_libdir)/ || die "move $(get_libname)"
- gen_usr_ldscript libcom_err$(get_libname)
-}
-
-pkg_postinst() {
- echo
- ewarn "PLEASE PLEASE take note of this"
- ewarn "Please make *sure* to run revdep-rebuild now"
- ewarn "Certain things on your system may have linked against a"
- ewarn "different version of com_err -- those things need to be"
- ewarn "recompiled. Sorry for the inconvenience"
- echo
- epause 10
- ebeep
-}
diff --git a/sys-libs/com_err/files/com_err-1.40-headers.patch b/sys-libs/com_err/files/com_err-1.40-headers.patch
deleted file mode 100644
index 79f3a55e0fee..000000000000
--- a/sys-libs/com_err/files/com_err-1.40-headers.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- lib/et/error_message.c
-+++ lib/et/error_message.c
-@@ -16,6 +16,7 @@
- * express or implied warranty.
- */
-
-+#include <unistd.h>
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>