summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2003-04-06 02:34:08 +0000
committerChristian Birchinger <joker@gentoo.org>2003-04-06 02:34:08 +0000
commitf9ee1ea3ef6d1cd5de2ccbf43d99cf0828e978ea (patch)
treebd9194c3c99046f4e7b34f283b03c7012079b208 /sys-kernel
parentRemoved temp antlr-2.7.2 mask now that it's working (diff)
downloadgentoo-2-f9ee1ea3ef6d1cd5de2ccbf43d99cf0828e978ea.tar.gz
gentoo-2-f9ee1ea3ef6d1cd5de2ccbf43d99cf0828e978ea.tar.bz2
gentoo-2-f9ee1ea3ef6d1cd5de2ccbf43d99cf0828e978ea.zip
New version with a very minor sparc32 kgcc detect update (no kernel-source changes)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/sparc-sources/ChangeLog9
-rw-r--r--sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r82
-rw-r--r--sys-kernel/sparc-sources/sparc-sources-2.4.20-r8.ebuild63
3 files changed, 73 insertions, 1 deletions
diff --git a/sys-kernel/sparc-sources/ChangeLog b/sys-kernel/sparc-sources/ChangeLog
index 7c75bdf37735..2fff09a82d53 100644
--- a/sys-kernel/sparc-sources/ChangeLog
+++ b/sys-kernel/sparc-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/sparc-sources
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.21 2003/04/02 00:16:34 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/ChangeLog,v 1.22 2003/04/06 02:34:08 joker Exp $
+
+*sparc-sources-2.4.20-r8 (06 Apr 2003)
+
+ 06 Apr 2003; Christian Birchinger <joker@gentoo.org>
+ sparc-sources-2.4.20-r8.ebuild:
+ New version with a very minor sparc32 kgcc detect update.
+ No kernel-source changes.
*sparc-sources-2.4.20-r7 (30 Mar 2003)
diff --git a/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r8 b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r8
new file mode 100644
index 000000000000..f3f8c4ebfe17
--- /dev/null
+++ b/sys-kernel/sparc-sources/files/digest-sparc-sources-2.4.20-r8
@@ -0,0 +1,2 @@
+MD5 c439d5c93d7fc9a1480a90842465bb97 linux-2.4.20.tar.bz2 27421046
+MD5 2b71a0b7d738ed53f39d60434085c90b patches-2.4.20-r8-sparc.tar.bz2 136619
diff --git a/sys-kernel/sparc-sources/sparc-sources-2.4.20-r8.ebuild b/sys-kernel/sparc-sources/sparc-sources-2.4.20-r8.ebuild
new file mode 100644
index 000000000000..bde71ab79355
--- /dev/null
+++ b/sys-kernel/sparc-sources/sparc-sources-2.4.20-r8.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/sparc-sources/sparc-sources-2.4.20-r8.ebuild,v 1.1 2003/04/06 02:34:08 joker Exp $
+
+IUSE="build ultra1"
+
+# OKV=original kernel version, KV=patched kernel version. They can be the
+# same.
+KV=${PV}
+
+# Kernel ebuilds using the kernel.eclass can remove any patch that you
+# do not want to apply by simply setting the KERNEL_EXCLUDE shell
+# variable to the string you want to exclude (for instance
+# KERNEL_EXCLUDE="evms" would not patch any patches whose names match
+# *evms*). Kernels are only tested in the default configuration, but
+# this may be useful if you know that a particular patch is causing a
+# conflict with a patch you personally want to apply, or some other
+# similar situation.
+
+# This kernel also has support for the local USE flag acpi4linux which
+# activates the latest code from acpi.sourceforge.net instead of the
+# very out of date vanilla version
+
+ETYPE="sources"
+
+inherit kernel || die
+
+# Documentation on the patches contained in this kernel will be installed
+# to /usr/share/doc/sparc-sources-${PV}/patches.txt.gz
+
+DESCRIPTION="Full sources for the Gentoo Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2
+ mirror://gentoo/patches-${PVR}-sparc.tar.bz2"
+KEYWORDS="~x86 -ppc ~sparc"
+SLOT="${KV}"
+
+src_unpack() {
+ unpack ${A}
+ mv linux-${OKV} linux-${KV} || die
+
+ cd ${KV}
+ # Kill patches we aren't suppposed to use, don't worry about
+ # failures, if they aren't there that is a good thing!
+
+ kernel_src_unpack
+
+ # Patch the HME driver only on Ultra1 machines.
+ use ultra1 && epatch ${FILESDIR}/U1-hme-lockup.patch
+}
+
+pkg_postinst() {
+ kernel_pkg_postinst
+
+ # Display SUN Ultra 1 HME warning if it can be detected or if the machinetype is unknown.
+ if [ ! -r "/proc/openprom/name" -o "`cat /proc/openprom/name 2>/dev/null`" = "'SUNW,Ultra-1'" ]; then
+ einfo
+ einfo "For users with an Enterprise model Ultra 1 using the HME network interface,"
+ einfo "please emerge the kernel using the following command:"
+ einfo
+ einfo "USE=ultra1 emerge sparc-sources"
+ einfo
+ fi
+}