summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2011-11-28 08:21:36 +0000
committerAlex Alexander <wired@gentoo.org>2011-11-28 08:21:36 +0000
commite698bd77b2b2e9265b85ce567513f9345fa8d6d2 (patch)
treee464390231b132d7b1919897669f4d645f0d2659 /sys-kernel
parentVersion bumped. Bug #391801 (diff)
downloadgentoo-2-e698bd77b2b2e9265b85ce567513f9345fa8d6d2.tar.gz
gentoo-2-e698bd77b2b2e9265b85ce567513f9345fa8d6d2.tar.bz2
gentoo-2-e698bd77b2b2e9265b85ce567513f9345fa8d6d2.zip
version bump
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/pf-sources/ChangeLog7
-rw-r--r--sys-kernel/pf-sources/pf-sources-3.1.3.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sys-kernel/pf-sources/ChangeLog b/sys-kernel/pf-sources/ChangeLog
index 6dcd45cdf5e5..a7bcced07c81 100644
--- a/sys-kernel/pf-sources/ChangeLog
+++ b/sys-kernel/pf-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/pf-sources
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.40 2011/11/24 19:07:12 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/ChangeLog,v 1.41 2011/11/28 08:21:36 wired Exp $
+
+*pf-sources-3.1.3 (28 Nov 2011)
+
+ 28 Nov 2011; Alex Alexander <wired@gentoo.org> +pf-sources-3.1.3.ebuild:
+ version bump
*pf-sources-3.1.2 (24 Nov 2011)
diff --git a/sys-kernel/pf-sources/pf-sources-3.1.3.ebuild b/sys-kernel/pf-sources/pf-sources-3.1.3.ebuild
new file mode 100644
index 000000000000..d1a96256250c
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-3.1.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/pf-sources/pf-sources-3.1.3.ebuild,v 1.1 2011/11/28 08:21:36 wired Exp $
+
+EAPI="2"
+
+inherit versionator
+
+COMPRESSTYPE=".bz2"
+K_USEPV="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+
+CKV="$(get_version_component_range 1-2)"
+ETYPE="sources"
+inherit kernel-2
+detect_version
+K_NOSETEXTRAVERSION="don't_set_it"
+
+DESCRIPTION="Linux kernel fork with new features, including the -ck patchset (BFS), BFQ, TuxOnIce and LinuxIMQ"
+HOMEPAGE="http://pf.natalenko.name/"
+
+PF_FILE="patch-${PV}-pf${COMPRESSTYPE}"
+PF_URI="http://pf.natalenko.name/sources/$(get_version_component_range 1-2)/${PF_FILE}"
+EXPERIMENTAL_PATCHES=(
+ # http://ck-hack.blogspot.com/2010/11/create-task-groups-by-tty-comment.html
+ # http://ck.kolivas.org/patches/bfs/bfs357-penalise_fork_depth_account_threads.patch
+)
+EXPERIMENTAL_URI="
+ experimental? (
+ ${EXPERIMENTAL_PATCHES[@]}
+ )
+"
+SRC_URI="${KERNEL_URI} ${PF_URI}" # \${EXPERIMENTAL_URI}
+
+KEYWORDS="-* ~amd64 ~ppc ~ppc64 ~x86"
+IUSE="" # experimental
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}"/linux-"${KV_FULL}"
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare(){
+ epatch "${DISTDIR}"/"${PF_FILE}"
+ #if use experimental; then
+ #for patch in ${EXPERIMENTAL_PATCHES[@]}; do
+ #epatch "${DISTDIR}"/"${patch/*\/}"
+ #done
+ #fi
+}
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems, see: \
+${HOMEPAGE}."