summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2002-09-18 18:25:56 +0000
committerMichael Imhof <tantive@gentoo.org>2002-09-18 18:25:56 +0000
commitd9e11e81eb1faae8fa12092cff074518dd23c251 (patch)
tree822a53421e920dc6738b38152552a746fb08070a /sys-kernel
parentVersion bumped, includes openmosix-2.4.19-4 and evms 1.1.0 (diff)
downloadgentoo-2-d9e11e81eb1faae8fa12092cff074518dd23c251.tar.gz
gentoo-2-d9e11e81eb1faae8fa12092cff074518dd23c251.tar.bz2
gentoo-2-d9e11e81eb1faae8fa12092cff074518dd23c251.zip
Version bumped, includes openmosix-2.4.19-4 and evms 1.1.0
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/openmosix-sources/ChangeLog7
-rw-r--r--sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r5.ebuild111
2 files changed, 117 insertions, 1 deletions
diff --git a/sys-kernel/openmosix-sources/ChangeLog b/sys-kernel/openmosix-sources/ChangeLog
index ee465514cefb..5974881ae375 100644
--- a/sys-kernel/openmosix-sources/ChangeLog
+++ b/sys-kernel/openmosix-sources/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-kernel/openmosix-sources
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/ChangeLog,v 1.7 2002/09/16 19:58:14 tantive Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/ChangeLog,v 1.8 2002/09/18 18:25:56 tantive Exp $
+
+*openmosix-sources-2.4.19-r5 (18 Sep 2002)
+
+ 18 Sep 2002; Michael Imhof <tantive@gentoo.org>
+ Version bumped: Including openmosix-2.4.19-4 and evms 1.1.0 (and the gcc3 compile patch).
*openmosix-sources-2.4.18-r5 (16 Sep 2002)
diff --git a/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r5.ebuild b/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r5.ebuild
new file mode 100644
index 000000000000..1be049e3b10a
--- /dev/null
+++ b/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r5.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/openmosix-sources/openmosix-sources-2.4.19-r5.ebuild,v 1.1 2002/09/18 18:25:56 tantive Exp $
+#OKV=original kernel version, KV=patched kernel version. They can be the same.
+
+#we use this next variable to avoid duplicating stuff on cvs
+GFILESDIR=${PORTDIR}/sys-kernel/linux-sources/files
+OKV=2.4.19
+KV=2.4.19-openmosix-r5
+S=${WORKDIR}/linux-${KV}
+ETYPE="sources"
+
+# What's in this kernel?
+
+# INCLUDED:
+# 2.4.19, plus:
+# 2.4.19 openmosix-2.4.19-4
+# 2.4.19 evms-1.1.0 (evms-linux-2.4.19-common-files, evms-1.1.0-linux-2.4.patch, linux-2.4.19.VFS-lock.patch)
+# for gcc3 there is a patch applied that let's you compile this kernel with gcc3.
+
+DESCRIPTION="Full sources for the Gentoo openMosix Linux kernel"
+SRC_URI="http://www.kernel.org/pub/linux/kernel/v2.4/linux-${OKV}.tar.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}.patch.bz2 http://www.ibiblio.org/gentoo/distfiles/linux-gentoo-${KV}-gcc3.patch.bz2"
+PROVIDE="virtual/linux-sources"
+HOMEPAGE="http://www.kernel.org/ http://www.gentoo.org/ http://www.openmosix.org/"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+DEPEND="<sys-devel/gcc-3"
+
+
+if [ $ETYPE = "sources" ] && [ -z "`use build`" ]
+then
+ #console-tools is needed to solve the loadkeys fiasco; binutils version needed to avoid Athlon/PIII/SSE assembler bugs.
+ DEPEND=">=sys-devel/binutils-2.11.90.0.31"
+ RDEPEND=">=sys-libs/ncurses-5.2 sys-devel/perl >=sys-apps/modutils-2.4.2 sys-devel/make"
+fi
+
+[ -z "$LINUX_HOSTCFLAGS" ] && LINUX_HOSTCFLAGS="-Wall -Wstrict-prototypes -O2 -fomit-frame-pointer -I${S}/include"
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack linux-${OKV}.tar.bz2
+ mv linux-${OKV} linux-${KV} || die
+ cd ${S}
+ cat ${DISTDIR}/linux-gentoo-${KV}.patch.bz2 | bzip2 -d | patch -p1 || die
+
+ #if the used gcc is gcc3 there is a seperate patch applied.
+ if [ `gcc -dumpversion | cut -d. -f1` == 3 ]; then
+ cat ${DISTDIR}/linux-gentoo-${KV}-gcc3.patch.bzip2 | bzip2 -d | patch -p1 || die
+ fi
+
+ #sometimes we have icky kernel symbols; this seems to get rid of them
+ make mrproper || die
+
+ #this file is required for other things to build properly, so we autogenerate it
+ make include/linux/version.h || die
+
+ #fix silly permissions in tarball
+ cd ${WORKDIR}
+ chown -R 0.0 *
+ chmod -R a+r-w+X,u+w *
+
+ # Gentoo Linux uses /boot, so fix 'make install' to work properly
+ cd ${S}
+ mv Makefile Makefile.orig
+ sed -e 's:#export\tINSTALL_PATH:export\tINSTALL_PATH:' \
+ Makefile.orig >Makefile || die # test, remove me if Makefile ok
+ rm Makefile.orig
+}
+
+src_compile() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ yes "" | make oldconfig
+ echo "Ignore any errors from the yes command above."
+ fi
+}
+
+src_install() {
+ if [ "$ETYPE" = "sources" ]
+ then
+ dodir /usr/src
+ echo ">>> Copying sources..."
+ mv ${WORKDIR}/* ${D}/usr/src
+ else
+ #linux-headers
+ dodir /usr/include/linux
+ cp -ax ${S}/include/linux/* ${D}/usr/include/linux
+ rm -rf ${D}/usr/include/linux/modules
+ dodir /usr/include/asm
+ cp -ax ${S}/include/asm-i386/* ${D}/usr/include/asm
+ fi
+}
+
+pkg_preinst() {
+ if [ "$ETYPE" = "headers" ]
+ then
+ [ -L ${ROOT}usr/include/linux ] && rm ${ROOT}usr/include/linux
+ [ -L ${ROOT}usr/include/asm ] && rm ${ROOT}usr/include/asm
+ true
+ fi
+}
+
+pkg_postinst() {
+ [ "$ETYPE" = "headers" ] && return
+ if [ ! -e ${ROOT}usr/src/linux ]
+ then
+ rm -f ${ROOT}usr/src/linux
+ ln -sf linux-${KV} ${ROOT}/usr/src/linux
+ fi
+}