summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-24 18:09:13 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-24 18:09:13 +0000
commitd7d6c2a4bf1a2d123487696dcd4e57107756a5d9 (patch)
tree771218f21627121d2f3695a0aa26a8504e0b45c2 /sys-kernel
parentUnmask ghc-7.4. (diff)
downloadgentoo-2-d7d6c2a4bf1a2d123487696dcd4e57107756a5d9.tar.gz
gentoo-2-d7d6c2a4bf1a2d123487696dcd4e57107756a5d9.tar.bz2
gentoo-2-d7d6c2a4bf1a2d123487696dcd4e57107756a5d9.zip
Based on 2.6.32.59 + genpatches-2.6.32-48 + grsecurity-2.9-2.6.32.59-201203221943
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/hardened-sources/ChangeLog9
-rw-r--r--sys-kernel/hardened-sources/hardened-sources-2.6.32-r96.ebuild51
2 files changed, 59 insertions, 1 deletions
diff --git a/sys-kernel/hardened-sources/ChangeLog b/sys-kernel/hardened-sources/ChangeLog
index 464b747baae9..4e3b0786680b 100644
--- a/sys-kernel/hardened-sources/ChangeLog
+++ b/sys-kernel/hardened-sources/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-kernel/hardened-sources
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.553 2012/03/21 20:33:37 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/ChangeLog,v 1.554 2012/03/24 18:09:13 blueness Exp $
+
+*hardened-sources-2.6.32-r96 (24 Mar 2012)
+
+ 24 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
+ +hardened-sources-2.6.32-r96.ebuild:
+ Based on 2.6.32.59 + genpatches-2.6.32-48 +
+ grsecurity-2.9-2.6.32.59-201203221943
21 Mar 2012; Anthony G. Basile <blueness@gentoo.org>
-hardened-sources-3.1.10.ebuild:
diff --git a/sys-kernel/hardened-sources/hardened-sources-2.6.32-r96.ebuild b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r96.ebuild
new file mode 100644
index 000000000000..0f07d9a40ac4
--- /dev/null
+++ b/sys-kernel/hardened-sources/hardened-sources-2.6.32-r96.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/hardened-sources/hardened-sources-2.6.32-r96.ebuild,v 1.1 2012/03/24 18:09:13 blueness Exp $
+
+EAPI="4"
+
+ETYPE="sources"
+K_WANT_GENPATCHES="base extras"
+K_GENPATCHES_VER="48"
+K_DEBLOB_AVAILABLE="1"
+
+inherit kernel-2
+detect_version
+
+HGPV="${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}-98"
+HGPV_URI="http://dev.gentoo.org/~blueness/hardened-sources/hardened-patches/hardened-patches-${HGPV}.extras.tar.bz2"
+SRC_URI="${KERNEL_URI} ${HGPV_URI} ${GENPATCHES_URI} ${ARCH_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/hardened-patches-${HGPV}.extras.tar.bz2"
+UNIPATCH_EXCLUDE="4200_fbcondecor-0.9.6.patch"
+
+DESCRIPTION="Hardened kernel sources (kernel series ${KV_MAJOR}.${KV_MINOR})"
+HOMEPAGE="http://www.gentoo.org/proj/en/hardened/"
+IUSE="deblob"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND=">=sys-devel/gcc-4.5"
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+
+ local GRADM_COMPAT="sys-apps/gradm-2.9*"
+
+ ewarn
+ ewarn "Hardened Gentoo provides three different predefined grsecurity level:"
+ ewarn "[server], [workstation], and [virtualization]."
+ ewarn
+ ewarn "Those who intend to use one of these predefined grsecurity levels"
+ ewarn "should read the help associated with the level. Users importing a"
+ ewarn "kernel configuration from a kernel prior to ${PN}-2.6.32,"
+ ewarn "should review their selected grsecurity/PaX options carefully."
+ ewarn
+ ewarn "Users of grsecurity's RBAC system must ensure they are using"
+ ewarn "${GRADM_COMPAT}, which is compatible with ${PF}."
+ ewarn "It is strongly recommended that the following command is issued"
+ ewarn "prior to booting a ${PF} kernel for the first time:"
+ ewarn
+ ewarn "emerge -na =${GRADM_COMPAT}"
+ ewarn
+}