summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-03-26 13:02:17 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-03-26 13:02:17 +0000
commitd464c143dbd5c691c70bc600e9507826b494bf41 (patch)
treec64d8f39152ae88b456627a3f3062a4fbba751be /sys-kernel
parentRemove old version (diff)
downloadgentoo-2-d464c143dbd5c691c70bc600e9507826b494bf41.tar.gz
gentoo-2-d464c143dbd5c691c70bc600e9507826b494bf41.tar.bz2
gentoo-2-d464c143dbd5c691c70bc600e9507826b494bf41.zip
sys-kernel/dracut-017: Fixes bug #409167 and bug #409177.
Fixes "inst_symlink will not create directory containing the symlink" (bug #409167) and adds new tiny feature - tmpdir option (bug #409177). (Portage version: 2.1.10.51/cvs/Linux x86_64)
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/dracut/ChangeLog10
-rw-r--r--sys-kernel/dracut/dracut-017-r2.ebuild272
-rw-r--r--sys-kernel/dracut/files/dracut-017-inst_symlink-parent-dir.patch45
-rw-r--r--sys-kernel/dracut/files/dracut-017-tmpdir-option.patch68
4 files changed, 394 insertions, 1 deletions
diff --git a/sys-kernel/dracut/ChangeLog b/sys-kernel/dracut/ChangeLog
index 6c3f1edda01c..eb023669925c 100644
--- a/sys-kernel/dracut/ChangeLog
+++ b/sys-kernel/dracut/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-kernel/dracut
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.54 2012/03/05 07:29:05 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/ChangeLog,v 1.55 2012/03/26 13:02:15 aidecoe Exp $
+
+*dracut-017-r2 (26 Mar 2012)
+
+ 26 Mar 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> +dracut-017-r2.ebuild,
+ +files/dracut-017-inst_symlink-parent-dir.patch,
+ +files/dracut-017-tmpdir-option.patch:
+ Fixes "inst_symlink will not create directory containing the symlink"
+ (bug #409167) and adds new tiny feature - tmpdir option (bug #409177).
05 Mar 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> dracut-017-r1.ebuild:
Warn if kernel config cannot be checked.
diff --git a/sys-kernel/dracut/dracut-017-r2.ebuild b/sys-kernel/dracut/dracut-017-r2.ebuild
new file mode 100644
index 000000000000..8b46d4cd6769
--- /dev/null
+++ b/sys-kernel/dracut/dracut-017-r2.ebuild
@@ -0,0 +1,272 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/dracut/dracut-017-r2.ebuild,v 1.1 2012/03/26 13:02:17 aidecoe Exp $
+
+EAPI=4
+
+inherit eutils linux-info
+
+add_req_use_for() {
+ local dep="$1"; shift
+ local f
+
+ for f in "$@"; do
+ REQUIRED_USE+="${f}? ( ${dep} )
+"
+ done
+}
+
+DESCRIPTION="Generic initramfs generation tool"
+HOMEPAGE="http://dracut.wiki.kernel.org"
+SRC_URI="mirror://kernel/linux/utils/boot/${PN}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="dracut_modules_crypt-gpg? ( dracut_modules_crypt )
+ dracut_modules_livenet? ( dracut_modules_dmsquash-live )
+ "
+COMMON_MODULES="
+ dracut_modules_biosdevname
+ dracut_modules_btrfs
+ dracut_modules_caps
+ dracut_modules_crypt-gpg
+ dracut_modules_gensplash
+ dracut_modules_mdraid
+ dracut_modules_multipath
+ dracut_modules_plymouth
+ dracut_modules_syslog
+ "
+DM_MODULES="
+ dracut_modules_crypt
+ dracut_modules_dmraid
+ dracut_modules_dmsquash-live
+ dracut_modules_livenet
+ dracut_modules_lvm
+ "
+NETWORK_MODULES="
+ dracut_modules_iscsi
+ dracut_modules_livenet
+ dracut_modules_nbd
+ dracut_modules_nfs
+ dracut_modules_ssh-client
+ "
+add_req_use_for device-mapper ${DM_MODULES}
+add_req_use_for net ${NETWORK_MODULES}
+IUSE_DRACUT_MODULES="${COMMON_MODULES} ${DM_MODULES} ${NETWORK_MODULES}"
+IUSE="debug device-mapper net selinux ${IUSE_DRACUT_MODULES}"
+
+RESTRICT="test"
+
+RDEPEND="
+ >=app-shells/bash-4.0
+ >=app-shells/dash-0.5.4.11
+ >=sys-apps/baselayout-1.12.14-r1
+ >=sys-apps/sysvinit-2.87-r3
+ >=sys-apps/util-linux-2.20
+ >=sys-fs/udev-164
+ app-arch/cpio
+ || ( >=sys-apps/module-init-tools-3.8 >sys-apps/kmod-5[tools] )
+
+ debug? ( dev-util/strace )
+ device-mapper? ( || ( sys-fs/device-mapper >=sys-fs/lvm2-2.02.33 ) )
+ net? ( net-misc/curl >=net-misc/dhcp-4.2.1-r1 sys-apps/iproute2 )
+ selinux? ( sys-libs/libselinux sys-libs/libsepol )
+ dracut_modules_biosdevname? ( sys-apps/biosdevname )
+ dracut_modules_btrfs? ( sys-fs/btrfs-progs )
+ dracut_modules_caps? ( sys-libs/libcap )
+ dracut_modules_crypt? ( sys-fs/cryptsetup )
+ dracut_modules_crypt-gpg? ( app-crypt/gnupg )
+ dracut_modules_dmraid? ( sys-fs/dmraid sys-fs/multipath-tools )
+ dracut_modules_gensplash? ( media-gfx/splashutils )
+ dracut_modules_iscsi? ( >=sys-block/open-iscsi-2.0.871.3 )
+ dracut_modules_lvm? ( >=sys-fs/lvm2-2.02.33 )
+ dracut_modules_mdraid? ( sys-fs/mdadm )
+ dracut_modules_multipath? ( sys-fs/multipath-tools )
+ dracut_modules_nbd? ( sys-block/nbd )
+ dracut_modules_nfs? ( net-fs/nfs-utils net-nds/rpcbind )
+ dracut_modules_plymouth? ( >=sys-boot/plymouth-0.8.3-r1 )
+ dracut_modules_ssh-client? ( dev-libs/openssl )
+ dracut_modules_syslog? ( || ( app-admin/syslog-ng app-admin/rsyslog ) )
+ "
+DEPEND="
+ >=dev-libs/libxslt-1.1.26
+ app-text/docbook-xml-dtd:4.5
+ >=app-text/docbook-xsl-stylesheets-1.75.2
+ "
+
+#
+# Helper functions
+#
+
+# Returns true if any of specified modules is enabled by USE flag and false
+# otherwise.
+# $1 = list of modules (which have corresponding USE flags of the same name)
+any_module() {
+ local m modules=" $@ "
+
+ for m in ${modules}; do
+ ! use $m && modules=${modules/ $m / }
+ done
+
+ shopt -s extglob
+ modules=${modules%%+( )}
+ shopt -u extglob
+
+ [[ ${modules} ]]
+}
+
+# Removes module from modules.d.
+# $1 = module name
+# Module name can be specified without number prefix.
+rm_module() {
+ local force m
+ [[ $1 = -f ]] && force=-f
+
+ for m in $@; do
+ if [[ $m =~ ^[0-9][0-9][^\ ]*$ ]]; then
+ rm ${force} --interactive=never -r "${modules_dir}"/$m
+ else
+ rm ${force} --interactive=never -r "${modules_dir}"/[0-9][0-9]$m
+ fi
+ done
+}
+
+# Displays Gentoo Base System major release number
+base_sys_maj_ver() {
+ local line
+
+ read line < /etc/gentoo-release
+ line=${line##* }
+ echo "${line%%.*}"
+}
+
+#
+# ebuild functions
+#
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-multipath-udev-rules.patch"
+ epatch "${FILESDIR}/${P}-usrmount-fstab-comments.patch"
+ epatch "${FILESDIR}/${P}-usrmount-newroot-etc-check.patch"
+ epatch "${FILESDIR}/${P}-convertfs-fix-check-for-usr-bin.patch"
+ epatch "${FILESDIR}/${P}-crypt-simplify-rd.luks.uuid-testing.patch"
+ epatch "${FILESDIR}/${P}-inst_symlink-parent-dir.patch"
+ epatch "${FILESDIR}/${P}-tmpdir-option.patch"
+}
+
+src_compile() {
+ emake WITH_SWITCH_ROOT=0
+}
+
+src_install() {
+ emake WITH_SWITCH_ROOT=0 \
+ prefix=/usr sysconfdir=/etc DESTDIR="${D}" \
+ install
+
+ local gen2conf
+
+ dodir /var/lib/dracut/overlay
+ dodoc HACKING TODO AUTHORS NEWS README*
+
+ case "$(base_sys_maj_ver)" in
+ 1) gen2conf=gentoo.conf ;;
+ 2) gen2conf=gentoo-openrc.conf ;;
+ *) die "Expected ver. 1 or 2 of Gentoo Base System (/etc/gentoo-release)."
+ esac
+
+ insinto /etc/dracut.conf.d
+ newins dracut.conf.d/${gen2conf}.example ${gen2conf}
+
+ insinto /etc/logrotate.d
+ newins dracut.logrotate dracut
+
+ #
+ # Modules
+ #
+ local module
+ modules_dir="${D}/usr/lib/dracut/modules.d"
+
+ echo "${PF}" > "${modules_dir}"/10rpmversion/dracut-version \
+ || die 'dracut-version failed'
+
+ # Remove modules not enabled by USE flags
+ for module in ${IUSE_DRACUT_MODULES} ; do
+ ! use ${module} && rm_module -f ${module#dracut_modules_}
+ done
+
+ # Those flags are specific, and even are corresponding to modules, they need
+ # to be declared as regular USE flags.
+ use debug || rm_module 95debug
+ use selinux || rm_module 98selinux
+
+ # Following flags define set of helper modules which are base dependencies
+ # for others and as so have no practical use, so remove these modules.
+ use device-mapper || rm_module 90dm
+ use net || rm_module 40network 45ifcfg 45url-lib
+
+ # Remove S/390 modules which are not tested at all
+ rm_module 95dasd 95dasd_mod 95zfcp 95znet
+
+ # Remove modules which won't work for sure
+ rm_module 95fcoe # no tools
+ # fips module depends on masked app-crypt/hmaccalc
+ rm_module 01fips 02fips-aesni
+
+ # Remove extra modules which go to future dracut-extras
+ rm_module 00bootchart 05busybox 97masterkey 98ecryptfs 98integrity
+}
+
+pkg_postinst() {
+ if linux-info_get_any_version && linux_config_src_exists; then
+ echo
+ ewarn "If the following test report contains a missing kernel"
+ ewarn "configuration option, you should reconfigure and rebuild your"
+ ewarn "kernel before booting image generated with this Dracut version."
+ echo
+
+ local CONFIG_CHECK="~BLK_DEV_INITRD ~DEVTMPFS ~MODULES"
+
+ # Kernel configuration options descriptions:
+ local desc_DEVTMPFS="Maintain a devtmpfs filesystem to mount at /dev"
+ local desc_BLK_DEV_INITRD="Initial RAM filesystem and RAM disk "\
+"(initramfs/initrd) support"
+ local desc_MODULES="Enable loadable module support"
+
+ local opt desc
+
+ # Generate ERROR_* variables for check_extra_config.
+ for opt in ${CONFIG_CHECK}; do
+ opt=${opt#\~}
+ desc=desc_${opt}
+ eval "local ERROR_${opt}='CONFIG_${opt}: \"${!desc}\"" \
+ "is missing and REQUIRED'"
+ done
+
+ check_extra_config
+ echo
+ else
+ echo
+ ewarn "Your kernel configuration couldn't be checked. Do you have"
+ ewarn "/usr/src/linux/.config file there? Please check manually if"
+ ewarn "following options are enabled:"
+ ewarn ""
+ ewarn " CONFIG_BLK_DEV_INITRD"
+ ewarn " CONFIG_DEVTMPFS"
+ ewarn " CONFIG_MODULES"
+ echo
+ fi
+
+ elog 'To generate the initramfs:'
+ elog ' # mount /boot (if necessary)'
+ elog ' # dracut "" <kernel-version>'
+ elog ''
+ elog 'For command line documentation see dracut.kernel(7).'
+ elog ''
+ elog 'Simple example to select root and resume partition:'
+ elog ' root=/dev/sda1 resume=/dev/sda2'
+ elog ''
+ elog 'To include only dracut modules and kernel drivers for this system,'
+ elog 'use the "-H" option. Some modules need to be explicitly added with'
+ elog '"-a" option even if required tools are installed.'
+}
diff --git a/sys-kernel/dracut/files/dracut-017-inst_symlink-parent-dir.patch b/sys-kernel/dracut/files/dracut-017-inst_symlink-parent-dir.patch
new file mode 100644
index 000000000000..eb8da2fc4d20
--- /dev/null
+++ b/sys-kernel/dracut/files/dracut-017-inst_symlink-parent-dir.patch
@@ -0,0 +1,45 @@
+From f575da6f7ca80c97d0299878b13c71c67f22460f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Mon, 26 Mar 2012 00:03:57 +0200
+Subject: [PATCH] inst_symlink: create parent dir if doesn't exist
+
+If symlink is yet alone in target directory, inst_symlink will fail to
+create it. This is how to reproduce the bug:
+
+ # mkdir /tmp/test
+ # ln -s /bin/cp /tmp/test/cp
+ # ./dracut -l -f -H /tmp/test.img -I /tmp/test/cp
+
+Result:
+
+[...]
+
+I: *** Including modules done ***
+ln: failed to create symbolic link
+`/var/tmp/initramfs.Z5isVu//tmp/test/cp': No such file or directory
+ln: failed to create symbolic link
+`/var/tmp/initramfs.Z5isVu//tmp/test/cp': No such file or directory
+I: Wrote /tmp/test.img:
+
+[...]
+
+Following patch creates directory for the symlink if it doesn't exist.
+---
+ dracut-functions.sh | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/dracut-functions.sh b/dracut-functions.sh
+index f4ccf53..8082466 100755
+--- a/dracut-functions.sh
++++ b/dracut-functions.sh
+@@ -545,6 +545,7 @@ inst_symlink() {
+ inst "$_realsrc"
+ fi
+ fi
++ [[ ! -e $initdir/${_target%/*} ]] && inst_dir "${_target%/*}"
+ [[ -d ${_target%/*} ]] && _target=$(readlink -f ${_target%/*})/${_target##*/}
+ ln -sfn $(convert_abs_rel "${_target}" "${_realsrc}") "$initdir/$_target"
+ }
+--
+1.7.8.5
+
diff --git a/sys-kernel/dracut/files/dracut-017-tmpdir-option.patch b/sys-kernel/dracut/files/dracut-017-tmpdir-option.patch
new file mode 100644
index 000000000000..83d004d62b49
--- /dev/null
+++ b/sys-kernel/dracut/files/dracut-017-tmpdir-option.patch
@@ -0,0 +1,68 @@
+From decb1e033b26a1de80b452338ac7cff37a2471f5 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Amadeusz=20=C5=BBo=C5=82nowski?= <aidecoe@aidecoe.name>
+Date: Mon, 26 Mar 2012 13:29:07 +0200
+Subject: [PATCH 1/2] add --tmpdir option to cmd line args and tmpdir to
+ config file
+
+Default temporary directory used by Dracut is /var/tmp, but users might
+want to change it to /tmp.
+---
+ dracut.conf | 3 +++
+ dracut.sh | 9 +++++++--
+ 2 files changed, 10 insertions(+), 2 deletions(-)
+
+diff --git a/dracut.conf b/dracut.conf
+index a502066..e5fdd85 100644
+--- a/dracut.conf
++++ b/dracut.conf
+@@ -38,3 +38,6 @@ lvmconf="yes"
+
+ # inhibit installation of any fsck tools
+ #nofscks="yes"
++
++# temporary directory
++#tmpdir=/var/tmp
+diff --git a/dracut.sh b/dracut.sh
+index 1bf8ad9..5887131 100755
+--- a/dracut.sh
++++ b/dracut.sh
+@@ -80,6 +80,8 @@ Creates initial ramdisk images for preloading modules
+ Default: /etc/dracut.conf
+ --confdir [DIR] Specify configuration directory to use *.conf files
+ from. Default: /etc/dracut.conf.d
++ --tmpdir [DIR] Temporary directory to be used instead of default
++ /var/tmp.
+ -l, --local Local mode. Use modules from the current working
+ directory instead of the system-wide installed in
+ /usr/lib/dracut/modules.d.
+@@ -225,6 +227,7 @@ while (($# > 0)); do
+ -k|--kmoddir) read_arg drivers_dir_l "$@" || shift;;
+ -c|--conf) read_arg conffile "$@" || shift;;
+ --confdir) read_arg confdir "$@" || shift;;
++ --tmpdir) read_arg tmpdir_l "$@" || shift;;
+ -L|--stdlog) read_arg stdloglvl_l "$@" || shift;;
+ --compress) read_arg compress_l "$@" || shift;;
+ --prefix) read_arg prefix_l "$@" || shift;;
+@@ -411,6 +414,8 @@ stdloglvl=$((stdloglvl + verbosity_mod_l))
+ [[ $lvmconf_l ]] && lvmconf=$lvmconf_l
+ [[ $dracutbasedir ]] || dracutbasedir=/usr/lib/dracut
+ [[ $fw_dir ]] || fw_dir="/lib/firmware/updates /lib/firmware"
++[[ $tmpdir_l ]] && tmpdir="$tmpdir_l"
++[[ $tmpdir ]] || tmpdir=/var/tmp
+ [[ $do_strip ]] || do_strip=no
+ [[ $compress_l ]] && compress=$compress_l
+ [[ $show_modules_l ]] && show_modules=$show_modules_l
+@@ -544,8 +549,8 @@ elif [[ -f "$outfile" && ! -w "$outfile" ]]; then
+ exit 1
+ fi
+
+-readonly TMPDIR=/var/tmp
+-readonly initdir=$(mktemp --tmpdir=/var/tmp/ -d -t initramfs.XXXXXX)
++readonly TMPDIR="$tmpdir"
++readonly initdir=$(mktemp --tmpdir="$TMPDIR/" -d -t initramfs.XXXXXX)
+ [ -d "$initdir" ] || {
+ dfatal "mktemp failed."
+ exit 1
+--
+1.7.8.5
+